Unable to connect to windows share through nemo

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
tytonic
Level 1
Level 1
Posts: 9
Joined: Tue Apr 19, 2016 11:47 pm

Unable to connect to windows share through nemo

Postby tytonic » Wed Apr 20, 2016 12:12 am

I would like to thank you in advance for your help. I recently bought a new laptop and decided that with this purchase I would abandon Windows in favor of Linux. After some recommendations and testing I chose to Linux Mint 17.3, the 64 bit version with the Cinnamon desktop.

I have a windows share hosted on a Windows 7 computer which I have been using as my file server/NAS. The share is setup with read/write access for everyone in the network. I have been able to access the share from my laptop through the nemo file manager in the past either by browsing the network to the share or using "Connect to server . . ." in the file menu. This week, however, when I tried to access the share through either of the above methods I was prompted for login credentials and not given the option to connect as anonymous. I can still access the share as a guest from a Windows 10 machine without credentials and from another Linux Mint 17.3 machine through nemo without credentials. Further, I am able to mount the share on my laptop from the command line using "mount -t cifs //network_share_name /mount_point -o guest" and access the share without difficulty. Finally, I tried installing nautilus and accessing the share through it with the same results described above when using nemo.

Searching with google and the forums hasn't been successful. Any help and education would be appreciated.

User avatar
Spearmint2
Level 14
Level 14
Posts: 5457
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Unable to connect to windows share through nemo

Postby Spearmint2 » Wed Apr 20, 2016 12:31 am

Is this share on a partition that isn't mounted at startup, not in the fstab file? Have you mounted it in nemo first and then tried to access the share? Why haven't you made a bookmark for it? Isn't that available in nemo?
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

tytonic
Level 1
Level 1
Posts: 9
Joined: Tue Apr 19, 2016 11:47 pm

Re: Unable to connect to windows share through nemo

Postby tytonic » Wed Apr 20, 2016 7:53 am

The share is not in my fstab file, ie not mounted at startup. I am unable to mount it in nemo. Specifically, when I browse the network and double-click the computer with the share, I am prompted for login credentials, which, of course, I can't provide because it setup as a guest only share. I had not setup a bookmark for it when I had connected previously, and since I am unable to connect, nemo doesn't allow me to setup a bookmark now.

Thanks

Cosmo.
Level 22
Level 22
Posts: 16047
Joined: Sat Dec 06, 2014 7:34 am

Re: Unable to connect to windows share through nemo

Postby Cosmo. » Wed Apr 20, 2016 10:36 am

After you connected to the share with the terminal, try to run nemo /mount_point. What happens?

altair4
Level 18
Level 18
Posts: 8820
Joined: Tue Feb 03, 2009 10:27 am

Re: Unable to connect to windows share through nemo

Postby altair4 » Wed Apr 20, 2016 12:01 pm

Samba violated the #1 rule when issuing updates: They updated too many things at once which is going to make finding a workaround for what is clearly a bug very very difficult.

I would like you to run an experiment if you are agreeable:

Edit /etc/samba/smb.conf and under the "workgroup = workgroup" line add these two lines:

Code: Select all

client max protocol = SMB3
client ipc max protocol = NT1

Then restart smbd:

Code: Select all

sudo service smbd restart


See if you can now access the windows share.

Notes:

*** Setting "client max protocol" to SMB3 will disable browsing because of a years old bug that nobody wants to fix so you will have to use "Connect to Server" or enter the path ( as in smb://server/share ) in nemo to access the share.

*** All of the changes to how samba and smb.conf work have no impact on a CIFS mount because mount.cifs is unaware of the samba defaults and runs in it's own space. That's why a cifs mount works for you.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

tytonic
Level 1
Level 1
Posts: 9
Joined: Tue Apr 19, 2016 11:47 pm

Re: Unable to connect to windows share through nemo

Postby tytonic » Wed Apr 20, 2016 2:25 pm

Cosmo,
After mounting the share using the command line and then running

Code: Select all

nemo /mount_point
. Nemo opens with the share accessed. :) That is at least one work around for GUI access to my share

altair4,
I edited the samb.conf per your instructions and restarted the service. Unfortunately, I am still unable to connect to the share using the File -> Connect to server . . . or by typing smb://IP_address/share/ in the address bar inside nemo to connect to the share. I receive the same message requesting credentials.

Appreciate your time and input.

altair4
Level 18
Level 18
Posts: 8820
Joined: Tue Feb 03, 2009 10:27 am

Re: Unable to connect to windows share through nemo

Postby altair4 » Wed Apr 20, 2016 2:59 pm

What you could do until someone finds a fix for this thing is something like this:

If a manual mount like this works:
sudo mount -t cifs //server-name/share-name /mountpoint -o guest

[1] Umount the share if you are doing it manually.
[2] Create a mount point under /media - it has to be under /media or your home folder:

Code: Select all

sudo mkdir /media/WinShare

[3] Add a line to the end of /etc/fstab for that share:

Code: Select all

//server-name/share-name /media/WinShare cifs guest,noauto,user 0 0


You should immediately see an icon on your desktop and on the side panel of nemo that when selected will automatically mount that share to /media/WinShare.

If you right click the icon after it's mounted you can umount the share.

This will not automount the share but it will allow you to mount it on demand through nemo much like you were able to do before the update.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

User avatar
Spearmint2
Level 14
Level 14
Posts: 5457
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Unable to connect to windows share through nemo

Postby Spearmint2 » Wed Apr 20, 2016 3:09 pm

I would check how you have that shared again.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

Cosmo.
Level 22
Level 22
Posts: 16047
Joined: Sat Dec 06, 2014 7:34 am

Re: Unable to connect to windows share through nemo

Postby Cosmo. » Wed Apr 20, 2016 3:12 pm

tytonic wrote:After mounting the share using the command line and then running

Code: Select all

nemo /mount_point
. Nemo opens with the share accessed. :) That is at least one work around for GUI access to my share

Next step: You should now be able to create the already mentioned nemo bookmark. Question, can you afterwards use this bookmark without the workaround with the terminal?

tytonic
Level 1
Level 1
Posts: 9
Joined: Tue Apr 19, 2016 11:47 pm

Re: Unable to connect to windows share through nemo

Postby tytonic » Thu Apr 21, 2016 8:54 am

Thanks everyone for the help!

Spearmint2,
I checked the share settings again and found no issues. i am still able to browse the network and connect to the share from my desktop machine at home which is also running Mint Cinnamon 17.3 64-bit and from my Windows 10 machine. I wish I knew where to look for the difference between my Mint desktop and Mint laptop setup that is causing the problem.

altair4,
This works, but I have one question about this work around. The Windows 7 computer with the share does sleep to save power when not accessed or used for 20 min. Will using this work around interfere with the sleep function? Will I have to send a WOL packet manually before being about to mount the drive or will this keep the computer from sleeping?

Cosmo,
I tried editing the bookmarks manually

Code: Select all

sudo nano /home/user/.config/gtk-3.0/bookmarks

Added

Code: Select all

smb://network_share BookmarkName

Unfortunately, since this relys on samba it still doesn't work as I hoped

tytonic
Level 1
Level 1
Posts: 9
Joined: Tue Apr 19, 2016 11:47 pm

Re: Unable to connect to windows share through nemo

Postby tytonic » Thu Apr 21, 2016 8:54 am

Thanks everyone for the help!

Spearmint2,
I checked the share settings again and found no issues. i am still able to browse the network and connect to the share from my desktop machine at home which is also running Mint Cinnamon 17.3 64-bit and from my Windows 10 machine. I wish I knew where to look for the difference between my Mint desktop and Mint laptop setup that is causing the problem.

altair4,
This works, but I have one question about this work around. The Windows 7 computer with the share does sleep to save power when not accessed or used for 20 min. Will using this work around interfere with the sleep function? Will I have to send a WOL packet manually before being about to mount the drive or will this keep the computer from sleeping?

Cosmo,
I tried editing the bookmarks manually

Code: Select all

sudo nano /home/user/.config/gtk-3.0/bookmarks

Added

Code: Select all

smb://network_share BookmarkName

Unfortunately, since this relys on samba it still doesn't work as I hoped

altair4
Level 18
Level 18
Posts: 8820
Joined: Tue Feb 03, 2009 10:27 am

Re: Unable to connect to windows share through nemo

Postby altair4 » Thu Apr 21, 2016 9:07 am

tytonic wrote:altair4,
This works, but I have one question about this work around. The Windows 7 computer with the share does sleep to save power when not accessed or used for 20 min. Will using this work around interfere with the sleep function? Will I have to send a WOL packet manually before being about to mount the drive or will this keep the computer from sleeping?

Good question. Unfortunately I have no answer since I never tried it under those conditions.

Before Samba made a mess of things how did you manage this? When you accessed it through Network in Nemo did it interfere with things?
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

tytonic
Level 1
Level 1
Posts: 9
Joined: Tue Apr 19, 2016 11:47 pm

Re: Unable to connect to windows share through nemo

Postby tytonic » Thu Apr 21, 2016 10:09 am

altair4,
Previously, when i accessed the network in nemo I had to send a WOL packet before I could mount the share. I tried adding an automount previously to the fstab on my other Mint 17.3 machine and doing so prevented the windows 7 machine from sleeping. I will do some tests tonight.

Thanks again for the help.

Cosmo.
Level 22
Level 22
Posts: 16047
Joined: Sat Dec 06, 2014 7:34 am

Re: Unable to connect to windows share through nemo

Postby Cosmo. » Thu Apr 21, 2016 10:43 am

tytonic wrote:I tried editing the bookmarks manually

Code: Select all

sudo nano /home/user/.config/gtk-3.0/bookmarks

Why this? I ask in a double sense:
First: Why this circumstantial way, if you could do this inside nemo very easier?
Second: Why sudo? In case you should answer, that you cannot edit / create this file without privileged rights, there is something broken in your account.

User avatar
Spearmint2
Level 14
Level 14
Posts: 5457
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Unable to connect to windows share through nemo

Postby Spearmint2 » Thu Apr 21, 2016 12:42 pm

Cosmo. wrote:Why this? I ask in a double sense:
First: Why this circumstantial way, if you could do this inside nemo very easier?
Second: Why sudo? In case you should answer, that you cannot edit / create this file without privileged rights, there is something broken in your account.


Maybe he should run md5sum on the ISO he used to install it. A bad download will still install, but leave out some necessary file/s. If so, he'd need to get an ISO that works correctly, and do another install on top of the current one.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

tytonic
Level 1
Level 1
Posts: 9
Joined: Tue Apr 19, 2016 11:47 pm

Re: Unable to connect to windows share through nemo

Postby tytonic » Thu Apr 21, 2016 1:29 pm

Cosmo,
1. I tried this method of creating a bookmark previously. Before I mounted the drive from the terminal/fstab under /media it wasn't appearing in nemo and I was unable to create a bookmark from nemo. I tried editing the file directly to see if it would work as this is how the file was configured on my Mint desktop
2. You are correct I did not need sudo to edit that file.

Spearmint2,
I did an md5sum on the ISO I used for the install on my laptop.
Result
e71a2aad8b58605e906dbea444dc4983

MD5sum for ISO from linuxmint.com download page
e71a2aad8b58605e906dbea444dc4983

I must have installed or removed something at some point which made a change. Here are some programs I've installed or removed in the last couple weeks
In the last week:
avidemux - installed via the software center and removed the same way as it wasn't functioning as expected
openshot - installed via the software center. Working appropriately
vokoscreen - installed via software center and removed the same way
kazam - installed via software center
nautilus - installed via software center to test if this was a problem related to nemo. removed via software center

Prior to last week:
easytag - installed via the software center
ffmpeg - added ppa and installed via apt on CLI

I suppose I could try a fresh install. It may solve the problem but wouldn't help me find the cause

altair4
Level 18
Level 18
Posts: 8820
Joined: Tue Feb 03, 2009 10:27 am

Re: Unable to connect to windows share through nemo

Postby altair4 » Thu Apr 21, 2016 1:30 pm

Crikey,

Once upon a time the user was able to go through Network in Nemo or through Connect to Server and connect to his guest share in Win7 just fine.

Now all of sudden he cannot.

He can't use nemo to bookmark the networked location because he can't connect to the networked location in the first place. ( Why he edited the file as root is unknown - it would seem to me that his bookmark file is now owned by root - but that's another problem )

I made the assumption that he has kept his system up to date. If he runs:

Code: Select all

samba -V

And it comes back with this I'm wrong and his problem is something else:
Version 4.1.6-Ubuntu

If it comes back with:
Version 4.3.8-Ubuntu

Then he has fallen prey to what happens at Samba when the kids release a new version containing 8 separate "patches" while the parents are away at work.

What he is describing is a known bug.

All of these so called fixes apply to samba and smbclient and by extension the gvfs mount process that nemo uses to mount smb shares. Cifs is independent which is why it still works.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

User avatar
Spearmint2
Level 14
Level 14
Posts: 5457
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Unable to connect to windows share through nemo

Postby Spearmint2 » Thu Apr 21, 2016 2:06 pm

So altair, would you think a solution would be to uninstall both nemo and samba and then reinstall them?
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

altair4
Level 18
Level 18
Posts: 8820
Joined: Tue Feb 03, 2009 10:27 am

Re: Unable to connect to windows share through nemo

Postby altair4 » Thu Apr 21, 2016 2:36 pm

Now you're just messin' with me.

I have already offered a solution and that is connect using cifs. That works. The OP said it worked.

Reinstalling samba won't fix the problem it is the problem. Samba was released broken so only Samba can fix it. As soon as mum and dad come home from work at the Samba household maybe they can figure out what happened. But they better hurry up the bug reports are mounting.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

tytonic
Level 1
Level 1
Posts: 9
Joined: Tue Apr 19, 2016 11:47 pm

[Solved] Unable to connect to windows share through nemo

Postby tytonic » Thu Apr 21, 2016 3:46 pm

Code: Select all

samba -V

returns

Code: Select all

Version 4.3.8-Ubuntu


Thanks again for the help. The cifs option works fine for now until samba is updated


Return to “Newbie Questions”