Urdu fonts are not rendering properly in any browser.

Archived topics about LMDE 1 and LMDE 2
Locked
ghufranmsn
Level 1
Level 1
Posts: 5
Joined: Sun May 22, 2016 10:25 am

Urdu fonts are not rendering properly in any browser.

Post by ghufranmsn »

I have been using Linux since two or three years. But now as my job need me to brows internet in my own native language Urdu. I am facing a big problem which is font rendering for Urdu. I tried every solution which was available in google searches but no luck. I installed lot of Urdu fonts but words shows in search results are always broken. Here is a screenshot with firefox, Chromium, and Windows FIrefox which clearly shows huge difference of fonts displaying. I wish some one could help me so I would continue using Linux.
Note= I am using Linux Mint Debian Edition 2

Image
(Click screenshot to enlarge. Press <Alt><Cursor Left> to return here.)
Last edited by karlchen on Sun May 22, 2016 2:03 pm, edited 1 time in total.
Reason: Applied [rimg] tags to url of screenshot, giving a clickable preview, ain't [rimg] tags great?!
ghufranmsn
Level 1
Level 1
Posts: 5
Joined: Sun May 22, 2016 10:25 am

Re: Urdu fonts are not rendering properly in any browser.

Post by ghufranmsn »

Thank You every one. It happened to know that Opera Browser is doing fine under Linux. So problem is with Firefox and Chromium. I wish there developer will look after this problem. As we are receiving updates often.
kevinthefixer
Level 4
Level 4
Posts: 278
Joined: Thu Jul 23, 2015 10:36 pm

Re: Urdu fonts are not rendering properly in any browser.

Post by kevinthefixer »

Perhaps you should file bug reports.
ghufranmsn
Level 1
Level 1
Posts: 5
Joined: Sun May 22, 2016 10:25 am

Re: Urdu fonts are not rendering properly in any browser.

Post by ghufranmsn »

Ok here is font setting for Firefox which make it to read Urdu properly.
Attachments
ghj.png
Locked

Return to “LMDE Archive”