Uninstall adobe-flashplugin from Linux Mint 17.3.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
SETHANATH
Level 3
Level 3
Posts: 187
Joined: Sat Jun 14, 2014 6:54 pm

Uninstall adobe-flashplugin from Linux Mint 17.3.

Post by SETHANATH » Mon Jun 27, 2016 12:51 pm

Hi,

I installed flashplugin-installer from Linux Mint 17.3 through the use of this command 'sudo apt-get install flashplugin-installer' from Linux Mint 17.3. However, by doing so, I also need to remove mint-meta-codecs and mint-meta-codecs-core.

My questions to you are
- Can I remove adobe-flashplugin, but still keep mint-meta-codecs and mint-meta-codecs-core?
- How do I install mint-meta-codecs and mint-meta-codecs-core back to my PC?
- What else are inside mint-meta-codecs and mint-meta-codecs-core, beside adobe-flashplugin?

Thank you.

User avatar
xenopeek
Level 24
Level 24
Posts: 24096
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Uninstall adobe-flashplugin from Linux Mint 17.3.

Post by xenopeek » Mon Jun 27, 2016 2:15 pm

mint-meta-codecs and mint-meta-codecs-core are so called meta packages. They list what others packages need to be installed but don't have any content of their own. adobe-flashplugin was installed through these and so removing that package will need to remove those packages (else you end up with a system with broken dependencies).

It is fine to remove meta packages from Linux Mint 17.3 as it is unlikely there will be changes to them on Linux Mint 17.3 (and there won't be a Linux Mint 17.4 that might bring changes). If meta packages changes the list of to be installed packages, those wouldn't be installed for you automatically if you don't have the meta package installed. That's why you would want to have it on your system. But in general Linux Mint doesn't change meta packages between major releases.

I don't know if flashplugin-installer will update your Adobe Flash version through Update Manager. adobe-flashplugin does.
Image

SETHANATH
Level 3
Level 3
Posts: 187
Joined: Sat Jun 14, 2014 6:54 pm

Re: Uninstall adobe-flashplugin from Linux Mint 17.3.

Post by SETHANATH » Mon Jun 27, 2016 2:49 pm

If meta packages changes the list of to be installed packages, those wouldn't be installed for you automatically if you don't have the meta package installed.
That's why you would want to have it on your system. But in general Linux Mint doesn't change meta packages between major releases.
How do I remove only adobe-flashplugin, but keep these two meta packages as I want the rest of the packages to be installed automatically?

Thank you.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Uninstall adobe-flashplugin from Linux Mint 17.3.

Post by Cosmo. » Mon Jun 27, 2016 3:03 pm

You cannot.

Perhaps this analogy helps to understand the situation:
You have printer with black, red, blue and yellow ink. You can buy every ink alone, but you can also buy all inks together in a set. Now you remove one of those inks out of the set; obviously you do not have a complete set anymore, but only the remaining inks.

The meta package is the set. The meta-package itself contains no "ink". If you uninstall one of the packages, all the other packages of this "set" will remain (and they will continue to get updates in case there are any available). But you obviously do not have the complete set (aka meta-package) any more.

You could later install the meta-package again and the package management will recognize, that all but one packages of this meta-package are already on your system and will only install the one, which does not.

Or the other way round: If you would (theoretically) be able to remove the flash-package, but leave the meta-package, the meta-package would tell the package-management, that there is something missing and the flash-package would get installed again behind your back. You wouldn't be happy in this case, would you?

I hope this helps to understand the meaning of a meta package.

SETHANATH
Level 3
Level 3
Posts: 187
Joined: Sat Jun 14, 2014 6:54 pm

Re: Uninstall adobe-flashplugin from Linux Mint 17.3.

Post by SETHANATH » Mon Jun 27, 2016 4:17 pm

It works. I did the following, just like you suggested. I noticed that adobe-flashplugin is put back into the OS, but not used. I checked my browser, and I can see that flashplugin-installer is being used, instead, correctly.

$ sudo apt-get install mint-meta-codecs
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
adobe-flash-properties-gtk adobe-flashplugin
Suggested packages:
x-ttcidfont-conf xfs libnspr4-0d
The following NEW packages will be installed:
adobe-flash-properties-gtk adobe-flashplugin mint-meta-codecs
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 10.4 MB of archives.
After this operation, 38.7 MB of additional disk space will be used.
Do you want to continue? [Y/n]

However, I cannot find mint-meta-codecs-core.

$ sudo apt-get install mint-meta-codecs-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package mint-meta-codecs-core

Please help.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Uninstall adobe-flashplugin from Linux Mint 17.3.

Post by Cosmo. » Mon Jun 27, 2016 4:30 pm

The name is: mint-meta-core.

Post Reply

Return to “Newbie Questions”