Disable Touchpad - does this work?

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Level 2
Level 2
Posts: 71
Joined: Sat Apr 16, 2016 4:06 pm

Disable Touchpad - does this work?

Post by hunny »

Code: Select all

[Desktop Entry]
Name=Disable touchpad
GenericName=Touchpad disabler
Comment=Disables touchpad
Exec=synclient TouchpadOff=1
https://www.maketecheasier.com/disable- ... tup-linux/

I've tried it and my touchpad is still in operation at start up.

My System

Code: Select all

Kernel: 3.19.0-32-generic x86_64 (64 bit gcc: 4.8.2)
           Desktop: MATE 1.12.0 (Gtk 3.10.8~8+qiana)
           Distro: Linux Mint 17.3 Rosa
Machine:   Mobo: Medion model: E6227 v: 1.0
           Bios: American Megatrends v: 207 date: 04/03/2012
CPU:       Dual core Intel Core i3-2350M (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9179
           clock speeds: max: 2300 MHz 1: 1524 MHz 2: 1596 MHz 3: 1735 MHz
           4: 1785 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.17.1 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1360x768@59.8hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile
           GLX Version: 3.0 Mesa 10.5.9 Direct Rendering: Yes
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k3.19.0-32-generic
Network:   Card-1: Intel Centrino Wireless-N 2230
           driver: iwlwifi v: in-tree: bus-ID: 02:00.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 03:00.0
           IF: eth0 state: down mac: <filter>

Partition: ID-1: / size: 55G used: 8.0G (16%) fs: ext4 dev: /dev/sdb1
           ID-2: swap-1 size: 4.18GB used: 0.00GB (0%) fs: swap dev: /dev/sdb5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 64.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 220 Uptime: 9 min Memory: 2647.1/3846.7MB
           Init: Upstart runlevel: 2 Gcc sys: 4.8.4
           Client: Shell (bash 4.3.111) inxi: 2.2.28 
"Linux, It's life Jim but not as we know it..."
Level 1
Level 1
Posts: 16
Joined: Sun Jul 17, 2016 9:40 am

Re: Disable Touchpad - does this work?

Post by bbobbo »

from the command line, run:

synclient TouchpadOff=1

then run

synclient|grep TouchpadOff

to see if the setting changes. if not, then some other process is probably controlling the touchpad device. i ran the synclient command from my command line, and it had no effect on the setting.

see: https://bugs.freedesktop.org/show_bug.cgi?id=89270

from a link on the page you first referenced, you can install a PPA which might work for you:

https://www.maketecheasier.com/disable- ... in-ubuntu/
Level 2
Level 2
Posts: 71
Joined: Sat Apr 16, 2016 4:06 pm

Re: Disable Touchpad - does this work?

Post by hunny »

Thank you for that.

I think you misunderstand. I can disable the touchpad via the settings, but it is still in operation when I log in. Once I have done so the setting kicks in and disables it.

I wanted to know how to disable on the log in screen, as currently it is active.
"Linux, It's life Jim but not as we know it..."
Post Reply

Return to “Software & Applications”