mintupgrade from 17.3 failed halfway through

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Colbey
Level 1
Level 1
Posts: 12
Joined: Sun Jan 08, 2012 3:06 pm

mintupgrade from 17.3 failed halfway through

Post by Colbey »

Hi, all. I tried to upgrade my 17.3 install to 18 following the prescribed use of mintupgrade, and I ended up with this:

Code: Select all

Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for doc-base (0.10.5) ...
Possible precedence issue with control flow operator at /usr/share/perl5/Debian/DocBase/DB.pm line 101.
The following error has occured while loading doc-base modules:

Can't locate UUID.pm in @INC (you may need to install the UUID module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.1 /usr/local/share/perl/5.22.1 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /usr/share/perl5/Debian/DocBase/Programs/Scrollkeeper.pm line 21.
BEGIN failed--compilation aborted at /usr/share/perl5/Debian/DocBase/Programs/Scrollkeeper.pm line 21.
Compilation failed in require at /usr/share/perl5/Debian/DocBase/InstallDocs.pm line 25.
BEGIN failed--compilation aborted at /usr/share/perl5/Debian/DocBase/InstallDocs.pm line 25.
Compilation failed in require at /usr/sbin/install-docs line 27.

*******************************************************************
It seems install-docs is not fully functional at the moment,
and it will try to recover from the error next time it is called.

Please run `install-docs --install-changed' command
manually after the upgrade process is finished.
*******************************************************************

Processing triggers for gconf2 (3.2.6-0ubuntu2) ...
Processing triggers for libglib2.0-0:amd64 (2.40.2-0ubuntu1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libsane-common_1.0.25+git20150528-1ubuntu2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

------------------------------------------------
!!  ERROR: Failed to upgrade some of the packages. Please review the error message, use APT to fix the situation and try again.
!!  Exiting.
------------------------------------------------

josh@chesed ~ $ sudo -i
chesed ~ # install-docs --install-changed
Possible precedence issue with control flow operator at /usr/share/perl5/Debian/DocBase/DB.pm line 101.
The following error has occured while loading doc-base modules:

Can't locate UUID.pm in @INC (you may need to install the UUID module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.1 /usr/local/share/perl/5.22.1 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /usr/share/perl5/Debian/DocBase/Programs/Scrollkeeper.pm line 21.
BEGIN failed--compilation aborted at /usr/share/perl5/Debian/DocBase/Programs/Scrollkeeper.pm line 21.
Compilation failed in require at /usr/share/perl5/Debian/DocBase/InstallDocs.pm line 25.
BEGIN failed--compilation aborted at /usr/share/perl5/Debian/DocBase/InstallDocs.pm line 25.
Compilation failed in require at /usr/sbin/install-docs line 27.

*******************************************************************
It seems install-docs is not fully functional at the moment,
and it will try to recover from the error next time it is called.
*******************************************************************

chesed ~ # apt install libuuid-perl
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 clementine : Depends: libtag1c2a (>= 1.9.1) but it is not installable
 dconf-gsettings-backend : Depends: libdconf1 (= 0.20.0-1) but 0.24.0-2 is to be installed
 dconf-service : Depends: libdconf1 (= 0.20.0-1) but 0.24.0-2 is to be installed
 findimagedupes : Depends: perlapi-5.18.1 but it is not installable
 gstreamer1.0-plugins-good : Depends: libtag1c2a (>= 1.5) but it is not installable
 gvfs : Depends: libglib2.0-0 (>= 2.45.7) but 2.40.2-0ubuntu1 is to be installed
 gvfs-backends : Depends: libglib2.0-0 (>= 2.45.7) but 2.40.2-0ubuntu1 is to be installed
 gvfs-bin : Depends: libglib2.0-0 (>= 2.45.7) but 2.40.2-0ubuntu1 is to be installed
 gvfs-daemons : Depends: libglib2.0-0 (>= 2.45.7) but 2.40.2-0ubuntu1 is to be installed
 gvfs-fuse : Depends: libglib2.0-0 (>= 2.45.7) but 2.40.2-0ubuntu1 is to be installed
 gvfs-libs : Depends: libglib2.0-0 (>= 2.45.7) but 2.40.2-0ubuntu1 is to be installed
 hplip : Depends: python3 (>= 3.5~) but 3.4.0-0ubuntu2 is to be installed
 libalgorithm-diff-xs-perl : Depends: perlapi-5.18.1 but it is not installable
 libapt-pkg-perl : Depends: perlapi-5.18.1 but it is not installable
 libarchive12 : Depends: libnettle4 (>= 2.3) but it is not installable
 libarchive13 : Depends: libnettle4 (>= 2.3) but it is not installable
 libc-dev-bin : Depends: libc6 (< 2.20) but 2.23-0ubuntu3 is to be installed
 libc6-dbg : Depends: libc6 (= 2.19-0ubuntu6.9) but 2.23-0ubuntu3 is to be installed
 libc6-dev : Depends: libc6 (= 2.19-0ubuntu6.9) but 2.23-0ubuntu3 is to be installed
 libc6-i386 : Depends: libc6 (= 2.19-0ubuntu6.9) but 2.23-0ubuntu3 is to be installed
 libcairo-perl : Depends: perlapi-5.18.1 but it is not installable
 libclone-perl : Depends: perlapi-5.18.1 but it is not installable
 libcrypt-ssleay-perl : Depends: perlapi-5.18.1 but it is not installable
 libcupscgi1 : Depends: libcups2 (= 1.7.2-0ubuntu1.7) but 2.1.3-4 is to be installed
 libcupsimage2 : Depends: libcups2 (= 1.7.2-0ubuntu1.7) but 2.1.3-4 is to be installed
 libcupsmime1 : Depends: libcups2 (= 1.7.2-0ubuntu1.7) but 2.1.3-4 is to be installed
 libcupsppdc1 : Depends: libcups2 (= 1.7.2-0ubuntu1.7) but 2.1.3-4 is to be installed
 libdbd-mysql-perl : Depends: perlapi-5.18.1 but it is not installable
 libdbi-perl : Depends: perlapi-5.18.1 but it is not installable
 libfile-fcntllock-perl : Depends: perlapi-5.18.1 but it is not installable
 libglib-perl : Depends: perlapi-5.18.1 but it is not installable
 libgnutls28 : Depends: libhogweed2 (>= 2.7) but it is not installable
               Depends: libnettle4 (>= 2.7) but it is not installable
 libgraphics-magick-perl : Depends: perlapi-5.18.1 but it is not installable
 libgtk2-perl : Depends: perlapi-5.18.2 but it is not installable
 libhdate-perl : Depends: perlapi-5.18.2 but it is not installable
 libhtml-parser-perl : Depends: perlapi-5.18.1 but it is not installable
 libio-pty-perl : Depends: perlapi-5.18.1 but it is not installable
 liblist-moreutils-perl : Depends: perlapi-5.18.1 but it is not installable
 liblocale-gettext-perl : PreDepends: perlapi-5.18.1 but it is not installable
 libmusicbrainz-discid-perl : Depends: perlapi-5.18.1 but it is not installable
 libnet-dns-perl : Depends: perlapi-5.18.1 but it is not installable
 libnet-ssleay-perl : Depends: perlapi-5.18.2 but it is not installable
 libpango-perl : Depends: perlapi-5.18.1 but it is not installable
 libperl5.18 : Depends: perl-base (= 5.18.2-2ubuntu1.1) but 5.22.1-9 is to be installed
 libperlio-gzip-perl : Depends: perlapi-5.18.1 but it is not installable
 libpurple0 : Depends: perlapi-5.18.2 but it is not installable
 libsane : Depends: libsane-common (= 1.0.25+git20150528-1ubuntu2) but 1.0.23-3ubuntu3.1 is to be installed
 libsocket6-perl : Depends: perlapi-5.18.2 but it is not installable
 libsub-identify-perl : Depends: perlapi-5.18.1 but it is not installable
 libsub-name-perl : Depends: perlapi-5.18.1 but it is not installable
 libterm-readkey-perl : Depends: perlapi-5.18.1 but it is not installable
 libtext-charwidth-perl : Depends: perlapi-5.18.1 but it is not installable
 libtext-iconv-perl : Depends: perlapi-5.18.1 but it is not installable
 libtext-soundex-perl : Depends: perlapi-5.18.1 but it is not installable
 libxml-libxml-perl : Depends: perlapi-5.18.2 but it is not installable
 libxml-parser-perl : Depends: perlapi-5.18.1 but it is not installable
 libyaml-syck-perl : Depends: perlapi-5.18.1 but it is not installable
 pidgin : Depends: perlapi-5.18.2 but it is not installable
 python3 : Depends: python3-minimal (= 3.4.0-0ubuntu2) but 3.5.1-3 is to be installed
           Depends: libpython3-stdlib (= 3.4.0-0ubuntu2) but 3.5.1-3 is to be installed
 python3-pil : Depends: python3 (>= 3.5~) but 3.4.0-0ubuntu2 is to be installed
 python3-uno : Depends: libreoffice-core (= 1:5.0.3~rc2-0ubuntu1~trusty2) but 1:5.1.4-0ubuntu1 is to be installed
 vlc-nox : Depends: libebml4 but it is not installable
           Depends: libmatroska6 but it is not installable
           Depends: libsidplay2 but it is not installable
           Depends: libtag1c2a (>= 1.7) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

At this point, basically no matter what I try, I get this list of unmet dependencies. Aptitude and apt-get both can't figure out how to resolve it. Can you help? Thanks!

deepakdeshp
Level 16
Level 16
Posts: 6627
Joined: Sun Aug 09, 2015 10:00 am

Re: mintupgrade from 17.3 failed halfway through

Post by deepakdeshp »

Hello,
Did you try upgrading with the steps given in the link?It does a dry run. https://community.linuxmint.com/tutorial/view/2316

Please refer to
https://community.linuxmint.com/tutorial/view/482
The problem is with perl5 hence you can hold the perl5 package from upgrade with following command and try the upgrade after holding perl5 upgrade.

Code: Select all

sudo aptitude hold perl5
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Laurent85
Level 16
Level 16
Posts: 6303
Joined: Tue May 26, 2015 10:11 am

Re: mintupgrade from 17.3 failed halfway through

Post by Laurent85 »

Do not hold a package while upgrading :idea:

When the upgrade process is stuck then alternatively run the following commands until the system could complete with all updates:

Code: Select all

sudo dpkg --configure -a
sudo apt-get -f install 
sudo apt-get dist-upgrade -o Dpkg::Options::="--force-confnew"
Next install additional packages:

Code: Select all

sudo apt-get install xed xreader xviewer xviewer-plugins xplayer pix
Then remove the following packages:

Code: Select all

gedit evince eog totem totem-mozilla gthumb pluma atril eom
Finally remove old dependency packages:

Code: Select all

sudo apt-get --purge autoremove
Image

Post Reply

Return to “Installation & Boot”