[found workaround] Mint 18, dead keys not working

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
brunovianna
Level 1
Level 1
Posts: 7
Joined: Thu Jul 28, 2016 4:19 pm

[found workaround] Mint 18, dead keys not working

Post by brunovianna » Fri Jul 29, 2016 10:50 am

Hello

I've being using Mint since version 12 or 13. I just upgraded to 18 64-bit. I use an keyboard with American physical layout. But since I write a lot in other languages, I always rely on the international with dead keys layout so I can get the funny characters such as á or ç.

Thing is, the dead keys are not working with this keyboard layout - or any other. Usually I'd type ´ + a, to get á. Now I just get ´a.

Any ideas?
Thanks!
Last edited by brunovianna on Fri Jul 29, 2016 4:10 pm, edited 2 times in total.

brunovianna
Level 1
Level 1
Posts: 7
Joined: Thu Jul 28, 2016 4:19 pm

Re: Mint 18, dead keys not working

Post by brunovianna » Fri Jul 29, 2016 11:01 am

I found this on thefile ~/.xsession.errors:

![1469803086,000,xklavier_evt_xkb.c:xkl_xkb_process_x_event/] ATTENTION! Curre
ntly cached group 0 is not equal to the current group from the event: 1
![1469803088,000,xklavier


Also, when I open a non-graphic session (ctrl-alt-f1), the dead keys work. So, definitely something in the X configuration...

brunovianna
Level 1
Level 1
Posts: 7
Joined: Thu Jul 28, 2016 4:19 pm

Re: Mint 18, dead keys not working

Post by brunovianna » Fri Jul 29, 2016 4:10 pm

Found workaround:

install ibus:
$sudo apt-get install ibus

run ibus-setup

$sudo ibus-setup

User avatar
jimallyn
Level 18
Level 18
Posts: 8867
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: [found workaround] Mint 18, dead keys not working

Post by jimallyn » Fri Jul 29, 2016 5:13 pm

I use the Compose key to get special characters. In Cinnamon, click Menu, Preferences, Keyboard, Layouts, Options, and select Position of Compose key. Then you can press the Compose key and the next two characters you type will create special characters. Most of the key combinations are pretty intuitive:

Compose oo gives you °
Compose n~ gives you ñ
Compose c| gives you ¢
Compose e' gives you é

I use the left Win key for my Compose key, but there are a lot of other choices. Oh, and you have to press and release the Compose key, then press the two character keys. Some combinations will work if you hold the Compress key, but many of them will not. Took me a while to figure that out.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

brunovianna
Level 1
Level 1
Posts: 7
Joined: Thu Jul 28, 2016 4:19 pm

Re: [found workaround] Mint 18, dead keys not working

Post by brunovianna » Sun Jul 31, 2016 9:15 am

Thanks! I still would like to get the old way working. Typing 3 keys to get a special character is fine when you only need at seldom times. But when I'm writing and need accentuated characters all the time, it breaks the flow of text to me. Besides, it seems like a bug to me.

For now I'm combining the use of the compose key and ibus (which didn't give the complete set of Portuguese characters)

Post Reply

Return to “Other topics”