[SOLVED] Intel HD Graphics Diagonal Tear

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
riffbiker
Level 1
Level 1
Posts: 12
Joined: Mon Jan 12, 2015 11:08 am

[SOLVED] Intel HD Graphics Diagonal Tear

Post by riffbiker » Thu Aug 04, 2016 12:15 pm

I have an issue with the default Intel Graphics Driver in Mint 18 as installed in a new-build computer. I shall refer to the issue as a form of 'video-tearing', but it is not the usual shimmer in movie video replay, but on larger desktop documents. It takes the form of an intermittent but repeatable on-screen diagonal video 'tearing', evident when scrolling, eg, within Firefox or a PDF. Video player reproduction is not affected.

Solutions tried - none make any difference:
1. Enabling 'TearFree' via adding a correctly written and installed '20-intel.conf' file and confirming enablement in Terminal
2. Disabling hardware graphics acceleration in Firefox (default is hardware acceleration enabled)
3. Disabling 'compositing for full-screen windows' - default is OFF (ie. compositing is on) anyway
4. Uninstalling the Intel driver - THIS WORKS BUT CAUSES ISSUES!
Removing the Intel Driver thereby forcing fallback on the 'generic modesetting Xorg' driver cured this issue. However, it introduced another rather strange issue in OpenOffice (which I use in preference to LibreOffice) whereby the text 'autoinput' (auto-complete) is almost transparent until entered, when the text correctly becomes black.
5. Investigated installing an earlier Intel Driver, (v 2:2.21.6-0ubuntu4.1) is reported as a stable release - however it will not install due to dependency issues. The required dependency packages appear deprecated and are not available in the Linux Mint 18 repository.

I have not given the detailed Terminal Commands and procedures I used as - anyone who recognises this issue will be familiar with such techniques. I can elaborate if anyone is interested.

It would seem the Intel Driver is the problem, but it is the latest version. Short of using a separate graphics board, does anyone have any further ideas - or if a 'bug', can we consider getting Intel to look into their driver. Thanks in advance.

Configuration:
Main Board: ASUS H81I Plus - UEFI (BIOS)
Processor: Intel Core i3 4130T with Integrated Intel HD Graphics 4400
OS: Linux Mint 18 Sarah x64 with Linux Kernel v 4.4.0-31
Intel Graphics Driver: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1 (Mint 18 default)

Riffbiker
Computer Engineer
Last edited by riffbiker on Fri Aug 05, 2016 9:48 am, edited 1 time in total.

User avatar
Portreve
Level 7
Level 7
Posts: 1846
Joined: Mon Apr 18, 2011 12:03 am
Location: Florida
Contact:

Re: Intel HD Graphics Diagonal Tear

Post by Portreve » Thu Aug 04, 2016 7:53 pm

riffbiker wrote:I have an issue with the default Intel Graphics Driver in Mint 18 as installed in a new-build computer. I shall refer to the issue as a form of 'video-tearing', but it is not the usual shimmer in movie video replay, but on larger desktop documents. It takes the form of an intermittent but repeatable on-screen diagonal video 'tearing', evident when scrolling, eg, within Firefox or a PDF. Video player reproduction is not affected.
Try this.
I have to leave so I can get home by the time I arrive.

Presently rocking LinuxMint 19.1 Cinnamon.

Remember to mark your fixed problem [SOLVED].

riffbiker
Level 1
Level 1
Posts: 12
Joined: Mon Jan 12, 2015 11:08 am

Re: Intel HD Graphics Diagonal Tear

Post by riffbiker » Fri Aug 05, 2016 9:29 am

Hello Portreve,

Thank you very much for your response. You have steered me in the correct direction and at time of writing I appear to have resolved this issue!

In fact, it required two changes - and it was that which proved challenging to find. As mentioned in my original problem description, enabling 'TearFree' via adding a correctly written and installed '20-intel.conf' file (as per your most helpful description) and confirming enablement in the Terminal did not appear to work - ALONE! It improved desktop tearing, but still left reduced tearing in Firefox.

What I did not know, without the enlightenment coming from this esteemed Community, was that hardware graphics acceleration is disabled in Firefox for Linux by default - WHATEVER the Firefox Preferences are set to! It is disabled at a lower level!

So, my thanks again to you and all the contributors on your linked thread.

---
THIS IS WHAT I HAVE NOW DONE TO RESOLVE THE ISSUE AS DESCRIBED
This set of instructions apply to Firefox v47 (and earlier)

1. Add a correctly written and installed configuration file for in-processor INTEL HD Graphics
1.1 Portreve has kindly described how to do this here: Portreve Link
1.2 After Restart, confirm that TearFree is enabled with this Terminal Command (Cinnamon)
cat /var/log/Xorg.0.log | grep TearFree
It should correctly report: 'intel(0): TearFree enabled'
2. Enable Firefox (v 47.0) graphic hardware acceleration
2.1 Launch Firefox
2.2 Type < about:config > without the brackets - It will warn 'Here Be Dragons' - click 'I'll Be Careful, I Promise!
2.3 In the Search Bar enter < layers.acceleration.force-enabled > without the brackets
2.4 It will state 'false' - double click it to change to 'true' and close the Firefox Tab
2.5 Restart Firefox
2.6.1 Confirm GPU Acceleration is active - do this:
2.6.2 In Firefox, type < about:support > without the brackets
2.6.3 Under the heading 'Graphics', discover GPU Accelerated Windows
2.6.4 It should read: 1/1 OpenGL (OMTC) - this means hardware acceleration is active
2.6.5 If it displays: 0/1 Basic (OMTC) - this means hardware acceleration is inactive
2.6.7 Close the Firefox Tab

---

ADDENDUM: 8 August 2016
Firefox 48 for Linux is being rolled out and some of the above is deprecated, ie. it is no longer possible to see 'GPU Accelerated Windows' in the Graphics section of 'about:support'. However, the rest of the instructions remain true.

For your convenience, the instructions as at 8 August 2016 for Firefox 48:
THIS IS WHAT I HAVE NOW DONE TO RESOLVE THE ISSUE AS DESCRIBED
This set of instructions apply to Firefox v48 (and later...)
1. Add a correctly written and installed configuration file for in-processor INTEL HD Graphics
1.1 Portreve has kindly described how to do this here: Portreve Link
1.2 After Restart, confirm that TearFree is enabled with this Terminal Command (Cinnamon)
cat /var/log/Xorg.0.log | grep TearFree
It should correctly report: 'intel(0): TearFree enabled'
2. Enable Firefox (v 48.0) graphic hardware acceleration
2.1 Launch Firefox
2.2 Type < about:config > without the brackets - It will warn 'Here Be Dragons' - click 'I'll Be Careful, I Promise!
2.3 In the Search Bar enter < layers.acceleration.force-enabled > without the brackets
2.4 It will state 'false' - double click it to change to 'true' and close the Firefox Tab
2.5 Restart Firefox

Hopefully, this should resolve all Intel Graphics Screen-Tearing issues under Linux Mint 18

My grateful thanks to Portreve - and the many other contributors on his link (and other sources) for helping me find a solution - which I hope helps you also.

Best Regards,
Riffbiker
Computer Engineer
Last edited by riffbiker on Mon Aug 08, 2016 5:32 am, edited 1 time in total.

Seffis
Level 2
Level 2
Posts: 50
Joined: Tue Sep 02, 2014 3:06 am

Re: [SOLVED] Intel HD Graphics Diagonal Tear

Post by Seffis » Sat Aug 06, 2016 9:48 pm

Same issue here (Intel Graphics 3000), and appears to be solved after changing < layers.acceleration.force-enabled > to true in about:config in Firefox. Although I could not find the graphics section in about:config to confirm.

I thought I was going to have to live with this issue... so thanks...
Toshiba C655-S5549 Intel I3 dual core Intel Graphics 3000

riffbiker
Level 1
Level 1
Posts: 12
Joined: Mon Jan 12, 2015 11:08 am

Re: [SOLVED] Intel HD Graphics Diagonal Tear

Post by riffbiker » Mon Aug 08, 2016 5:41 am

Hi Seffis,

Glad to have helped - as others have helped me find this solution. The 'Graphics Section' is not under < about:config > but instead is to be found under < about:support >.

With effect of Firefox 48, which is being rolled-out now (I received an update on 7 August 2016 via Update Manager), there are some changes although the basic instructions remain true. <about:support > no longer details 'GPU Accelerated Windows'. Please see my ADDENDUM above.

It is also worthwhile creating a ' 20-intel.conf ' configuration file as kindly described by Portreve in his link as linked above - note this is for Linux Mint 18 (as the installation location for this file changed).

Kind Regards.

Seffis
Level 2
Level 2
Posts: 50
Joined: Tue Sep 02, 2014 3:06 am

Re: [SOLVED] Intel HD Graphics Diagonal Tear

Post by Seffis » Tue Aug 16, 2016 10:35 pm

as the installation location for this file changed
Guess that's why cat /var/log/Xorg.0.log | grep TearFree did not show anything. So created it (20-intel.conf) in the correct lo\cation. And then edited the Firefox about:config.

Conclusion: This is the first time since 17,x, that I have not seen software rendering and software decoding while watching YouTube videos, in 'Stats for Nerds.' :)
Toshiba C655-S5549 Intel I3 dual core Intel Graphics 3000

alexdd
Level 1
Level 1
Posts: 13
Joined: Wed Jun 03, 2015 2:10 pm

Re: [SOLVED] Intel HD Graphics Diagonal Tear

Post by alexdd » Thu Feb 21, 2019 7:00 am

Hey,
I tried the above (ADDENDUM: 8 August 2016) and still have diagonal screen tearing.

Linux Mint 18.3 64bit
Graphics Intel Corporation Mobile 945GM/MGS, 943/940GML Express integrated Graphics Controller

-> Any ideas what to do?

-> Can I just update to Linuxmint 19.1 and screen tearing will be gone?

Post Reply

Return to “Hardware Support”