[SOLVED] Mint 18 with Radeon graphics issue

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
barryw
Level 1
Level 1
Posts: 7
Joined: Tue Aug 16, 2016 12:52 am

[SOLVED] Mint 18 with Radeon graphics issue

Post by barryw » Thu Aug 18, 2016 12:45 am

Linux Mint 18 graphics works fine from LiveCD but after install initially got black screen until nomodeset added to Grub.
The system then boots into graphical environment with reduced resolution and software rendering.

This is most frustrating as obviously Mint18 and the kernel support the graphics.
The difference I notice in the Inix output is that in the Display server drivers. When booted from CD the drivers are ati,radeon with fbdev,vesa unloaded. After HD install the drivers are fbdev,ati with vesa,radeon unloaded.
I gather that somehow I need to force the radeon driver to be loaded and fbdev to be unloaded.
Tried doing this with modprobe blacklist and load file entries with no luck.
Tried adding resolutions and modes with xrandr with no luck. Is there a file anywhere that holds the xrandr settings that could be modified?

Any help in solving this would be mostly appreciated.

Below are output from inix and xrandr both from LiveCD and after install

inix -Gx output from liveCD (note the Radeon driver used and fbdev unloaded)

Graphics: Card-1: Advanced Micro Devices [AMD/ATI] BeaverCreek [Radeon HD 6620G]
bus-ID: 00:01.0 chip-ID: 1002:9641
Card-2: Advanced Micro Devices [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]
bus-ID: 02:00.0 chip-ID: 1002:6760
Display Server: X.Org 1.18.3 drivers: ati,radeon (unloaded: fbdev,vesa)
Resolution: 1366x768@60.07hz
GLX Renderer: Gallium 0.4 on AMD SUMO (DRM 2.43.0, LLVM 3.8.0)
GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes


inix -Gx output after install on HDD (note the fbdev driver used and Radeon unloaded)

Graphics: Card-1: Advanced Micro Devices [AMD/ATI] BeaverCreek [Radeon HD 6620G]
bus-ID: 00:01.0
Card-2: Advanced Micro Devices [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]
bus-ID: 02:00.0
Display Server: X.Org 1.18.3 drivers: fbdev,ati (unloaded: vesa,radeon)
Resolution: 1024x768@76.00hz
GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.8, 128 bits)
GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes

xrandr -q output from liveCD (allgood)

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
VGA-0 disconnected (normal left inverted right x axis y axis)
LVDS connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
1366x768 60.07*+
1280x720 59.86
1152x768 59.78
1024x768 59.92
800x600 59.86
848x480 59.66
720x480 59.71
640x480 59.38
HDMI-0 disconnected (normal left inverted right x axis y axis)

Xrandr -q output after install (not good)

Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
1024x768 76.00*
Last edited by barryw on Sat Aug 20, 2016 11:04 pm, edited 1 time in total.

barryw
Level 1
Level 1
Posts: 7
Joined: Tue Aug 16, 2016 12:52 am

Re: Mint 18 with Radeon graphics issue

Post by barryw » Sat Aug 20, 2016 11:02 pm

I have fixed this issue on my installation. :D
The answer was to replace the nomodeset in grub cmdline during boot (which I needed to get any display at boot) with radeon.dpm=1.
This was found at https://www.x.org/wiki/RadeonFeature/ whch contained, under the KMS section,
"dpm" support, must be selected at boot (via radeon.dpm=1) and is only supported on R6xx and newer asics.

To test this when the grub menu appears press e (for edit) then replace the nomodeset (if there) with radeon=dpm=1. Press f10 to boot this session with the change.

Of course to make the change stick you must edit, as root, /etc/default/grub and change the
GRUB_CMDLINE_LINUX_DEFAULT= line to include radeon.dpm=1
eg GRUB_CMDLINE_LINUX_DEFAULT="radeon.dpm=1 quiet splash"

Then run sudo update-grub.

Post Reply

Return to “Graphics Cards & Monitors”