Screen tearing? nvidia drivers - LM18.1 MATE

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
7inchexhaust
Level 1
Level 1
Posts: 3
Joined: Sun Nov 13, 2016 1:57 pm

Screen tearing? nvidia drivers - LM18.1 MATE

Post by 7inchexhaust » Mon Dec 26, 2016 2:06 pm

Hello all,

I need help fixing this screen tearing issue I have.
I've run mint since 14 (on my laptop), but only started running mint on my desktop as of 17.

I currently have upgraded to 18.1, but I've had this issue since using it on my desktop.

I had the problem fixed on my last install, but cannot seem to get it working correctly this time and it is driving me insane.
I am running LM18.1 MATE and had it seemingly working on LM18 MATE.
Video card is an nvidia GTX970 - running nvidia driver 367.57 - and I do not believe changing driver versions around helps the issue at all.
Last time I made a couple of changes and it seemed to have fixed the issue fully.
Those changes were:
  • add ForceFullCompositionPipeline=On to xorg.conf
    add Option "TripleBuffer" "True" to xorg.conf
    set the window manager to metacity + compton
    set firefox about:config gfx.xrender.enabled to true

I'm still getting this issue. I *think* it is called screen tearing, but mainly I get a horizontal line going up the screen, or a horizontal line on the screen when scrolling. It seems to happen anytime, but is more noticeable if a video is playing or in a game.

I think the issue may be due to my triple monitor setup being a tiny bit more complicated than usual and non uniformity of the monitors. They are all using a different interface to connect to the video card and are all different resolutions and possibly refresh rates. But I dont see why they cant just run 60hz refresh rates and just work.
The worst part is that I think I had it working before I ruined the install and had to reformat.

Any help would be great.



Here is xorg.conf

Code: Select all

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 361.42  (buildd@lgw01-18)  Tue Apr  5 14:33:28 UTC 2016


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Acer K272HUL"
    HorizSync       15.0 - 99.0
    VertRefresh     23.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    Option         "TripleBuffer" "True"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 970"
EndSection

Section "Screen"

# Removed Option "metamodes" "HDMI-0: nvidia-auto-select +0+0 {rotation=left}, DP-0: nvidia-auto-select +1080+240 {ForceFullCompositionPipeline=On} , DVI-D-0: nvidia-auto-select +3640+0 {rotation=left}; "
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "DynamicTwinView" "False"
    Option         "TripleBuffer" "True"
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2"
    Option         "metamodes" "DP-0: nvidia-auto-select +1080+240 {ForceFullCompositionPipeline=On} , HDMI-0: nvidia-auto-select +0+0 {rotation=left}, DVI-D-0: nvidia-auto-select +3640+0 {rotation=left}; DP-0: nvidia-auto-select +0+0; DP-0: 1920x1200 +0+0; DP-0: 1920x1200_60_0 +0+0; DP-0: 1920x1080 +0+0; DP-0: 1920x1080_60_0 +0+0; DP-0: 1920x1080_60_1 +0+0; DP-0: 1920x1080_50 +0+0; DP-0: 1920x1080_50_0 +0+0; DP-0: 1920x1080_60i +0+0; DP-0: 1920x1080_50i +0+0; DP-0: 1680x1050 +0+0; DP-0: 1600x1200 +0+0; DP-0: 1440x900 +0+0; DP-0: 1440x900_60 +0+0; DP-0: 1280x1024 +0+0; DP-0: 1280x1024_60 +0+0; DP-0: 1280x720 +0+0; DP-0: 1280x720_60_0 +0+0; DP-0: 1280x720_50 +0+0; DP-0: 1024x768 +0+0; DP-0: 1024x768_60 +0+0; DP-0: 800x600 +0+0; DP-0: 800x600_60 +0+0; DP-0: 720x576 +0+0; DP-0: 720x480 +0+0; DP-0: 640x480 +0+0; DP-0: 640x480_72 +0+0; DP-0: 640x480_60 +0+0; DP-0: 640x480_60_0 +0+0; DP-0: nvidia-auto-select +0+0 {viewportin=1366x768, viewportout=2560x1439+0+0, ForceFullCompositionPipeline=On}"
    Option       "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

josweet
Level 2
Level 2
Posts: 87
Joined: Sat Jan 03, 2015 12:41 pm

Re: Screen tearing? nvidia drivers - LM18.1 MATE

Post by josweet » Tue Dec 27, 2016 9:40 am

Try this mate, as it definitely made a difference for me>
Open the Nvidia X server settings and change the following>

1)> Anti Aliasing to Enhanced. I moved mine to 8x on the slide bar, but that may well need to be changed
2) > Open GL settings. Slide al the way to the left (High quality)

I also used the icc profile from here to setup my screen> http://www.tftcentral.co.uk/articles/icc_profiles.htm
To install, go to > settings/colour , then add profile. Once added, click the tiny arrow next to the device listed and this will open the tree up. You will now be able to select the the correct icc profile for your monitor.

Let me know how you get on.

7inchexhaust
Level 1
Level 1
Posts: 3
Joined: Sun Nov 13, 2016 1:57 pm

Re: Screen tearing? nvidia drivers - LM18.1 MATE

Post by 7inchexhaust » Tue Dec 27, 2016 3:02 pm

josweet wrote:Try this mate, as it definitely made a difference for me>
Open the Nvidia X server settings and change the following>

1)> Anti Aliasing to Enhanced. I moved mine to 8x on the slide bar, but that may well need to be changed
2) > Open GL settings. Slide al the way to the left (High quality)

I also used the icc profile from here to setup my screen> http://www.tftcentral.co.uk/articles/icc_profiles.htm
To install, go to > settings/colour , then add profile. Once added, click the tiny arrow next to the device listed and this will open the tree up. You will now be able to select the the correct icc profile for your monitor.

Let me know how you get on.
Thanks for the reply. I made the 2 changes in the nvidia settings, but it doesn't appear to have fixed it. It may actually be happening less often now though.
As far as the ICC profiles, my monitor that is having the screen tearing issue is not listed on there.

User avatar
trytip
Level 8
Level 8
Posts: 2400
Joined: Tue Jul 05, 2016 1:20 pm

Re: Screen tearing? nvidia drivers - LM18.1 MATE

Post by trytip » Tue Dec 27, 2016 3:51 pm

i'm only familiar with nvidia-340 and only mod i made to my xorg.conf is adding these 2 Options to allow more resolutions and tripple buffer

Code: Select all

Section "Device"
    Option         "ModeValidation" "AllowNonEdidModes"
    Option         "TripleBuffer" "1
BUT in control center/desktop settings/windows i choose Marco+Compton try that to see if any improvement
Image

7inchexhaust
Level 1
Level 1
Posts: 3
Joined: Sun Nov 13, 2016 1:57 pm

Re: Screen tearing? nvidia drivers - LM18.1 MATE

Post by 7inchexhaust » Wed Dec 28, 2016 12:21 pm

trytip wrote:i'm only familiar with nvidia-340 and only mod i made to my xorg.conf is adding these 2 Options to allow more resolutions and tripple buffer

Code: Select all

Section "Device"
    Option         "ModeValidation" "AllowNonEdidModes"
    Option         "TripleBuffer" "1
BUT in control center/desktop settings/windows i choose Marco+Compton try that to see if any improvement
Thanks.

Made these changes, but didn't notice any difference.

If it helps, the tearing ONLY occurs on the main, 1440p monitor.

User avatar
trytip
Level 8
Level 8
Posts: 2400
Joined: Tue Jul 05, 2016 1:20 pm

Re: Screen tearing? nvidia drivers - LM18.1 MATE

Post by trytip » Fri Dec 30, 2016 3:52 am

the options are to get extra resolutions. for the tearing you need to use control center > desktop settings > windows > marco+compton
Image

Post Reply

Return to “Sound, Multimedia, & Codecs”