Intel Device 5916 driver

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
SamM
Level 1
Level 1
Posts: 3
Joined: Thu Dec 29, 2016 4:36 pm

Intel Device 5916 driver

Post by SamM » Thu Dec 29, 2016 6:24 pm

Hi,

My Lenovo 710s is running in software rendering mode. Seems to be an issue with the Intel graphics card driver.

Image

Code: Select all

$ inxi -b
System:    Host: sam-laptop Kernel: 4.4.0-21-generic x86_64 (64 bit) Desktop: Cinnamon 3.0.7
           Distro: Linux Mint 18 Sarah
Machine:   System: LENOVO (portable) product: 80VQ v: Lenovo ideapad 710S-13IKB
           Mobo: LENOVO model: Lenovo ideapad 710S-13IKB v: SDK0J40709 WIN
           Bios: LENOVO v: 3HCN12S2 date: 10/07/2016
CPU:       Dual core Intel Core i5-7200U (-HT-MCP-) speed/max: 400/2601 MHz
Graphics:  Card: Intel Device 5916
           Display Server: X.Org 1.18.4 drivers: fbdev,intel (unloaded: vesa)
           Resolution: 1920x1080@77.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.8, 256 bits) GLX Version: 3.0 Mesa 11.2.0
Network:   Card-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
           Card-2: Atheros
Drives:    HDD Total Size: NA (-)
Info:      Processes: 197 Uptime: 1 min Memory: 1189.5/7876.4MB Client: Shell (bash) inxi: 2.2.35 
I gave this a go (but not luck): http://unix.stackexchange.com/questions ... ux-mint-18

Please help.

User avatar
kyphi
Level 9
Level 9
Posts: 2561
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter Valley, Australia

Re: Intel Device 5916 driver

Post by kyphi » Sun Jan 01, 2017 7:54 pm

I found that there appeared to be a conflict of interest between the standard Nouveau driver and the Intel microcode in that occasionally graphics were garbled. When I disabled the Intel driver there were no further graphics disturbances. Try it and see.
Linux Mint 19.1 Cinnamon - 64bit

User avatar
Pjotr
Level 20
Level 20
Posts: 12389
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Intel Device 5916 driver

Post by Pjotr » Sun Jan 01, 2017 8:05 pm

Try this:
Update Manager - panel: View - Linux kernels
Install the latest kernel of the 4.4 series. Then reboot.
Tip: 10 things to do after installing Linux Mint 19.1 Tessa
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

mideal
Level 2
Level 2
Posts: 85
Joined: Fri Jan 18, 2013 10:28 am
Location: Germany - Wilhelmshaven & Frankfurt
Contact:

Re: Intel Device 5916 driver

Post by mideal » Mon Jul 17, 2017 11:10 am

After upgrading to 18.2 (Cinnamon/64bit, kernel 4.8.0-58 automatically chosen) my Lenovo Yoga 910 (i7-7500U) shows extreme flickering (this can't every been called "tearing") when doing nothing, starting at the login screen.
I activated the Intel Microcode drive (shown above), with no effect.

Playing a video with VLC (even moving the windows to another workspace on somewhere to the bottom) reduces this to a quick short flicker every few seconds,
additionally moving the cursor via trackpad slowly cuts it totally.
(Choosing LightDM makes it even worse, even the "play video trick" doesn't work.)

After a short break with suspend-to-ram to read and google on another computer the flickering vanished completely (but is back after rebooting).

This is at least a functioning workaround - and could be used to eliminate the problem completely, if I'd only know how :?
What is wrong?
Yoga 16GB/1TB running Mint 18.2 Cinnamon 64Bit
__________________________
…trust me - I’m the sunscreen.

mideal
Level 2
Level 2
Posts: 85
Joined: Fri Jan 18, 2013 10:28 am
Location: Germany - Wilhelmshaven & Frankfurt
Contact:

Re: Intel Device 5916 driver

Post by mideal » Mon Jul 17, 2017 11:45 am

Thought what I changed after installing and first boot: that was adding nemo-desktop to "autostart" as it happened that the desktop was not shown (while everything lese worked).

Disabled nemo-desktop autostart, rebooted, no flicker - but of course no desktop again :-(

Changed all autostart programs without delay to delay "1" (seconds?), re-activeated nemo-desktop, rebooted, no flicker, working desktop.
Changed all autostart programs without delay "1" to delay "0" again, rebooted, no flicker, working desktop.

I'm baffled.

Added: My conclusions where wrong - flickering was always stopped after closing the lid and reativating the Yoga again. The temporary sleep mode indeed stops the flickering completely, but not boot-persistant. See next post.
Last edited by mideal on Mon Jul 24, 2017 10:56 am, edited 1 time in total.
Yoga 16GB/1TB running Mint 18.2 Cinnamon 64Bit
__________________________
…trust me - I’m the sunscreen.

mideal
Level 2
Level 2
Posts: 85
Joined: Fri Jan 18, 2013 10:28 am
Location: Germany - Wilhelmshaven & Frankfurt
Contact:

Re: Intel Device 5916 driver

Post by mideal » Mon Jul 24, 2017 10:54 am

As always let the notebook sleep for some seconds to fix the flickering, here's the permanent solution:

1. Edit /etc/default/grub

Add

Code: Select all

i915.enable_rc6=0
[/b] to the list of parameter of GRUB_CMDLINE_LINUX_DEFAULT

2. Run

Code: Select all

sudo update-grub
resp.

Code: Select all

sudo update-grub2
3. Reboot (optional)

Result: Flickerfree.
Yoga 16GB/1TB running Mint 18.2 Cinnamon 64Bit
__________________________
…trust me - I’m the sunscreen.

Post Reply

Return to “Newbie Questions”