Acces problem with PEAP/MSCHAPv2

Questions about Wi-Fi and other network devices, file sharing, firewalls, connection sharing etc
Forum rules
Before you post please read how to get help
Post Reply
Husse

Re: Acces problem with PEAP/MSCHAPv2

Post by Husse »

The problem is that this is not "normal" authentication WPA works perfectly in Linux
This means I can't get any experience with it - have to rely entirely on google
Does this help?
http://narnia.cs.ttu.edu/drupal/node/147
or this?
http://ohioloco.ubuntuforums.org/showth ... ?p=6837614
miket

Re: Acces problem with PEAP/MSCHAPv2

Post by miket »

Hi !
redshot wrote:Hello, I have the same problem. Its an eduroam network, protected with 802.1x authentication, and I can't connect, it returns to the login screen.
Meanwhile, all Ubuntu laptops around me can connect, while I only get frustrated :D
Thanks in advance.
This is interesting as Mint is based on Ubuntu ?

How are the Ubuntu users connecting ?
What tools are they using ?
Do you not have the same funtionality in Mint ?

Let us know, we may be able to help you round this one.

Mike.
Husse

Re: Acces problem with PEAP/MSCHAPv2

Post by Husse »

Felicia XFCE
I can't experiment with wifi there as I don't have it installed on a computer with wifi
On Felicia main there is an option for tkip - it's just not called tkip
I use WPA Preshared key and TKIP on my wireless (one XP and one Mint laptop) and I have Elyssa main, Felicia KDE and Felicia main with mint4win all working fine
I might install XFCE on it to check but time is in short supply
I think the option you should use is called something with Personal in it
I'll ask merlwiz79 about this
Husse

Re: Acces problem with PEAP/MSCHAPv2

Post by Husse »

I could not follow you in the post above
Can you connect without the certificate?
Husse

Re: Acces problem with PEAP/MSCHAPv2

Post by Husse »

I'll ask miket to look at this again - I have no experience with certificates in this respect
miket

Re: Acces problem with PEAP/MSCHAPv2

Post by miket »

Hi !

This is an old problem that seems to have risen again ??
The explanation and fix is detailed here :

https://bugs.launchpad.net/ubuntu/+sour ... bug/107321

It may also be worth trying wicd instead of nm-applet (The default Gnome network manager) as it seems
to be far more reliable :)

Mike.
hir0
Level 1
Level 1
Posts: 6
Joined: Sat Mar 16, 2013 5:47 am

Re: Acces problem with PEAP/MSCHAPv2

Post by hir0 »

I had the same issue here with my Lenovo T420s and Mint 16 Petra.
Found a solution based on a nice hint in this bug history:
https://bugs.launchpad.net/ubuntu/+sour ... ug/1104476

[Snip]
Remove the line that I marked (line 20) , to fix it
This is an example of my NetworkManager profile.
This file is saved under /etc/NetworkManager/system-connections/
[Snip]


Remove the line that I marked (line 20) , to fix it
This file is saved under /etc/NetworkManager/system-connections/

Code: Select all

lnx ~ $ sudo cat /etc/NetworkManager/system-connections/wlan-bla 
[connection]
id=bla
uuid=bla
type=802-11-wireless

[802-11-wireless]
ssid=bla
mode=infrastructure
security=802-11-wireless-security

[802-11-wireless-security]
key-mgmt=wpa-eap

[ipv4]
method=auto

[ipv6]
method=auto

[802-1x]
eap=peap;
identity=bla
anonymous-identity=bla
#ca-cert=/home/gans/Documents/bla.cer
phase2-auth=mschapv2
password-flags=1
#system-ca-certs=true
Uncommenting the two lines made it work.
Looks like the "system-ca-certs=true" is always configured by network-manager regardles if you want or not....

Hope that help you too?
BR.h
Post Reply

Return to “Networking”