Acces problem with PEAP/MSCHAPv2

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Silvas
Level 1
Level 1
Posts: 2
Joined: Sun Mar 29, 2009 2:52 pm
Location: The Netherlands

Acces problem with PEAP/MSCHAPv2

Post by Silvas » Sun Mar 29, 2009 3:20 pm

First of all this distribution is great to use and everything seems to work flawless. Unfortunately I can't seem to get acces to my schools network.
It seems it's protected with PEAP/MSCHAPv2. I looked around for quite a bit but can't seem to find a working solution, mint just seems to work a little different.

Can somebody help me with this, it's pretty annoying. Oh yeah i use Felicia with XFCE desktop.

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Acces problem with PEAP/MSCHAPv2

Post by Husse » Sun Mar 29, 2009 6:10 pm

Image
Don't fix it if it ain't broken, don't break it if you can't fix it

Silvas
Level 1
Level 1
Posts: 2
Joined: Sun Mar 29, 2009 2:52 pm
Location: The Netherlands

Re: Acces problem with PEAP/MSCHAPv2

Post by Silvas » Tue Mar 31, 2009 5:39 am

thanks for pointing out some threats i over looked. I have played with some scripts and installed networkmanager for gnome. Unfortunately it still doesn't work. I will keep trying but for now I'm going to dual boot with windows. :?

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Acces problem with PEAP/MSCHAPv2

Post by Husse » Tue Mar 31, 2009 6:10 am

The problem is that this is not "normal" authentication WPA works perfectly in Linux
This means I can't get any experience with it - have to rely entirely on google
Does this help?
http://narnia.cs.ttu.edu/drupal/node/147
or this?
http://ohioloco.ubuntuforums.org/showth ... ?p=6837614
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

redshot
Level 1
Level 1
Posts: 4
Joined: Mon Apr 20, 2009 6:25 am

Re: Acces problem with PEAP/MSCHAPv2

Post by redshot » Mon Apr 20, 2009 6:42 am

Hello, I have the same problem. Its an eduroam network, protected with 802.1x authentication, and I can't connect, it returns to the login screen.

Meanwhile, all Ubuntu laptops around me can connect, while I only get frustrated :D

Thanks in advance.

User avatar
miket
Level 5
Level 5
Posts: 523
Joined: Tue Mar 04, 2008 5:50 am
Location: UK & France
Contact:

Re: Acces problem with PEAP/MSCHAPv2

Post by miket » Mon Apr 20, 2009 7:18 am

Hi !
redshot wrote:Hello, I have the same problem. Its an eduroam network, protected with 802.1x authentication, and I can't connect, it returns to the login screen.
Meanwhile, all Ubuntu laptops around me can connect, while I only get frustrated :D
Thanks in advance.
This is interesting as Mint is based on Ubuntu ?

How are the Ubuntu users connecting ?
What tools are they using ?
Do you not have the same funtionality in Mint ?

Let us know, we may be able to help you round this one.

Mike.

redshot
Level 1
Level 1
Posts: 4
Joined: Mon Apr 20, 2009 6:25 am

Re: Acces problem with PEAP/MSCHAPv2

Post by redshot » Mon Apr 20, 2009 4:49 pm

They are connecting with the NetworkManager. There are various authentication types we can use, like TTLS and PEAP. With Windows, I was able to connect with all authentications.

But, there is one authentication type which doesn't appear, and that may be the one which could allow me to connect. It's an "Inner Authentication", TKIP. It appears that Ubuntus use this authentication type to connect, and it doesn't appear on Mint. But it's weird, because I was supposed to be able to connect with all types of authentication.

Btw, I can connect to standard WEP secured networks.

Thanks in advance.

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Acces problem with PEAP/MSCHAPv2

Post by Husse » Tue Apr 21, 2009 6:09 am

Felicia XFCE
I can't experiment with wifi there as I don't have it installed on a computer with wifi
On Felicia main there is an option for tkip - it's just not called tkip
I use WPA Preshared key and TKIP on my wireless (one XP and one Mint laptop) and I have Elyssa main, Felicia KDE and Felicia main with mint4win all working fine
I might install XFCE on it to check but time is in short supply
I think the option you should use is called something with Personal in it
I'll ask merlwiz79 about this
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

redshot
Level 1
Level 1
Posts: 4
Joined: Mon Apr 20, 2009 6:25 am

Re: Acces problem with PEAP/MSCHAPv2

Post by redshot » Wed Apr 22, 2009 8:09 am

Hello there.

I think I found the problem. It is the CA Certificate. I found this because I was able to connect to the Ethernet without the certificate, and it uses the same authentication than Wireless.

But, when I try to edit the Network Settings in NetworkManager, I select the CA certificate provided, but if I close that window and open it again, the certificate isn't selected.

Thanks in advance.

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Acces problem with PEAP/MSCHAPv2

Post by Husse » Wed Apr 22, 2009 12:17 pm

I could not follow you in the post above
Can you connect without the certificate?
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

redshot
Level 1
Level 1
Posts: 4
Joined: Mon Apr 20, 2009 6:25 am

Re: Acces problem with PEAP/MSCHAPv2

Post by redshot » Thu Apr 23, 2009 11:57 am

Husse wrote:I could not follow you in the post above
Can you connect without the certificate?
I can connect to the Ethernet (cable) network without a certificate. But to connect to the Wireless network, the certificate is necessary.

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Acces problem with PEAP/MSCHAPv2

Post by Husse » Fri Apr 24, 2009 6:08 am

I'll ask miket to look at this again - I have no experience with certificates in this respect
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
miket
Level 5
Level 5
Posts: 523
Joined: Tue Mar 04, 2008 5:50 am
Location: UK & France
Contact:

Re: Acces problem with PEAP/MSCHAPv2

Post by miket » Fri Apr 24, 2009 7:28 am

Hi !

This is an old problem that seems to have risen again ??
The explanation and fix is detailed here :

https://bugs.launchpad.net/ubuntu/+sour ... bug/107321

It may also be worth trying wicd instead of nm-applet (The default Gnome network manager) as it seems
to be far more reliable :)

Mike.

hir0
Level 1
Level 1
Posts: 6
Joined: Sat Mar 16, 2013 5:47 am

Re: Acces problem with PEAP/MSCHAPv2

Post by hir0 » Wed Jan 08, 2014 5:20 am

I had the same issue here with my Lenovo T420s and Mint 16 Petra.
Found a solution based on a nice hint in this bug history:
https://bugs.launchpad.net/ubuntu/+sour ... ug/1104476

[Snip]
Remove the line that I marked (line 20) , to fix it
This is an example of my NetworkManager profile.
This file is saved under /etc/NetworkManager/system-connections/
[Snip]


Remove the line that I marked (line 20) , to fix it
This file is saved under /etc/NetworkManager/system-connections/

Code: Select all

lnx ~ $ sudo cat /etc/NetworkManager/system-connections/wlan-bla 
[connection]
id=bla
uuid=bla
type=802-11-wireless

[802-11-wireless]
ssid=bla
mode=infrastructure
security=802-11-wireless-security

[802-11-wireless-security]
key-mgmt=wpa-eap

[ipv4]
method=auto

[ipv6]
method=auto

[802-1x]
eap=peap;
identity=bla
anonymous-identity=bla
#ca-cert=/home/gans/Documents/bla.cer
phase2-auth=mschapv2
password-flags=1
#system-ca-certs=true
Uncommenting the two lines made it work.
Looks like the "system-ca-certs=true" is always configured by network-manager regardles if you want or not....

Hope that help you too?
BR.h

Post Reply

Return to “Wireless”