[SOLVED] How To? Install "ffmpeg" in LM-17 ???

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
Webtest
Level 4
Level 4
Posts: 306
Joined: Sun Feb 21, 2010 4:45 pm
Location: Carlisle, Pennsylvania, USA

[SOLVED] How To? Install "ffmpeg" in LM-17 ???

Post by Webtest »

Esteemed Forum Participants and Lurkers:
===============================
Mint 17.2 Mate 64 bit LiveMedia system

How can I install "ffmpeg" on my system ...
(as "sudo"):

Code: Select all

mint Desktop # apt-get install ffmpeg
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ffmpeg is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'ffmpeg' has no installation candidate
mint Desktop #
I have tried using "avconv" which DOES install, but most examples I have found are for "ffmpeg". Does this error mean that "ffmpeg" is not included in the package manager?

I'm using LM-17.2 due to several incompatibilities with later versions. Thank you for any and all comments, suggestions, and assistance.
Blessings in abundance, all the best, & ENJOY!
Art in Carlisle, PA USA
Last edited by Webtest on Fri Feb 17, 2017 10:45 am, edited 1 time in total.
BOAT - a hole in the water that you pour money into
LINUX - a hole in your life that you pour TIME into

HP dx2400 Core 2 Duo 8 GB. Mint 13/15/17.x/18.x Mate <on LOCKED SD cards, and Kanguru USB drives> No Hard Drive / No SSD

User avatar
austin.texas
Level 20
Level 20
Posts: 12048
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: How To? Install "ffmpeg" ???

Post by austin.texas »

This should be all you need:

Code: Select all

sudo apt-get install mint-meta-codecs
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

User avatar
Webtest
Level 4
Level 4
Posts: 306
Joined: Sun Feb 21, 2010 4:45 pm
Location: Carlisle, Pennsylvania, USA

Re: How To? Install "ffmpeg" ???

Post by Webtest »

Well austin.texas ... That didn't seem to work ...

Code: Select all

mint@mint ~ $ sudo -i
mint ~ # apt-get install mint-meta-codecs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
mint-meta-codecs is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
mint ~ # ffmpeg -h
ffmpeg: command not found
Thanks for trying ... what next?

Blessings in abundance, all the best, & ENJOY!
Art in Carlisle PA USA
BOAT - a hole in the water that you pour money into
LINUX - a hole in your life that you pour TIME into

HP dx2400 Core 2 Duo 8 GB. Mint 13/15/17.x/18.x Mate <on LOCKED SD cards, and Kanguru USB drives> No Hard Drive / No SSD

all41
Level 16
Level 16
Posts: 6081
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: How To? Install "ffmpeg" ???

Post by all41 »

You can get the latest ffmpeg here:
https://launchpad.net/~mc3man/+archive/ ... usty-media
libera ab tyrannis

User avatar
austin.texas
Level 20
Level 20
Posts: 12048
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: How To? Install "ffmpeg" ???

Post by austin.texas »

I think the only way you are going to get ffmpeg is via a PPA. It has been replaced by avconv - which is a fork of ffmpeg.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

User avatar
austin.texas
Level 20
Level 20
Posts: 12048
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: How To? Install "ffmpeg" ???

Post by austin.texas »

Well, look what just hit the Update Manager today !
fffmpeg.jpg

Code: Select all

~ $ apt-cache policy ffmpeg
ffmpeg:
  Installed: 7:2.8.11-0ubuntu0.16.04.1
  Candidate: 7:2.8.11-0ubuntu0.16.04.1
  Version table:
 *** 7:2.8.11-0ubuntu0.16.04.1 500
        500 http://cosmos.cites.illinois.edu/pub/ubuntu xenial-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages
        100 /var/lib/dpkg/status
     7:2.8.6-1ubuntu2 500
        500 http://cosmos.cites.illinois.edu/pub/ubuntu xenial/universe amd64 Packages
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

User avatar
Webtest
Level 4
Level 4
Posts: 306
Joined: Sun Feb 21, 2010 4:45 pm
Location: Carlisle, Pennsylvania, USA

Re: How To? Install "ffmpeg" ???

Post by Webtest »

Thanks All41 and Austin.Texas ...

I appreciate all of your helpful assistance. I haven't delved into the "Update Manager" suggestion yet, but I was able to get ffmpeg installed ... here are the basics on how it was accomplished ...

Code: Select all

Installing FFMpeg on Linux Mint 17.3 (works for 17.2 also!)
http://www.aptgetlife.co.uk/installing-ffmpeg-on-linux-mint-17-3/

sudo add-apt-repository ppa:mc3man/trusty-media
sudo apt-get update                           <-- updates the pkgmgr repo list
sudo apt-get install ffmpeg

This works ... be sure to do the "update" or nothing happens to the repos list

Haven't looked for examples yet ...
http://www.catswhocode.com/blog/19-ffmpeg-commands-for-all-needs
Many thanks again ... Blessings in abundance, all the best, & ENJOY!
Art in Carlisle PA USA
BOAT - a hole in the water that you pour money into
LINUX - a hole in your life that you pour TIME into

HP dx2400 Core 2 Duo 8 GB. Mint 13/15/17.x/18.x Mate <on LOCKED SD cards, and Kanguru USB drives> No Hard Drive / No SSD

all41
Level 16
Level 16
Posts: 6081
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: How To? Install "ffmpeg" ???

Post by all41 »

austin.texas wrote:Well, look what just hit the Update Manager today !
fffmpeg.jpg

Code: Select all

~ $ apt-cache policy ffmpeg
ffmpeg:
  Installed: 7:2.8.11-0ubuntu0.16.04.1
  Candidate: 7:2.8.11-0ubuntu0.16.04.1
  Version table:
 *** 7:2.8.11-0ubuntu0.16.04.1 500
        500 http://cosmos.cites.illinois.edu/pub/ubuntu xenial-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages
        100 /var/lib/dpkg/status
     7:2.8.6-1ubuntu2 500
        500 http://cosmos.cites.illinois.edu/pub/ubuntu xenial/universe amd64 Packages
Excellent.
I don't like referring beyond repositories for this--
I didn't see the update.
Is this for xenial only? Or because I have a newer package?

Code: Select all

~ $ apt-cache policy ffmpeg
ffmpeg:
  Installed: 7:3.2.2+git~trusty
  Candidate: 7:3.2.2+git~trusty
  Version table:
 *** 7:3.2.2+git~trusty 0
        100 /var/lib/dpkg/status
libera ab tyrannis

User avatar
austin.texas
Level 20
Level 20
Posts: 12048
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: How To? Install "ffmpeg" ???

Post by austin.texas »

all41 wrote:Is this for xenial only? Or because I have a newer package?
Because you have a newer package.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

Post Reply

Return to “Newbie Questions”