HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Questions about applications and software
Forum rules
Before you post please read how to get help
a_menace
Level 1
Level 1
Posts: 6
Joined: Sun Mar 19, 2017 11:37 am

HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by a_menace » Sun Mar 19, 2017 12:01 pm

Hi I am new to the forum and new to linux in general. I have been trying to get kodi working on a fresh install of Linux Mint 18.1 for weeks now.. It installs fine but when i try to run an addon it crashes. I have googled every error i get from the log with no success and I am starting to believe my problem is unique. I am way out of my league here so i am just going to post the log and hope someone can help me. First time using this forum i had to copy the text into a openoffice file to get it to upload.. sorry i didnt know of a better way.. Please help!! This is driving me crazy

Hoser Rob
Level 11
Level 11
Posts: 3863
Joined: Sat Dec 15, 2012 8:57 am

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by Hoser Rob » Sun Mar 19, 2017 12:39 pm

That crash log is 54 pages long ... I seriously doubt anyone's going to read all that.

All I can find indicates that Kodi 17 is just a bug fest. You'd probably be better off trying Kodi 16.1.

You didn't say how you installed Kodi or much else. Are you having any trouble playing media with other programs?

I don't think Kodi is in the 18 repos so I assume you used a ppa. If that's true, you'll have to uninstall Kodi first. Then go into Software Sources and delete that ppa.

Then copy/paste each line here one by one into the terminal (from http://askubuntu.com/questions/883850/w ... version-17):

Code: Select all

sudo apt-add-repository ppa:team-xbmc/kodi-old
sudo apt update
sudo apt install kodi

hhg123
Level 1
Level 1
Posts: 11
Joined: Sat Nov 26, 2016 12:45 pm

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by hhg123 » Sun Mar 19, 2017 1:37 pm

Issue has just started over past 10_days of Linux Mint 18.1 Cinnamon updates.
I did a new load of 18.0 & Kodi 16.1 back in Nov./Dec. 2016; no issues; also maintained all 18.0 updates as they came out.
Upgraded to 18.1, no issues; also maintained all 18.1 updates as they came out (Note: all public/generic drivers).
Kodi 16.1 updated to 17 [?] with, or at the same time of, one of 18.1 updates; no issues, except for me learning the new format (I think at least a month ago, now!).
Everything (that I used) worked great till recent 18.1 updates (past 10_days).
I cannot state exactly when; but in the past 10_days I noticed Kodi: menus/selections became very sensitive; then last night it would sometimes quickly close Kodi, back to Linux Mint main PC menu.
Note: I am up to date with all Mint 18.1 updates as of last Friday night or Saturday morning.
Today, Kodi is so sensitive, almost any key, especially if clicking through Kodi menu quickly will close Kodi, back to Linux Mint main PC menu.
I have restarted 18.1 multiple times and checked internet connection (hard connection); no issues till I go into Kodi as far as I can tell. Sometimes when I have program playing due to latency I use Ares Project. However, when I tried to use it to see if there was anything different, it states there is an ‘HTTP Error’ (first time ever this has come up!).
From this point I am stuck!!!

Penn
Level 5
Level 5
Posts: 740
Joined: Tue Jun 10, 2014 1:12 pm

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by Penn » Sun Mar 19, 2017 1:58 pm

As Hoser said, Kodi 17 seems to be a mess and you would be best off going back one version. I haven't used it but with the amount of people that were looking to roll back to 16 Jarvis it sounds to me like there is a reason they decided to call 17 Krypton(ite).

The simple method that may work

Code: Select all

sudo apt-get remove kodi
Then open Software Sources and remove the 2 xbmc (kodi) lines that include the word stable or any others but I'm assuming you only have the stable ppa. Then do what Hoser has in that code box one line at a time. You will notice the new ppa has the word "old" in it meaning the old Jarvis version.

If you run into issues with this simple route you may need to get look at the threads from a month ago when people were first finding out Kyptonite is a bad thing but most of the bigger issues had Mint 17.X.

hhg123
Level 1
Level 1
Posts: 11
Joined: Sat Nov 26, 2016 12:45 pm

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by hhg123 » Sun Mar 19, 2017 2:15 pm

Yes, I can understand why Kodi 17 would have issues with Minit 17.?; I was having issue with Kodi 16.1 and Mint 17.? (?=latest).
This was the reason I went to Mint 18.0 the first chance I had; and all those quirky issues went away; I was so happy!

hhg123
Level 1
Level 1
Posts: 11
Joined: Sat Nov 26, 2016 12:45 pm

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by hhg123 » Sun Mar 19, 2017 10:37 pm

Kodi 17 was an auto update after Mint 18.1 had been installed and keep up to date (about 1 month ago).
Issues with Kodi 17, just started in past 7-10 day gradually got worst (became unusable today 19-March).
I tried reinstalling Kodi 17.1; after a complete uninstall including ppa using the uninstall instructions on Kodi web-site.
It appears to now be running fine; I did have to re-start Mint/Kodi several times.
Like I said Kodi 17.1 with Mint 18.1 (up to date) appears to be working fine, but only after restarting several times and giving it some time to work things out (?) with the complete re-install. Hope this helps someone.

peter_szekeres
Level 1
Level 1
Posts: 6
Joined: Mon Mar 20, 2017 2:28 am

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by peter_szekeres » Mon Mar 20, 2017 2:33 am

Exactly my symptoms as well, it worked just fine but yesterday it became unusable. I have regular Ubuntu 16.04.2 on my laptop and it works just fine there, but on the other two desktop computers in my household Kodi closes off immediately with core dump and generating very long error logs. I have no idea what is causing this, as long as I'm aware the exact same packages have been updated on booth ubuntu and linux mint 18.1 yesterday so any help would be great. Kodi is unusable in this state, I even moved the whole .kodi folder from ubuntu to linux mint to see if by chance an extension update broke some package in kodi itself but it made no difference.

Steve216c
Level 1
Level 1
Posts: 2
Joined: Mon Mar 20, 2017 2:39 pm

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by Steve216c » Mon Mar 20, 2017 3:00 pm

I have same problem on my Mint Mate Zotac bi323 PC exactly as described and since yesterday. I tried the commands suggest in terminal, but reinstalls seem to go back to latest kodi version.

On Raspian (pi), korora (laptop) kodi works fine. I am frustrated that Mint doesn't like kodi right now. And that i cannot get it to work despite trying unsuccessfully to repeat tips here and elsewhere... Not sure if kodi or mint build is at fault when other Linux OS work fine now on kodi

steviebones
Level 1
Level 1
Posts: 2
Joined: Mon Mar 20, 2017 5:58 pm

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by steviebones » Mon Mar 20, 2017 6:16 pm

DANG!
I feel a sense of relief now.Me too,my kodi krypton was working just fine a week ago,with mint 18.1.
I got paranoid,cause last year i was sued for copyright infringement from torrenting..lol ;-0
WHOO! I've tried numerous un-installs,wiping everything completely,moving user data folder away,
all to no avail = she keeps crashing when trying to load Exodus or Bob or Phoenix etc..
I'll try the Jarvis Distro,but i'm fried right now chasing this princess down..lol

Penn
Level 5
Level 5
Posts: 740
Joined: Tue Jun 10, 2014 1:12 pm

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by Penn » Mon Mar 20, 2017 6:25 pm

Steve216c wrote:I tried the commands suggest in terminal, but reinstalls seem to go back to latest kodi version.
I'm thinking you are forgetting to remove the ppa. No terminal command was given for it. I think that is

Code: Select all

sudo ppa-purge ppa:team-xbmc/ppa
If not, try the gui method in software sources.

Another command that might help would be to remove the downloaded deb for kyrptonite

Code: Select all

sudo apt-get autoclean

Steve216c
Level 1
Level 1
Posts: 2
Joined: Mon Mar 20, 2017 2:39 pm

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by Steve216c » Tue Mar 21, 2017 4:44 pm

Bizarrely, everything is working today... A ghost in the machine perhaps?

There was an add on update though when i powered kodi up, so perhaps it was a bug fix.

33windowlicker
Level 1
Level 1
Posts: 39
Joined: Mon Sep 26, 2016 2:53 pm

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by 33windowlicker » Thu Mar 23, 2017 4:53 am

Steve216c wrote:Bizarrely, everything is working today... A ghost in the machine perhaps?

There was an add on update though when i powered kodi up, so perhaps it was a bug fix.
Which addon updated? My Kodi is still broken =(

User avatar
greerd
Level 5
Level 5
Posts: 941
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by greerd » Thu Mar 23, 2017 7:18 am

33windowlicker wrote:Which addon updated? My Kodi is still broken =(
There was an update to kodi and kodi-bin (17.0 to 17.1) in the repos that evening, I suspect that was the fix.
Have you updated your system via Update Manager?

EDIT: The update was via the kodi ppa, do you have the ppa added to your software sources?

Code: Select all

sudo add-apt-repository ppa:team-xbmc/ppa
sudo apt-get update
then update via your Update Manager.
Image

peter_szekeres
Level 1
Level 1
Posts: 6
Joined: Mon Mar 20, 2017 2:28 am

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by peter_szekeres » Fri Mar 24, 2017 3:34 am

Even with that update it's still crashing on me. I can still use it without problems on vanilla ubuntu however.

Truecrazy
Level 1
Level 1
Posts: 2
Joined: Fri Mar 24, 2017 6:25 am

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by Truecrazy » Fri Mar 24, 2017 6:35 am

Me too. Same issues after last update Linux mint kde (from 1-2 weeks ago).Other my friends with mint 18 have same issues!
Here the crash log:
http://pastebin.com/10yHj1jP

User avatar
greerd
Level 5
Level 5
Posts: 941
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by greerd » Fri Mar 24, 2017 8:12 am

peter_szekeres wrote:Even with that update it's still crashing on me. I can still use it without problems on vanilla ubuntu however.
Did you try reverting back to 16.x using the previous entries from Penn and Hoser Rob? I'll summarize the the procedure, from a terminal depressing enter after each command: (you should only have to enter your password once)

Code: Select all

sudo apt-get remove kodi
sudo ppa-purge ppa:team-xbmc/ppa
sudo apt-add-repository ppa:team-xbmc/kodi-old
sudo apt update
sudo apt install kodi
Does this work?
Image

Truecrazy
Level 1
Level 1
Posts: 2
Joined: Fri Mar 24, 2017 6:25 am

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by Truecrazy » Fri Mar 24, 2017 9:41 am

I have found the solution in kodi forum! It work for me!


http://forum.kodi.tv/showthread.php?tid=304613&page=2

peter_szekeres
Level 1
Level 1
Posts: 6
Joined: Mon Mar 20, 2017 2:28 am

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by peter_szekeres » Sun Mar 26, 2017 4:27 am

greerd wrote:
peter_szekeres wrote:Even with that update it's still crashing on me. I can still use it without problems on vanilla ubuntu however.
Did you try reverting back to 16.x using the previous entries from Penn and Hoser Rob? I'll summarize the the procedure, from a terminal depressing enter after each command: (you should only have to enter your password once)

Code: Select all

sudo apt-get remove kodi
sudo ppa-purge ppa:team-xbmc/ppa
sudo apt-add-repository ppa:team-xbmc/kodi-old
sudo apt update
sudo apt install kodi
Does this work?
These steps should work, but they don't since there is still a missing package that will not allow kodi to be installed. I had to manually download and install 'libcrossguid1' from here to work: "http://ppa.launchpad.net/team-xbmc/ppa/ ... _amd64.deb". But anyway this 16.1 version is also crashing and showing same symptoms as 17.1. I have no idea what is up with this or what Linux Mint changed but it completely broke this application for me. :(

peter_szekeres
Level 1
Level 1
Posts: 6
Joined: Mon Mar 20, 2017 2:28 am

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by peter_szekeres » Sun Mar 26, 2017 4:36 am

Truecrazy wrote:I have found the solution in kodi forum! It work for me!


http://forum.kodi.tv/showthread.php?tid=304613&page=2
This actually seems to have solved the issue I had, will have to test a bit but so far it looks great. A little change to the solution, I had to use apt to install the packages because dpkg was reluctant to do so for me.

wget http://launchpadlibrarian.net/299484105 ... _amd64.deb
wget http://launchpadlibrarian.net/292839640 ... -1_all.deb

sudo apt install ~/python-cryptography_1.7.1-2_amd64.deb ~/python-openssl_16.2.0-1_all.deb

Penn
Level 5
Level 5
Posts: 740
Joined: Tue Jun 10, 2014 1:12 pm

Re: HELP!! Kodi 17 crashes when using addons in Linux Mint 18.1

Post by Penn » Sun Mar 26, 2017 10:39 am

peter_szekeres wrote:These steps should work, but they don't since there is still a missing package that will not allow kodi to be installed. I had to manually download and install 'libcrossguid1' from here to work: "http://ppa.launchpad.net/team-xbmc/ppa/ ... _amd64.deb". But anyway this 16.1 version is also crashing and showing same symptoms as 17.1. I have no idea what is up with this or what Linux Mint changed but it completely broke this application for me. :(
It isn't a matter of what Mint did. For one thing, the issues exist with the Ubuntu base but even that isn't a matter of Ubuntu doing or not doing something. In fact, that is the first time I can recall anyone having issues with 16.1 in Mint so that seems unique to you.

Part of the packaging for a deb file is to include dependency or recommends information. This doesn't only include what packages are needed but the minimum version number. Kodi failed to do that as can be evidence by your next post about the solution. Furthermore, if the PPA and deb were written correct crossguid would install automatically instead of needing to get it manually.

By the way, that link you gave is for Xenial 64 bit which means if someone needs the 32 bit that won't get it done. This isn't meant to demean you but to point out how easy it is to not manage to accommodate the needs of every system.

Kodi is very useful when it works but going all the way back to when it was XBMC on the X-Box it was designed for it has been buggy. For a lot of people that "when it works" is never. Contrary to what the Kodi fanboy in the link where you found the solution says, Kodi developers are sloppy.

Post Reply

Return to “Software & Applications”