[SOLVED] samba install failed

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
soky
Level 1
Level 1
Posts: 5
Joined: Tue Apr 25, 2017 8:54 am

[SOLVED] samba install failed

Post by soky » Tue Apr 25, 2017 9:21 am

Hi all,

I have a new installed Linux Mint 18.1 Serena and like it!
But I can not install samba:
sudo apt install samba

Code: Select all

Setting up samba (2:4.3.11+dfsg-0ubuntu0.16.04.6) ...
Job for smbd.service failed because the control process exited with error code. See "systemctl status smbd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript smbd, action "start" failed.
● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
   Loaded: loaded (/etc/init.d/smbd; bad; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2017-04-25 14:36:49 CEST; 5ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 2415 ExecStart=/etc/init.d/smbd start (code=exited, status=1/FAILURE)

Apr 25 14:36:48 HP-Z400 systemd[1]: Starting LSB: start Samba SMB/CIFS daemon (smbd)...
Apr 25 14:36:49 HP-Z400 smbd[2415]:  * Starting SMB/CIFS daemon smbd
Apr 25 14:36:49 HP-Z400 smbd[2415]:    ...fail!
Apr 25 14:36:49 HP-Z400 systemd[1]: smbd.service: Control process exited, code=exited status=1
Apr 25 14:36:49 HP-Z400 systemd[1]: Failed to start LSB: start Samba SMB/CIFS daemon (smbd).
Apr 25 14:36:49 HP-Z400 systemd[1]: smbd.service: Unit entered failed state.
Apr 25 14:36:49 HP-Z400 systemd[1]: smbd.service: Failed with result 'exit-code'.
dpkg: error processing package samba (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin (2.23-0ubuntu7) ...
Errors were encountered while processing:
 samba
E: Sub-process /usr/bin/dpkg returned an error code (1)
I have been updated and upgraded apt without result. The synaptic could not help too.
I can not figure out what missing or wrong for smbd.
Last edited by soky on Wed Apr 26, 2017 5:23 am, edited 1 time in total.

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: samba install failed

Post by austin.texas » Tue Apr 25, 2017 10:16 am

There are a couple of commands you can run to see if they help.
A command which repairs possible unmet dependencies:

Code: Select all

apt install --reinstall -f samba
A command to reconfigure all installed programs which may not be configured properly:

Code: Select all

sudo dpkg --configure -a
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

User avatar
richyrich
Level 19
Level 19
Posts: 9075
Joined: Mon May 04, 2009 8:31 pm

Re: samba install failed

Post by richyrich » Tue Apr 25, 2017 10:22 am

Here is a recent tutorial for Mint 18 by one of our members. :-)
(please read through the replies, as there is lots of good info)
Installing Samba Server in Mint 18

soky
Level 1
Level 1
Posts: 5
Joined: Tue Apr 25, 2017 8:54 am

Re: samba install failed

Post by soky » Tue Apr 25, 2017 2:24 pm

Thank you, I'll try it tomorrow, and this is promising too: viewtopic.php?f=238&t=225026&p=1186737& ... l#p1186737

soky
Level 1
Level 1
Posts: 5
Joined: Tue Apr 25, 2017 8:54 am

Re: samba install failed

Post by soky » Wed Apr 26, 2017 4:24 am

I have been made the following:

Code: Select all

HP-Z400 ~ # apt-get remove --purge samba samba-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  python-dnspython
Use 'sudo apt autoremove' to remove it.
The following packages will be REMOVED:
  casper* cifs-utils* lupin-casper* mint-meta-cinnamon* nemo-share* samba* samba-common* samba-common-bin* smbclient*
0 upgraded, 0 newly installed, 9 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 15,7 MB disk space will be freed.
Do you want to continue? [Y/n] 
(Reading database ... 205295 files and directories currently installed.)
Removing samba (2:4.3.11+dfsg-0ubuntu0.16.04.6) ...
Purging configuration files for samba (2:4.3.11+dfsg-0ubuntu0.16.04.6) ...
Removing lupin-casper (0.57) ...
Removing casper (1.376.2) ...
Purging configuration files for casper (1.376.2) ...
Removing cifs-utils (2:6.4-1ubuntu1.1) ...
Purging configuration files for cifs-utils (2:6.4-1ubuntu1.1) ...
Removing mint-meta-cinnamon (2016.11.28) ...
Removing nemo-share (3.2.0+serena) ...
Removing smbclient (2:4.3.11+dfsg-0ubuntu0.16.04.6) ...
Removing samba-common-bin (2:4.3.11+dfsg-0ubuntu0.16.04.6) ...
Removing samba-common (2:4.3.11+dfsg-0ubuntu0.16.04.6) ...
Purging configuration files for samba-common (2:4.3.11+dfsg-0ubuntu0.16.04.6) ...
Processing triggers for libc-bin (2.23-0ubuntu7) ...
Processing triggers for man-db (2.7.5-1) ...

Code: Select all

HP-Z400 ~ # apt-get install samba
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  samba-common samba-common-bin
Suggested packages:
  bind9 bind9utils ctdb ldb-tools smbldap-tools winbind heimdal-clients
Recommended packages:
  samba-dsdb-modules samba-vfs-modules
The following NEW packages will be installed:
  samba samba-common samba-common-bin
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/1.498 kB of archives.
After this operation, 13,3 MB of additional disk space will be used.
Do you want to continue? [Y/n] 
Preconfiguring packages ...
Selecting previously unselected package samba-common.
(Reading database ... 204860 files and directories currently installed.)
Preparing to unpack .../samba-common_2%3a4.3.11+dfsg-0ubuntu0.16.04.6_all.deb ...
Unpacking samba-common (2:4.3.11+dfsg-0ubuntu0.16.04.6) ...
Selecting previously unselected package samba-common-bin.
Preparing to unpack .../samba-common-bin_2%3a4.3.11+dfsg-0ubuntu0.16.04.6_amd64.deb ...
Unpacking samba-common-bin (2:4.3.11+dfsg-0ubuntu0.16.04.6) ...
Selecting previously unselected package samba.
Preparing to unpack .../samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.6_amd64.deb ...
Unpacking samba (2:4.3.11+dfsg-0ubuntu0.16.04.6) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for libc-bin (2.23-0ubuntu7) ...
Processing triggers for systemd (229-4ubuntu16) ...
Processing triggers for ureadahead (0.100.0-19) ...
Processing triggers for ufw (0.35-0ubuntu2) ...
Setting up samba-common (2:4.3.11+dfsg-0ubuntu0.16.04.6) ...

Creating config file /etc/samba/smb.conf with new version
Setting up samba-common-bin (2:4.3.11+dfsg-0ubuntu0.16.04.6) ...
Setting up samba (2:4.3.11+dfsg-0ubuntu0.16.04.6) ...
Processing triggers for libc-bin (2.23-0ubuntu7) ...
Processing triggers for systemd (229-4ubuntu16) ...
Processing triggers for ureadahead (0.100.0-19) ...
Processing triggers for ufw (0.35-0ubuntu2) ...
Renstall what deleted in the first command:

Code: Select all

HP-Z400 ~ # apt install casper* cifs-utils* lupin-casper* mint-meta-cinnamon* nemo-share* smbclient*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'casper' for glob 'casper*'
Note, selecting 'cifs-utils' for glob 'cifs-utils*'
Note, selecting 'lupin-casper' for glob 'lupin-casper*'
Note, selecting 'mint-meta-cinnamon' for glob 'mint-meta-cinnamon*'
Note, selecting 'mint-meta-cinnamon-dvd' for glob 'mint-meta-cinnamon*'
Note, selecting 'nemo-share' for glob 'nemo-share*'
Note, selecting 'smbclient' for glob 'smbclient*'
Suggested packages:
  winbind heimdal-clients
The following NEW packages will be installed:
  casper cifs-utils lupin-casper mint-meta-cinnamon nemo-share smbclient
0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 114 kB/499 kB of archives.
After this operation, 2.440 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 casper amd64 1.376.2 [44,8 kB]
Get:2 http://archive.ubuntu.com/ubuntu xenial/main amd64 lupin-casper all 0.57 [5.876 B]
Get:3 http://packages.linuxmint.com serena/backport amd64 nemo-share amd64 3.2.0+serena [58,7 kB]
Get:4 http://packages.linuxmint.com serena/main amd64 mint-meta-cinnamon all 2016.11.28 [4.202 B]
Fetched 114 kB in 0s (162 kB/s)               
Selecting previously unselected package smbclient.
(Reading database ... 205111 files and directories currently installed.)
Preparing to unpack .../smbclient_2%3a4.3.11+dfsg-0ubuntu0.16.04.6_amd64.deb ...
Unpacking smbclient (2:4.3.11+dfsg-0ubuntu0.16.04.6) ...
Selecting previously unselected package cifs-utils.
Preparing to unpack .../cifs-utils_2%3a6.4-1ubuntu1.1_amd64.deb ...
Unpacking cifs-utils (2:6.4-1ubuntu1.1) ...
Selecting previously unselected package nemo-share.
Preparing to unpack .../nemo-share_3.2.0+serena_amd64.deb ...
Unpacking nemo-share (3.2.0+serena) ...
Selecting previously unselected package mint-meta-cinnamon.
Preparing to unpack .../mint-meta-cinnamon_2016.11.28_all.deb ...
Unpacking mint-meta-cinnamon (2016.11.28) ...
Selecting previously unselected package casper.
Preparing to unpack .../casper_1.376.2_amd64.deb ...
Unpacking casper (1.376.2) ...
Selecting previously unselected package lupin-casper.
Preparing to unpack .../lupin-casper_0.57_all.deb ...
Unpacking lupin-casper (0.57) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up smbclient (2:4.3.11+dfsg-0ubuntu0.16.04.6) ...
Setting up cifs-utils (2:6.4-1ubuntu1.1) ...
Setting up nemo-share (3.2.0+serena) ...
Setting up mint-meta-cinnamon (2016.11.28) ...
Setting up casper (1.376.2) ...
update-initramfs: deferring update (trigger activated)
Setting up lupin-casper (0.57) ...
Processing triggers for initramfs-tools (0.122ubuntu8.8) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-53-generic
Warning: No support for locale: en_US.utf8
HP-Z400 ~ # apt autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
HP-Z400 ~ # 
It looks okay, thanks for everybody!

Post Reply

Return to “Software & Applications”