Disable autologin for KDE live USB

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Jaydemir
Level 4
Level 4
Posts: 216
Joined: Tue Jun 16, 2015 2:53 pm

Disable autologin for KDE live USB

Post by Jaydemir »

So I'm trying to make it that my live usb image of Mint 18.1 KDE doesn't auto-login on boot (like Live CDs typically do.) Searching the Googles, I found all sorts of files I'm 'supposed' to edit that don't exist, but finally stumble on sddm.conf.

The problem is that when I edit and reboot, it self-adds another entry to autologin mint. Is there another file I need to look for?
User avatar
austin.texas
Level 20
Level 20
Posts: 12045
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Disable autologin for KDE live USB

Post by austin.texas »

If you don't want the Mint usb to boot when you start up, you need to change the boot order in your BIOS settings.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018
Jaydemir
Level 4
Level 4
Posts: 216
Joined: Tue Jun 16, 2015 2:53 pm

Re: Disable autologin for KDE live USB

Post by Jaydemir »

austin.texas wrote:If you don't want the Mint usb to boot when you start up, you need to change the boot order in your BIOS settings.
That isn't what I mean. I have a live USB on my keychain that I use as a portable OS. If someone happens to grab my keychain, I don't want my OS to automatically let them into my system with root access.

I want to just have it boot to a login screen with no 'mint' or 'livesessionuser' account.
User avatar
austin.texas
Level 20
Level 20
Posts: 12045
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Disable autologin for KDE live USB

Post by austin.texas »

Someone knowledgeable could use their own live OS. The sure way to prevent that is to set a BIOS password, if your BIOS has that capability.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018
Jaydemir
Level 4
Level 4
Posts: 216
Joined: Tue Jun 16, 2015 2:53 pm

Re: Disable autologin for KDE live USB

Post by Jaydemir »

austin.texas wrote:Someone knowledgeable could use their own live OS. The sure way to prevent that is to set a BIOS password, if your BIOS has that capability.
Yeah, but a BIOS password on my desktop doesn't stop them from accessing my OS on their own computer.
User avatar
austin.texas
Level 20
Level 20
Posts: 12045
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Disable autologin for KDE live USB

Post by austin.texas »

In your first post you said it was the live Mint, but apparently it is an installed OS, or using persistence?
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018
Jaydemir
Level 4
Level 4
Posts: 216
Joined: Tue Jun 16, 2015 2:53 pm

Re: Disable autologin for KDE live USB

Post by Jaydemir »

austin.texas wrote:In your first post you said it was the live Mint, but apparently it is an installed OS, or using persistence?
A live Mint USING persistence. Sorry for being unclear.

Edit: nevermind. I think I know what the deal is.

I used a tool to create an EXT4 partition for persistent data, but the Live CD settings itself is NOT persistent (Since it's based on Ubuntu 16+). No matter what settings I change, they always revert back. This would explain why the sddm.conf file always reverts as well.

All in all, I might need to reconsider how I have the OS installed on the USB. I wanted to use a LiveCD because it gives me the option to boot regardless of BIOS or UEFI, where a fully installed OS makes me commit to one or the other. I'll just have to keep the drive under lock and key.
Post Reply

Return to “Installation & Boot”