Touchpad issues in Linux mint 18.1 serena

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
bismeet
Level 1
Level 1
Posts: 4
Joined: Sun Jun 18, 2017 9:38 pm

Touchpad issues in Linux mint 18.1 serena

Post by bismeet » Mon Jun 19, 2017 6:32 am

I have a Linux mint 18.1 Serena Dell laptop with kernel 4.4.0-79-generic version.
And this is the output of xinput list:

Code: Select all

[code]Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ DELL0794:00 06CB:7F13                   	id=11	[slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad              	id=14	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                    	id=10	[slave  keyboard (3)]
    ↳ Intel HID events                        	id=12	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=13	[slave  keyboard (3)]
    ↳ Dell WMI hotkeys                        	id=15	[slave  keyboard (3)]
[/code]
Everything is fine here except for the random jumps of the touchpad .It seems to scroll to the bottom of the page at random. Also,while typing the cursor jumps back few spaces every few minutes which is really irritating.Hope I can get some help.

User avatar
Pjotr
Level 20
Level 20
Posts: 10068
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Touchpad issues in Linux mint 18.1 serena

Post by Pjotr » Mon Jun 19, 2017 6:52 am

Disable the touchpad while typing:

1. Cinnamon:
https://sites.google.com/site/easylinux ... ile-typing
(item 2.11, right column)

2. Xfce:
https://sites.google.com/site/easylinux ... d-touchpad
(item 2.9, right column)
Tip: 10 things to do after installing Linux Mint 18.3 Sylvia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

bismeet
Level 1
Level 1
Posts: 4
Joined: Sun Jun 18, 2017 9:38 pm

Re: Touchpad issues in Linux mint 18.1 serena

Post by bismeet » Sat Jul 01, 2017 4:29 am

Disabling ain't the proper solution . I have to wait till it detects I stopped typing.

User avatar
Pjotr
Level 20
Level 20
Posts: 10068
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Touchpad issues in Linux mint 18.1 serena

Post by Pjotr » Sat Jul 01, 2017 4:37 am

bismeet wrote:Disabling ain't the proper solution . I have to wait till it detects I stopped typing.
If you have to wait too long, simply decrease the interval. To 0.5 seconds instead of 1.0, for example.
Tip: 10 things to do after installing Linux Mint 18.3 Sylvia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Post Reply

Return to “Newbie Questions”