Problem trying to get Linux Mint to boot from an iSCSI target [SOLVED]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
thelamelotl
Level 1
Level 1
Posts: 3
Joined: Mon Jun 26, 2017 10:55 pm

Problem trying to get Linux Mint to boot from an iSCSI target [SOLVED]

Post by thelamelotl »

I'm new in these forums but I have a pretty decent amount of experience with linux so I'm not exactly a newbie of it. I'm administrating a school computer lab which has 21 HP t610 thin clients and a server which runs Ubuntu Server and all computers are connected to a gigabit LAN network.

In my situation, the thin clients run Linux Mint XFCE which is booted from the server via PXE using the commonly used PXELINUX & TFTP configuration which I was able to setup. However, while performance was okay with 4 to 6 clients used actively, the performance becomes mediocre when all 21 clients are used actively and we even experienced some significant stability issues as well.

I suspect the poor performance is due to overhead of TFTP so I'm switching over to using iSCSI as I've read that it is much faster as the protocol has less overhead and it allows Linux to take advantage of buffering as if was running off of a hard drive. It also allows me to limit how much disk space the clients are allowed to have.

I followed this guide to setup Linux Mint to boot off of an iSCSI target and I was able to successfully perform all the steps described. However, it appears that during the startup process in initramfs, it does not appear to connect to the iSCSI target that contains the root directory of the operating system as if the ISCSI_* startup parameters have no effect. This of course results to error of not being able to mount the root directory and drops to the busybox prompt.

I thought it was PXELINUX being the cause of the problem so I switched to iPXE but I still have the same exact problem of not being able to connect to the iSCSI target during the initramfs startup process.

Upon further inspection, I notice that the iscsi-init kernel module wasn't included into the initramfs image which I think is the likely reason why the ISCSI_* parameters were not working. In fact, I don't seem to find iscsi-init included with open-iscsi at all. I don't know if it was renamed or removed from the package at some point. I've searched all over the internet regarding this issue but I was not able to find anything related to my problem.

Any help will be greatly appreciated.
Last edited by thelamelotl on Wed Jun 28, 2017 8:48 am, edited 1 time in total.

thelamelotl
Level 1
Level 1
Posts: 3
Joined: Mon Jun 26, 2017 10:55 pm

Re: Problem trying to get Linux Mint to boot from an iSCSI target

Post by thelamelotl »

Not meaning to bump but I should add that there's nothing wrong with my iSCSI target as I can connect to it as well as do a bunch of things on it such as partitioning and formatting no problem. iPXE also had no issue connecting to the iSCSI target and was even able to load GRUB from the target. The problem is that during the initramfs startup phase, it does not appear to do anything to connect to the iSCSI target as if the boot parameters related to ISCSI connectivity had no effect.

thelamelotl
Level 1
Level 1
Posts: 3
Joined: Mon Jun 26, 2017 10:55 pm

Re: Problem trying to get Linux Mint to boot from an iSCSI target

Post by thelamelotl »

Well, I finally figured out myself as to why the ISCSI_* options weren't working. Turns out I need to set MODULES to netboot inside /etc/initramfs-tools/initramfs.conf. With that set, the kernel will initialize the network interface and of course, connect to the iSCSI target and mounting the root file system to the iSCSI target during startup finally works.

For some reason, the tutorial left that very important step out. Anyway, all is well and good.

Post Reply

Return to “Installation & Boot”