[SOLVED] gnome-keyring-daemon prevents shutdown

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
rbsudo
Level 2
Level 2
Posts: 57
Joined: Sat Jul 15, 2017 10:59 am

[SOLVED] gnome-keyring-daemon prevents shutdown

Post by rbsudo » Sat Jul 15, 2017 11:34 am

Hi,

I've just recently installed Linux Mint 18.2 on my desktop, and like it very much so far.

The one thing that I've noticed happening a few times now is that when I go to shut it down, I will get a message...
gnome-keyring-daemon not responding
waiting for program to finish
It never finishes.

It just happened the last time I was using the pc after browsing on the internet and being on youtube (with Firefox and Chromium).... nothing else.

I don't know what is prompting this message to appear. How do I stop it from appearing? I've been forcing the system to shutdown by clicking on the option that allows me to force the shutdown.

Thanks for your suggestions.
Last edited by rbsudo on Mon Jul 17, 2017 9:31 am, edited 1 time in total.
Linux Mint 18.3 Sylvia.. Cinnamon.. 32-bit and 64-bit
"I learn by going where I have to go," Roethke

rbsudo
Level 2
Level 2
Posts: 57
Joined: Sat Jul 15, 2017 10:59 am

Re: gnome-keyring-daemon prevents shutdown

Post by rbsudo » Sat Jul 15, 2017 8:19 pm

This problem persisted all afternoon whenever I did a shutdown. I did a search and saw where someone had a different problem with gnome-keyring-daemon and they wound up disabling it.
I decided to try that and see what happens. Here's what I did (as root):

usr/bin/gnome-keyring-daemon/properties/permissions

unclick "Allow executing file as program"

So far it's been a clean shutdown, and I have not had the issue. I also haven't seen any other issues pop up as a result of what I did. I know this is not ideal, but I'll keep checking it out.
Just wondering if "Allow executing file as program" is turned on (ie., checked) in others s/w? Is that the default? Thanks.
Linux Mint 18.3 Sylvia.. Cinnamon.. 32-bit and 64-bit
"I learn by going where I have to go," Roethke

rbsudo
Level 2
Level 2
Posts: 57
Joined: Sat Jul 15, 2017 10:59 am

Re: gnome-keyring-daemon prevents shutdown

Post by rbsudo » Mon Jul 17, 2017 9:28 am

I wasn't comfortable with having disabled the gnome-keyring-daemon so I enabled it back on and got the same indication at shutdown that it was not responding.
I then decided to go ahead and reinstall Linux Mint 18.2, and, since then, everything has been working normal..... no more keyring messages at shutdown.
All I can figure is that it must have been something I altered right after that first install.
Linux Mint 18.3 Sylvia.. Cinnamon.. 32-bit and 64-bit
"I learn by going where I have to go," Roethke

styx
Level 1
Level 1
Posts: 1
Joined: Mon Sep 11, 2017 9:20 am

Re: [SOLVED] gnome-keyring-daemon prevents shutdown

Post by styx » Mon Sep 11, 2017 10:11 am

After upgrading from Linux Mint 18.1 Serena to Linux Mint 18.2 Sonya, I also decided to update the system kernel from 4.4.0-53 to 4.10.0-33. After the update, there was the same problem as you had with gnome-keyring-daemon, which prevented the computer from shutting down in normal mode. After some thought I rolled the system back to the old kernel 4.4.0-53, the problem disappeared. Therefore, it is the kernel update.

User avatar
jeanpaulberes
Level 2
Level 2
Posts: 75
Joined: Thu Jun 04, 2015 7:08 am
Location: Belgium
Contact:

Re: [SOLVED] gnome-keyring-daemon prevents shutdown

Post by jeanpaulberes » Mon Sep 11, 2017 4:33 pm

Dear,

In such cases you can or in Terminal or in Command HUD (Alt F2) type the command

shutdown now

This will force an immediate shutdown

Regards,
JP

Post Reply

Return to “Newbie Questions”