Applets won't install or update

Please post suggestions for improvement of Cinnamon on:
Post Reply
Level 3
Level 3
Posts: 153
Joined: Tue Jun 04, 2013 4:26 pm

Applets won't install or update

Post by hpmc13 »

I was trying to update some of the applets on Cinnamon and each of them failed. I also tried to install new applets that I had never installed before and got the same error message:

Code: Select all

An error occurred during installation or updating.  You may wish to report this incident to the developer of cpufreq@mtwebster.

If this was an update, the previous installation is unchanged

Details:  [Errno 2] No such file or directory
The only thing that changes is the e-mail address of the developer. For those that were upgrades I uninstalled the applet then tried to install it again to no avail. Running cinnamon-settings applets in a terminal brings up the following error when trying to update or install:

Code: Select all

Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
Any help is greatly appreciated.

Code: Select all

System:    Host: workpc Kernel: 4.10.0-27-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.4 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.2 Sonya
Machine:   System: Gigabyte product: N/A
           Mobo: Gigabyte model: 990FXA-UD3 R5 v: x.x Bios: American Megatrends v: F2 date: 04/01/2015
CPU:       Octa core AMD FX-8350 Eight-Core (-MCP-) cache: 16384 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 70722
           clock speeds: max: 4400 MHz 1: 1400 MHz 2: 1400 MHz 3: 2100 MHz 4: 2800 MHz 5: 3400 MHz 6: 1400 MHz
           7: 1400 MHz 8: 1400 MHz
Graphics:  Card: NVIDIA GM206 [GeForce GTX 960] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 driver: nvidia Resolution: 1280x1024@60.02hz, 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 960/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 381.22 Direct Rendering: Yes
Audio:     Card-1 NVIDIA Device 0fba driver: snd_hda_intel bus-ID: 01:00.1 Sound: ALSA v: k4.10.0-27-generic
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: c000 bus-ID: 05:00.0
           IF: eth1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1440.3GB (38.6% used) ID-1: /dev/sda model: ZOTAC_ZTSSD size: 120.0GB temp: 30C
           ID-2: /dev/sdb model: WDC_WD10EZEX size: 1000.2GB temp: 37C
           ID-3: /dev/sdc model: WDC_WD3200AAJS size: 320.1GB temp: 39C
Partition: ID-1: / size: 20G used: 12G (61%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 39G used: 3.7G (10%) fs: ext4 dev: /dev/sda2
           ID-3: swap-1 size: 2.14GB used: 0.00GB (0%) fs: swap dev: /dev/sda4
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 42.0C mobo: 31.8C gpu: 0.0:40C
           Fan Speeds (in rpm): cpu: 919 fan-2: 0 fan-3: 0 fan-4: 1295 fan-5: 0
Info:      Processes: 252 Uptime: 14:28 Memory: 1654.0/16011.4MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
Running LM 20 Cinnamon
Level 1
Level 1
Posts: 1
Joined: Thu Dec 28, 2017 4:49 pm

Re: Applets won't install or update

Post by ripster »

I'm having the exact same issue. I'm frustrated that there isn't anything being logged in ~/.cinnamon/glass.log
If I manually download an applet and put it into ~/.local/share/cinnamon/applets they seem to work just fine.
Even if nobody knows what the problem is I'd be happy to be pointed to a log file or some way to troubleshoot the applet installer.
Post Reply

Return to “Cinnamon”