[SOLVED] Turn off automatic login in 18.2?

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
InChrist
Level 4
Level 4
Posts: 203
Joined: Wed Apr 12, 2017 4:17 pm
Contact:

[SOLVED] Turn off automatic login in 18.2?

Post by InChrist » Fri Sep 01, 2017 5:43 am

Hi

I have turned on automatic login when installing 18.2 on a computer for friends. Now I want to be prompted again to have to enter the password on login. I tried login window, users ... but I could not find the option to disable automatic login.

Klaus
Last edited by InChrist on Fri Sep 01, 2017 7:45 am, edited 1 time in total.
I would be happy to receive competent clear help.
HP-ProBook-470-G3
Kernel: 4.13.0-39-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm
Distro: Linux Mint 18.3 Sylvia
(inxi -Szxx from 180425)

User avatar
k-314
Level 3
Level 3
Posts: 109
Joined: Sun Aug 06, 2017 4:42 am
Location: Germany

Re: Turn off automatic login in 18.2?

Post by k-314 » Fri Sep 01, 2017 5:49 am

On a Cinnamon desktop ...?

br
ASUS P5QL + Intel Core Duo E6750 @2.66GHz, Nvidia GEFORCE GT730
8GB DDR2-800, SSD 60GB, HDD 2TB, 250GB. Linux Mint 18.3 - Xfce

InChrist
Level 4
Level 4
Posts: 203
Joined: Wed Apr 12, 2017 4:17 pm
Contact:

Re: Turn off automatic login in 18.2?

Post by InChrist » Fri Sep 01, 2017 5:51 am

yes, 64 bit - funny on 18.1 in login window there are auto login options but not on 18.2
I would be happy to receive competent clear help.
HP-ProBook-470-G3
Kernel: 4.13.0-39-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm
Distro: Linux Mint 18.3 Sylvia
(inxi -Szxx from 180425)

User avatar
catweazel
Level 15
Level 15
Posts: 5917
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Turn off automatic login in 18.2?

Post by catweazel » Fri Sep 01, 2017 6:02 am

You must have performed an upgrade.

See the response by xenopeek, here: viewtopic.php?f=90&t=250723

There is no auto-login option in 18.2 Cinnamon as yet due to a switch from MDM to LightDM. The link describes a workaround for turning on auto-login. Presumably you reverse the procedure to turn it off.
A new scientific truth does not triumph by convincing its opponents and making them see the light, but rather because its opponents eventually die, and a new generation grows up that is familiar with it. - Max Planck

InChrist
Level 4
Level 4
Posts: 203
Joined: Wed Apr 12, 2017 4:17 pm
Contact:

Re: Turn off automatic login in 18.2?

Post by InChrist » Fri Sep 01, 2017 6:31 am

Thanks.

How to find viewtopic.php?f=90&t=250723?

I made a live usb-stick with the freshly downloaded 18.2 64 bit cinnamom from linuxmint.com.
And from this desktop I have installed it.
I would be happy to receive competent clear help.
HP-ProBook-470-G3
Kernel: 4.13.0-39-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm
Distro: Linux Mint 18.3 Sylvia
(inxi -Szxx from 180425)

User avatar
Pjotr
Level 20
Level 20
Posts: 10405
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Turn off automatic login in 18.2?

Post by Pjotr » Fri Sep 01, 2017 6:39 am

That means LightDM allright. :)

Code: Select all

gksudo xed /etc/lightdm/lightdm.conf
Put a hash tag before each line in that file, save it, close it and reboot.

Example of a "hash tagged" file:

Code: Select all

#[Seat:*]
#autologin-guest=false
#autologin-user=john
#autologin-user-timeout=0
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
catweazel
Level 15
Level 15
Posts: 5917
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Turn off automatic login in 18.2?

Post by catweazel » Fri Sep 01, 2017 6:42 am

InChrist wrote:Thanks.

How to find viewtopic.php?f=90&t=250723?
My apologies. I neglected the link. Pjotr's reply contains the same information.
A new scientific truth does not triumph by convincing its opponents and making them see the light, but rather because its opponents eventually die, and a new generation grows up that is familiar with it. - Max Planck

InChrist
Level 4
Level 4
Posts: 203
Joined: Wed Apr 12, 2017 4:17 pm
Contact:

Re: Turn off automatic login in 18.2?

Post by InChrist » Fri Sep 01, 2017 7:45 am

Thank you for the answers. I could change it and it works now without auto login.

I put a # before this line and now it prompts me do enter the password as I wished

Code: Select all

#autologin-user=myusername
So this would be the correct link I think
viewtopic.php?f=90&t=250723
I would be happy to receive competent clear help.
HP-ProBook-470-G3
Kernel: 4.13.0-39-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm
Distro: Linux Mint 18.3 Sylvia
(inxi -Szxx from 180425)

callagg2
Level 1
Level 1
Posts: 15
Joined: Sat Apr 19, 2014 6:25 am

Re: [SOLVED] Turn off automatic login in 18.2?

Post by callagg2 » Tue Sep 05, 2017 4:29 am

i've opened lightdm.conf
and the three lines were already there under defaults.
guest,....
username.....
etc
So i just reduced the countdown to 5 seconds, i did nothing else.

But whatever that did... the system will still not autologin,
but what is worse is that now i can't login in either - it won't even let me try to input a password.

At the login screen, it just keeps trying to autologin and the screen goes black for a second or two,
before returning to the login screen and trying to autologin again.

If i choose, CTRL+AlT+F2, before i even get a chance to login through the command line, it brings me back to the login screen.

What is the best way out of this loop?

//ah i got out of it.
Running an installation disk, i accessed the relevant file on the hard drive and changed it back.
all sorted now

Post Reply

Return to “Installation & Boot”