WiFi not found after installation

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Wed Sep 13, 2017 3:15 pm

Code: Select all

mint@mint ~ $ blkid
/dev/sda1: LABEL="System Reserved" UUID="3E5C13565C1307F3" TYPE="ntfs" PARTUUID="e445e445-01"
/dev/sda2: UUID="9EEC1769EC173B4B" TYPE="ntfs" PARTUUID="e445e445-02"
/dev/sda5: UUID="82554a19-6668-48b0-89be-31148a0ad2b8" TYPE="ext4" PARTUUID="e445e445-05"
/dev/sda4: UUID="54199622-8792-4b20-a40f-4999acd18bff" TYPE="swap" PARTUUID="e445e445-04"
/dev/sdb1: UUID="2017-06-29-11-09-27-00" LABEL="Linux Mint 18.2 Xfce 32-bit" TYPE="iso9660" PTUUID="4d40bfe0" PTTYPE="dos" PARTUUID="4d40bfe0-01"
mint@mint ~ $
Last edited by WharfRat on Wed Sep 13, 2017 4:26 pm, edited 1 time in total.
Reason: Added code tag

User avatar
WharfRat
Level 19
Level 19
Posts: 9503
Joined: Thu Apr 07, 2011 8:15 pm

Re: WiFi not found after installation

Postby WharfRat » Wed Sep 13, 2017 3:40 pm

OK, from the live media one line at a time. If you get any errors, don't try to continue.

Code: Select all

sudo -i
mount /dev/sda5 /mnt
mount -t proc none /mnt/proc
mount --rbind /sys /mnt/sys
mount --rbind /dev /mnt/dev
/usr/sbin/chroot /mnt /bin/bash
source /etc/profile
echo "nameserver 8.8.8.8" >> /etc/resolv.conf
export PS1="\[\033[1;33m\]chroot to ->\[\033[1;31m\](system) #\[\e[0m\] "
apt update
mintupdate-tool -l12345 upgrade
exit


After the updates install, shutdown from the menu then cross your fingers and boot to the installed version.
Image ImageImage

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Wed Sep 13, 2017 3:56 pm

Mint update tool gives unrecognised arguments : upgrade

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Wed Sep 13, 2017 3:58 pm

Ignore last, typo on terminal, my bad.

User avatar
WharfRat
Level 19
Level 19
Posts: 9503
Joined: Thu Apr 07, 2011 8:15 pm

Re: WiFi not found after installation

Postby WharfRat » Wed Sep 13, 2017 3:59 pm

pinckston wrote:Mint update tool gives unrecognised arguments : upgrade

Odd

Code: Select all

[bill@XPS] ~ $ sudo mintupdate-tool -l12345 upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[bill@XPS] ~ $



I hope you're copying and pasting these lines in the terminal :?
Image ImageImage

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Wed Sep 13, 2017 4:03 pm

Slight improvement, had to enable WiFi, previously it just said "device not ready". Unfortunately after enabling, device not ready is back.

User avatar
WharfRat
Level 19
Level 19
Posts: 9503
Joined: Thu Apr 07, 2011 8:15 pm

Re: WiFi not found after installation

Postby WharfRat » Wed Sep 13, 2017 4:07 pm

pinckston wrote:Slight improvement, had to enable WiFi, previously it just said "device not ready". Unfortunately after enabling, device not ready is back.

This happens when it's is booted to the installed version :?:
Image ImageImage

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Wed Sep 13, 2017 4:09 pm

Just tried installing iwlwifi all.deb, dpkg-deb: error: subprocess paste was killed by signal (broken pipe)

Any relevance?

Yes, it's the installed version. Seems that WiFi disabled it sees the WiFi chip but enabling it somehow breaks it!

Just been playing with rfkill a bit. It reads correctly until I hard block THEN soft block. Network manager then shows WiFi enabled but shaded out above, WiFi disabled. I turn off the hard block and this situation persists, and rfkill shows hard blocked no matter what I do.
Last edited by pinckston on Wed Sep 13, 2017 4:19 pm, edited 1 time in total.

User avatar
WharfRat
Level 19
Level 19
Posts: 9503
Joined: Thu Apr 07, 2011 8:15 pm

Re: WiFi not found after installation

Postby WharfRat » Wed Sep 13, 2017 4:19 pm

I had high hopes for that :(

In your original post you wrote
So, I wondered, could the booted contents of the live USB be transferred to an ex4 partition and then booted from hdd in the same configuration as if it was running live? In this way preserving the working WiFi.

I ran across this post viewtopic.php?f=90&t=231269#p1224664 which seems like it might provide what you're looking for.

I hate to direct you to that, but I'm at my wit's end here so this looks like the only other option at this junction.
Image ImageImage

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Wed Sep 13, 2017 4:21 pm

Yeah, that's why I asked the question in the manner I did, thinking outside the box. Wits end doesn't begin to describe where I'm at! I'll give the link a go Friday, pool match tomorrow. Thanks for your help, much appreciated.

User avatar
WharfRat
Level 19
Level 19
Posts: 9503
Joined: Thu Apr 07, 2011 8:15 pm

Re: WiFi not found after installation

Postby WharfRat » Wed Sep 13, 2017 4:25 pm

pinckston wrote:Yeah, that's why I asked the question in the manner I did, thinking outside the box. Wits end doesn't begin to describe where I'm at! I'll give the link a go Friday, pool match tomorrow. Thanks for your help, much appreciated.

Another option is to google usb wireless dongles for Linux and buy one from ebay or amazon. They're cheap :wink:
Image ImageImage

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Wed Sep 13, 2017 4:30 pm

I'll get a new laptop soon, this things a dinosaur, it's just become something of a mission! I don't like to be beaten and I'm learning as I go, so not wasted time and my 12 year old can have this one when I've sorted it.

User avatar
WharfRat
Level 19
Level 19
Posts: 9503
Joined: Thu Apr 07, 2011 8:15 pm

Re: WiFi not found after installation

Postby WharfRat » Wed Sep 13, 2017 4:34 pm

pinckston wrote:I'll get a new laptop soon, this things a dinosaur, it's just become something of a mission! I don't like to be beaten and I'm learning as I go, so not wasted time and my 12 year old can have this one when I've sorted it.

He might be 30 by the time you get it working :lol:

I'd be interested to know if viewtopic.php?f=90&t=231269#p1224664 works :wink:
Image ImageImage

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Wed Sep 13, 2017 4:50 pm

Too bloody right, try 40! I'll be sure to let you know how it goes mate.

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Fri Sep 15, 2017 1:02 pm

Hi wharfrat, no good on the link, says cannot mount rofs, no such file or directory :( :( :x

User avatar
WharfRat
Level 19
Level 19
Posts: 9503
Joined: Thu Apr 07, 2011 8:15 pm

Re: WiFi not found after installation

Postby WharfRat » Fri Sep 15, 2017 1:16 pm

pinckston wrote:Hi wharfrat, no good on the link, says cannot mount rofs, no such file or directory :( :( :x

If you got

Code: Select all

mint@mint ~ $ for a in /*  ;  do [ -d "$a" ]  &&  sudo mount  -o  rbind  "$a"  "/rofs$a"  ;  done
mount: mount point /rofs/cdrom does not exist
mount: mount point /rofs/rofs does not exist
mint@mint ~ $ findmnt

don't pay attention to it.

Use findmnt to see the mounts

Code: Select all

mint@mint ~ $ findmnt
TARGET                                       SOURCE       FSTYPE          OPTIONS
/                                            aufs         aufs            rw,noatime,si=4fcab25c27abcd4c
├─/sys                                       sysfs        sysfs           rw,nosuid,nodev,noexec,relatime
│ ├─/sys/kernel/security                     securityfs   securityfs      rw,nosuid,nodev,noexec,relatime
│ ├─/sys/fs/cgroup                           tmpfs        tmpfs           rw,mode=755
│ │ ├─/sys/fs/cgroup/systemd                 cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd
│ │ ├─/sys/fs/cgroup/hugetlb                 cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,hugetlb,release_agent=/run/cgmanager/agents/cgm-release-agent.hugetlb
│ │ ├─/sys/fs/cgroup/pids                    cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,pids,release_agent=/run/cgmanager/agents/cgm-release-agent.pids
│ │ ├─/sys/fs/cgroup/blkio                   cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,blkio
│ │ ├─/sys/fs/cgroup/net_cls,net_prio        cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,net_cls,net_prio
│ │ ├─/sys/fs/cgroup/cpu,cpuacct             cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,cpu,cpuacct
│ │ ├─/sys/fs/cgroup/memory                  cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,memory
│ │ ├─/sys/fs/cgroup/cpuset                  cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,cpuset,clone_children
│ │ ├─/sys/fs/cgroup/perf_event              cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,perf_event,release_agent=/run/cgmanager/agents/cgm-release-agent.perf_event
│ │ ├─/sys/fs/cgroup/devices                 cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,devices
│ │ └─/sys/fs/cgroup/freezer                 cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,freezer
│ ├─/sys/fs/pstore                           pstore       pstore          rw,nosuid,nodev,noexec,relatime
│ ├─/sys/kernel/debug                        debugfs      debugfs         rw,relatime
│ └─/sys/fs/fuse/connections                 fusectl      fusectl         rw,relatime
├─/proc                                      proc         proc            rw,nosuid,nodev,noexec,relatime
│ └─/proc/sys/fs/binfmt_misc                 systemd-1    autofs          rw,relatime,fd=32,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=9908
│   └─/proc/sys/fs/binfmt_misc               binfmt_misc  binfmt_misc     rw,relatime
├─/dev                                       udev         devtmpfs        rw,nosuid,relatime,size=1008276k,nr_inodes=252069,mode=755
│ ├─/dev/pts                                 devpts       devpts          rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000
│ ├─/dev/shm                                 tmpfs        tmpfs           rw,nosuid,nodev
│ ├─/dev/mqueue                              mqueue       mqueue          rw,relatime
│ └─/dev/hugepages                           hugetlbfs    hugetlbfs       rw,relatime
├─/run                                       tmpfs        tmpfs           rw,nosuid,noexec,relatime,size=204748k,mode=755
│ ├─/run/lock                                tmpfs        tmpfs           rw,nosuid,nodev,noexec,relatime,size=5120k
│ ├─/run/cgmanager/fs                        cgmfs        tmpfs           rw,relatime,size=100k,mode=755
│ └─/run/user/999                            tmpfs        tmpfs           rw,nosuid,nodev,relatime,size=204748k,mode=700,uid=999,gid=999
│   └─/run/user/999/gvfs                     gvfsd-fuse   fuse.gvfsd-fuse rw,nosuid,nodev,relatime,user_id=999,group_id=999
├─/cdrom                                     /dev/sr0     iso9660         ro,noatime
├─/rofs                                      /dev/loop0   squashfs        ro,noatime
│ ├─/rofs/bin                                aufs[/bin]   aufs            rw,noatime,si=4fcab25c27abcd4c
│ ├─/rofs/boot                               aufs[/boot]  aufs            rw,noatime,si=4fcab25c27abcd4c
│ ├─/rofs/dev                                udev         devtmpfs        rw,nosuid,relatime,size=1008276k,nr_inodes=252069,mode=755
│ │ ├─/rofs/dev/pts                          devpts       devpts          rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000
│ │ ├─/rofs/dev/shm                          tmpfs        tmpfs           rw,nosuid,nodev
│ │ ├─/rofs/dev/mqueue                       mqueue       mqueue          rw,relatime
│ │ └─/rofs/dev/hugepages                    hugetlbfs    hugetlbfs       rw,relatime
│ ├─/rofs/etc                                aufs[/etc]   aufs            rw,noatime,si=4fcab25c27abcd4c
│ ├─/rofs/home                               aufs[/home]  aufs            rw,noatime,si=4fcab25c27abcd4c
│ ├─/rofs/lib                                aufs[/lib]   aufs            rw,noatime,si=4fcab25c27abcd4c
│ ├─/rofs/lib64                              aufs[/lib64] aufs            rw,noatime,si=4fcab25c27abcd4c
│ ├─/rofs/media                              aufs[/media] aufs            rw,noatime,si=4fcab25c27abcd4c
│ ├─/rofs/mnt                                aufs[/mnt]   aufs            rw,noatime,si=4fcab25c27abcd4c
│ ├─/rofs/opt                                aufs[/opt]   aufs            rw,noatime,si=4fcab25c27abcd4c
│ ├─/rofs/proc                               proc         proc            rw,nosuid,nodev,noexec,relatime
│ │ └─/rofs/proc/sys/fs/binfmt_misc          systemd-1    autofs          rw,relatime,fd=32,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=9908
│ │   └─/rofs/proc/sys/fs/binfmt_misc        binfmt_misc  binfmt_misc     rw,relatime
│ ├─/rofs/root                               aufs[/root]  aufs            rw,noatime,si=4fcab25c27abcd4c
│ ├─/rofs/run                                tmpfs        tmpfs           rw,nosuid,noexec,relatime,size=204748k,mode=755
│ │ ├─/rofs/run/lock                         tmpfs        tmpfs           rw,nosuid,nodev,noexec,relatime,size=5120k
│ │ ├─/rofs/run/cgmanager/fs                 cgmfs        tmpfs           rw,relatime,size=100k,mode=755
│ │ └─/rofs/run/user/999                     tmpfs        tmpfs           rw,nosuid,nodev,relatime,size=204748k,mode=700,uid=999,gid=999
│ │   └─/rofs/run/user/999/gvfs              gvfsd-fuse   fuse.gvfsd-fuse rw,nosuid,nodev,relatime,user_id=999,group_id=999
│ ├─/rofs/sbin                               aufs[/sbin]  aufs            rw,noatime,si=4fcab25c27abcd4c
│ ├─/rofs/srv                                aufs[/srv]   aufs            rw,noatime,si=4fcab25c27abcd4c
│ ├─/rofs/sys                                sysfs        sysfs           rw,nosuid,nodev,noexec,relatime
│ │ ├─/rofs/sys/kernel/security              securityfs   securityfs      rw,nosuid,nodev,noexec,relatime
│ │ ├─/rofs/sys/fs/cgroup                    tmpfs        tmpfs           rw,mode=755
│ │ │ ├─/rofs/sys/fs/cgroup/systemd          cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd
│ │ │ ├─/rofs/sys/fs/cgroup/hugetlb          cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,hugetlb,release_agent=/run/cgmanager/agents/cgm-release-agent.hugetlb
│ │ │ ├─/rofs/sys/fs/cgroup/pids             cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,pids,release_agent=/run/cgmanager/agents/cgm-release-agent.pids
│ │ │ ├─/rofs/sys/fs/cgroup/blkio            cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,blkio
│ │ │ ├─/rofs/sys/fs/cgroup/net_cls,net_prio cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,net_cls,net_prio
│ │ │ ├─/rofs/sys/fs/cgroup/cpu,cpuacct      cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,cpu,cpuacct
│ │ │ ├─/rofs/sys/fs/cgroup/memory           cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,memory
│ │ │ ├─/rofs/sys/fs/cgroup/cpuset           cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,cpuset,clone_children
│ │ │ ├─/rofs/sys/fs/cgroup/perf_event       cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,perf_event,release_agent=/run/cgmanager/agents/cgm-release-agent.perf_event
│ │ │ ├─/rofs/sys/fs/cgroup/devices          cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,devices
│ │ │ └─/rofs/sys/fs/cgroup/freezer          cgroup       cgroup          rw,nosuid,nodev,noexec,relatime,freezer
│ │ ├─/rofs/sys/fs/pstore                    pstore       pstore          rw,nosuid,nodev,noexec,relatime
│ │ ├─/rofs/sys/kernel/debug                 debugfs      debugfs         rw,relatime
│ │ └─/rofs/sys/fs/fuse/connections          fusectl      fusectl         rw,relatime
│ ├─/rofs/tmp                                tmpfs        tmpfs           rw,nosuid,nodev,relatime
│ ├─/rofs/usr                                aufs[/usr]   aufs            rw,noatime,si=4fcab25c27abcd4c
│ └─/rofs/var                                aufs[/var]   aufs            rw,noatime,si=4fcab25c27abcd4c
└─/tmp                                       tmpfs        tmpfs           rw,nosuid,nodev,relatime
mint@mint ~ $


If you run findmnt before executing the mount line, you'll see there is nothing mounted to rofs

Code: Select all

TARGET                                SOURCE      FSTYPE          OPTIONS
/                                     aufs        aufs            rw,noatime,si=4fcab25c27abcd4c
├─/sys                                sysfs       sysfs           rw,nosuid,nodev,noexec,relatime
│ ├─/sys/kernel/security              securityfs  securityfs      rw,nosuid,nodev,noexec,relatime
│ ├─/sys/fs/cgroup                    tmpfs       tmpfs           rw,mode=755
│ │ ├─/sys/fs/cgroup/systemd          cgroup      cgroup          rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd
│ │ ├─/sys/fs/cgroup/hugetlb          cgroup      cgroup          rw,nosuid,nodev,noexec,relatime,hugetlb,release_agent=/run/cgmanager/agents/cgm-release-agent.hugetlb
│ │ ├─/sys/fs/cgroup/pids             cgroup      cgroup          rw,nosuid,nodev,noexec,relatime,pids,release_agent=/run/cgmanager/agents/cgm-release-agent.pids
│ │ ├─/sys/fs/cgroup/blkio            cgroup      cgroup          rw,nosuid,nodev,noexec,relatime,blkio
│ │ ├─/sys/fs/cgroup/net_cls,net_prio cgroup      cgroup          rw,nosuid,nodev,noexec,relatime,net_cls,net_prio
│ │ ├─/sys/fs/cgroup/cpu,cpuacct      cgroup      cgroup          rw,nosuid,nodev,noexec,relatime,cpu,cpuacct
│ │ ├─/sys/fs/cgroup/memory           cgroup      cgroup          rw,nosuid,nodev,noexec,relatime,memory
│ │ ├─/sys/fs/cgroup/cpuset           cgroup      cgroup          rw,nosuid,nodev,noexec,relatime,cpuset,clone_children
│ │ ├─/sys/fs/cgroup/perf_event       cgroup      cgroup          rw,nosuid,nodev,noexec,relatime,perf_event,release_agent=/run/cgmanager/agents/cgm-release-agent.perf_event
│ │ ├─/sys/fs/cgroup/devices          cgroup      cgroup          rw,nosuid,nodev,noexec,relatime,devices
│ │ └─/sys/fs/cgroup/freezer          cgroup      cgroup          rw,nosuid,nodev,noexec,relatime,freezer
│ ├─/sys/fs/pstore                    pstore      pstore          rw,nosuid,nodev,noexec,relatime
│ ├─/sys/kernel/debug                 debugfs     debugfs         rw,relatime
│ └─/sys/fs/fuse/connections          fusectl     fusectl         rw,relatime
├─/proc                               proc        proc            rw,nosuid,nodev,noexec,relatime
│ └─/proc/sys/fs/binfmt_misc          systemd-1   autofs          rw,relatime,fd=32,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=9908
│   └─/proc/sys/fs/binfmt_misc        binfmt_misc binfmt_misc     rw,relatime
├─/dev                                udev        devtmpfs        rw,nosuid,relatime,size=1008276k,nr_inodes=252069,mode=755
│ ├─/dev/pts                          devpts      devpts          rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000
│ ├─/dev/shm                          tmpfs       tmpfs           rw,nosuid,nodev
│ ├─/dev/mqueue                       mqueue      mqueue          rw,relatime
│ └─/dev/hugepages                    hugetlbfs   hugetlbfs       rw,relatime
├─/run                                tmpfs       tmpfs           rw,nosuid,noexec,relatime,size=204748k,mode=755
│ ├─/run/lock                         tmpfs       tmpfs           rw,nosuid,nodev,noexec,relatime,size=5120k
│ ├─/run/cgmanager/fs                 cgmfs       tmpfs           rw,relatime,size=100k,mode=755
│ └─/run/user/999                     tmpfs       tmpfs           rw,nosuid,nodev,relatime,size=204748k,mode=700,uid=999,gid=999
│   └─/run/user/999/gvfs              gvfsd-fuse  fuse.gvfsd-fuse rw,nosuid,nodev,relatime,user_id=999,group_id=999
├─/cdrom                              /dev/sr0    iso9660         ro,noatime
├─/rofs                               /dev/loop0  squashfs        ro,noatime
└─/tmp                                tmpfs       tmpfs           rw,nosuid,nodev,relatime


Image ImageImage

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Fri Sep 15, 2017 2:04 pm

I did wonder if that was the case but thought that op would have mentioned it, so I run the command, ignore the errors and proceed to install?

User avatar
WharfRat
Level 19
Level 19
Posts: 9503
Joined: Thu Apr 07, 2011 8:15 pm

Re: WiFi not found after installation

Postby WharfRat » Fri Sep 15, 2017 2:33 pm

pinckston wrote:I did wonder if that was the case but thought that op would have mentioned it, so I run the command, ignore the errors and proceed to install?

Yup, can it make things worse than they are now :?
Image ImageImage


Return to “Wireless”

Who is online

Users browsing this forum: No registered users and 3 guests