Printer has to be enabled manually after USB taken out and back in

Forum rules
Before you post please read this
Post Reply
Level 1
Level 1
Posts: 1
Joined: Thu Oct 26, 2017 9:47 am

Printer has to be enabled manually after USB taken out and back in

Post by beiti » Thu Oct 26, 2017 10:00 am

Hi everyone,

I am experiencing a strange problem with a printer (Canon MF 240). I use the Generic PCL 6 driver, the output is working sufficiently. This printer is in our office and is shared by lots of people, and - I know, we are old school - we just share the USB cable. So whoever wants to print, plugs it in, prints, goes.

What happens with the Linux Mint laptop is, that regularly the printer "disables" itself (Printer Properties > Policies > Top Checkbox "enabled").
Is there a way to change this behaviour? I can only guess at possible reasons:
1) There is a policy problem - ie some user rules are not set correct?
2) The printer policy is set somewhere in the system and I have no clue where?
3) Our printer might be a cheap copy of an original (I work in Liberia/West Africa)?
4) ... ?

I tried sending the print command before plugging and after plugging the cable in - no change. As soon as I unplug the cable, the printer is "disabled", and it won't enable itself - I have to do that manually. I tried a different cable - no change. My Macbook does not experience this problem, nor do the Windows laptops of my colleagues.

Thanks for help!

User avatar
Level 6
Level 6
Posts: 1069
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Printer has to be enabled manually after USB taken out and back in

Post by ClixTrix » Fri Oct 27, 2017 10:48 am

Try this.

1) Power OFF the printer.... 2) Connect USB to your Mint computer..... 3) Power ON the printer.

Does Mint then show the printer Enabled and Ready (after USB detected and reasonable startup time)?

Edit: "I use the Generic PCL 6 driver" ..... OK, but the Windows/Mac driver is probably UFR II LT Language vs. you using PCL Language. That is possibly why a reload/reset is necessary. You could try the Linux UFR II LT driver. ... ss-mf247dw
Linux Mint 19.1 x64 Cinnamon 4.15.0-65-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / Sapphire Radeon HD6450
NVMe-SSD: Samsung 960 EVO 250GB / SATA-SSD: Samsung 850 EVO 250GB + Toshiba OCZ VX500 512GB

Post Reply

Return to “Printers & Scanners”