Turning Off CPU Idle Setting and Enable Passive Setting

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 27
Joined: Sun Nov 27, 2016 2:59 pm

Turning Off CPU Idle Setting and Enable Passive Setting

Post by miketurn » Tue Nov 07, 2017 3:59 pm

I have a labtop with an Intel CPU that produces terrible high pitch noises (sounds like morse code) (I know some will comment, CPUs don't make noise, and to that I say.... yes sometimes they do) I tested this out on Linux Mint and also with Windows 7 and the noise is generated with both OSs.
I found a site online where a user mentions that there is a hidden power option setting in Windows 7 that allows you to turn off "CPU Idle"
I performed the steps he mentioned and when disabling this "idle" setting, it worked, the morse code noise stopped immediately.
I was so excited that this worked and then realized that there is another high pitch noise (that is constant!) that was hidden behind that noise, which really made me mad :x .

I thought there might be a power setting in my BIOS but I found nothing regarding this.


1.) I don't believe there is a fix for that secondary constant high pitch noise which is dissapointing, but the morse code one I was able to remove.
I was wondering is there such a setting that can found hopefully within Linux Mint (that does not require a separate piece of software to achieve)?
I guess this setting in Windows 7 disables the CPU from constantingly powering down and starting back up every time an action is performed.
I can understand why a setting to have the CPU idle when not being used for a while, but to have it constantly! going from action to idle seems foolish.

2.) Kind of a separate issue, but I mentioned this in the "Suggest A New Feature" for Linux Mint category a short while ago.
In Windows 7 "Power Options" there is a setting for labtops that allows you to enable either an "Active" or "Passive" mode when it comes to CPU cooling fans.
Active = Turn on fan when CPU gets hot
Passive = Will underclock the CPU before turning on the fan to full speed
This passive setting is a great feature for labtops with loud fans and it actually works quite well.
On my other post, no one mentioned that there is a built in setting for this in Linux Mint, but does anyone know of any programs to achieve this.

Thank you to anyone who reads this and for any advice offered.

Mute Ant
Level 14
Level 14
Posts: 5135
Joined: Tue Sep 03, 2013 7:45 pm
Location: Norfolk UK

Re: Turning Off CPU Idle Setting and Enable Passive Setting

Post by Mute Ant » Tue Nov 07, 2017 8:48 pm

"CPUs don't make noise" It's not number one on the list of offenders, no, but the integrated circuit is surrounded by coils, which contract when you run a current through them, and capacitors, which contract when you apply a voltage across them.

On my squeaky machine, it was the processor flipping between 'top-speed' and 'stopped' that caused the morse-code effect. There's a relatively simple fix to smooth it out...

1] Don't let the CPU do the default, which is to save power by using HLT and waiting for an interrupt. To stop that, you need to apply a kernel boot argument idle=poll You can try that for one-boot-only by interrupting GRUB as it boots the OS, just like adding nomodeset or init=/bin/bash

2] Add the package cpufrequtils to take control of the CPU speed. On a desktop machine, you might be happy with all the cores running at full speed all the time. On a laptop, with all the cores at minimum speed. There's other clock-control packages, but I have only ever needed the all-cpu-at-minimum-speed setting.
While you're waiting, read the free novel we sent you. It's a Spanish story about a guy named "manual".

Level 1
Level 1
Posts: 27
Joined: Sun Nov 27, 2016 2:59 pm

Re: Turning Off CPU Idle Setting and Enable Passive Setting

Post by miketurn » Mon Nov 20, 2017 8:01 pm

@Mute Ant
Thank you for your response.
Sorry I have not responded sooner I have been pulled into many other things.
When I say CPUs make noise, you know what mean, noise is generated with the components + power. That is like saying fans are completely silent, until you add power to them :D
I am not glad that you experience a "squeaky machine" but I am glad that you at least know what I am referring to and have some solutions.
I have not had a ton of time to test out these solutions as of yet, I remember researching them after I read your post.

1.) I remember I was about to try this but in doing some research about this I saw someone mention something about generating too much heat or concern about damaging hardware, don't hold me to this, I can't remember exactly what I read at the moment. Have you ever experienced any issues after enabling this?

2.) Does cpufrequtils come with Linux Mint? because I actually had this on my machine. As I mentioned I asked about this issue in the past so I may have downloaded it back then, I was just shocked to see it already there. I will have to look into this more as I do not see any kind of GUI for it, and my terminal skills are not that great.

Thank you again for your advice

Post Reply

Return to “Software & Applications”