SOLVED: GRUB menu list not showing updated kernels

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
pjc123
Level 1
Level 1
Posts: 45
Joined: Tue Apr 09, 2013 2:13 pm

SOLVED: GRUB menu list not showing updated kernels

Postby pjc123 » Tue Nov 21, 2017 12:45 pm

EDIT (11-24-2018): I deleted and updated a lot of this post because I restored my computer to previous image and some of the info no longer applies.

I have the following setup on a Lenovo T470 Thinkpad.

SSD (Drive #1) = Windows 10 (No problems here. Everything running OK)

SSD (Drive #2)
First two partitions = Centos 7. (I installed this first).
Fourth partition = Linux Mint 18 - 64 bit Cinnamon.

I use the BIOS boot menu to pick which drive I want to use. If I pick Drive #2 I use GRUB to select the Linux OS I want to load.

So, everything above works fine, however now I updated the kernels on Centos and Linux Mint, but their entries are not in the GRUB bootup menu. I tried various commands, but I can't get the new kernels to appear.

I ran "sudo update-grub" on the Mint side and the new kernels were detected. I just don't know what to run on the Centos side so both the new Centos kernels and Mint kernels show up there, because I believe this is where all kernels would show up in the GRUB menu list.

I tried the following in Centos:

grub2-mkconfig -o /boot/grub2/grub.cfg,

and all the kernels show up from Centos and Mint in the file /boot/grub2/grub.cfg, but they are still not in the boot up menu.

I do notice that there is a separate and older dated /boot/grub.cfg with the current menu list.

Am I now supposed to copy /boot/grub2/grub/cfg into /boot/grub/cfg and everything will work? If that works it seems like something is not set up properly or I am running the wrong command.
Last edited by pjc123 on Thu Nov 30, 2017 3:29 pm, edited 8 times in total.

User avatar
prestonR
Level 5
Level 5
Posts: 793
Joined: Wed Jan 07, 2015 12:24 pm
Location: Harare

Re: Mint Disappeared From Grub Menu

Postby prestonR » Tue Nov 21, 2017 1:30 pm

An easy way to boot any bootable OS on a system (and a useful tool for anybody who often multi-boots and/or has trouble with wrestling grubs) is Supergrubdisk2 https://www.supergrubdisk.org/super-grub2-disk/.

Download the 20MB iso, burn it on a USB stick and boot from it. It will check all connected drives for boot options and it will list them, pick the OS you want and boot away; it's like a grub before the grub.

Once you're back in your Mint, re-install grub (and let Mint's grub take back control of your systems 'grub' boot screen since Centos' obviously can't be trusted with it :D ) with:

Code: Select all

sudo grub-install /dev/sdX

where 'X' is where you want your grub (since it's an Uefi system you should point at the location of your 'efi' boot partition).

Alternatively, you can re-install Mint's grub from any live system and even from your Centos, search 'chroot re-install grub'.

pjc123
Level 1
Level 1
Posts: 45
Joined: Tue Apr 09, 2013 2:13 pm

Re: GRUB menu list not showing updated kernels

Postby pjc123 » Thu Nov 30, 2017 3:28 pm

SOLVED

1) Booted up into Linux Mint and ran

update-grub

2) Booted up into Centos and ran

grub2-mkconfig -o /boot/grub/grub.cfg


Return to “Installation & Boot”