Dell Aurora R6 dual boot How-To and issues I ran into.

Write tutorials here
There are more tutorials here
Forum rules
Please don't add support questions to tutorials,start your own thread in the appropriate sub-forum instead. Before you post please read this
Post Reply
Level 1
Level 1
Posts: 6
Joined: Sun Aug 30, 2015 7:42 pm

Dell Aurora R6 dual boot How-To and issues I ran into.

Post by Freth »

I just recently purchased a Dell Aurora R6. I set about installing Linux Mint on the system, which wasn't that difficult once I found the correct BIOS settings. Then I noticed a shutdown bug that I would work on for several hours. I was about to give up when I found the answer. But first, installation.


The first thing I needed to do was shrink my SSD volume, so I could install Linux on the second half of my 256GB SSD. The problem is Windows 10 puts system files far on the end of the partition and you have to remove those first.

1. Run the Disk Cleanup Wizard, making sure to remove the hibernation file and all restore points.
2. Disable System Restore
3. Disable the pagefile - Open up System in Control Panel, then Advanced System Settings \ Advanced \ Performance \ Advanced \ Change \ No Paging File.
4. Disable kernel memory dump. In the same Advanced Settings, go to Startup and Recovery \ Settings and then change the Write debugging information drop-down to “None” to disable the kernel memory dump.
5. Disable Hibernation mode in your power options \ advanced power options screen.
Reboot the machine, and then delete your c:\pagefile.sys file (if it exists).

Then use Disk Management to shrink the volume in half. Leave the remaining unallocated.

F2 on boot splash screen to enter BIOS. Change the following settings:

BIOS changes for installing Linux.
Advanced - SATA Operation - Set it to AHCI, not RAID
Boot - Secure Boot - Disabled (ignore warnings, Windows will be just fine)
Boot - Boot List Option - UEFI
Load Legacy Option ROM - Disabled
Attempt Legacy Boot - Disabled

Load up your Linux Mint Live USB or DVD and run the installer.
When you get to the drive window (Erase, etc.) select Something Else.
Find the unallocated space of the second half of the SSD. Add a swap partition the size of your memory. Add an ext4 partition and designate / in the dropdown.
Continue with the install.

Everything should work fine, EXCEPT...

Shutdown Bug

Linux Mint wouldn't shut down properly on my R6. It would hang with a kernel panic. I was able to get it to work using kernel, but on other kernels it would hang. After further investigation, I found the issue to be i2c-designware-core. If you blacklist it, the system shuts down normally. This seems to be a common issue with Dell systems, but I only found the answer in one place ( ... nware.html).

Create a new file in order to deactivate (blacklist) the module:

$ sudo nano /etc/modprobe.d/blacklist-i2c-designware-core.conf

and copy the following line in the conf file: install i2c-designware-core /bin/false

Reboot the machine once, and then try shutting down again, now the computer should shutdown ok.

You can delete /etc/modprobe.d/blacklist-i2c-designware-core.conf if this fix does not work for you.
Level 1
Level 1
Posts: 1
Joined: Tue Jun 26, 2018 9:01 pm

Re: Dell Aurora R6 dual boot How-To and issues I ran into.

Post by jefflearnslinux »

I use to have that shutdown fix for this for kernels 4.14 and below, which was what you had mentioned

sudo gedit /etc/modprobe.d/blacklist-i2c-designware-core.conf

then pasting this in the text file

install i2c-designware-core /bin/false

Found on this article here: ... nware.html

But with kernel 4.15 and above this does not fix the shutdown hang anymore it's outdated, I know it was something to do with the designware modules, but in the new kernels all that is changed, in fact the kernel panic seems to be even worse spitting out even more module issues with the 4.15+ kernel. How I solved this issue was installing Manjaro and using their built in kernel installer,and switched to a "Real Time" kernel. You can also install these in Mint as well.

Why this is still an issue is beyond me The article mentioned above was written in the end of Nov 2016 and I had purchased my R5 in Sept of 2016, and played around with Linux on this machine during this time, but because not too many people had this version there was no help whatsoever on any forums at the time, well my theory is(correct me if I'm wrong), I think the RT(or low latency kernel) only gives a certain amount of time for it to run a job, and I think that's what plays a huge factor in the shutdown process, so whatever it's getting hung up on with the regular kernel(be it certain modules not installed), the RT doesn't allow it to run that process that long. But I could be wrong on that assumption.

Right now I am running kernel 4.16-rt and I have no absolutely no issues with shutdown or reboot, also no performance issues either. This seems to plague all of the "R" series 5 and above for Alienware machines. This fix was found just by playing with different kernels, so you could say it's sort of a happy accident.

These are my specs for this rig.
Alienware Aurora R5
Nvidia GTX 1070/8GBvram
8GB ram
i7 Intel core processor(8core)"Skylake"
Post Reply

Return to “Tutorials”