[SOLVED] Intel Microcode update broke WiFi

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 1
Joined: Fri Jan 12, 2018 11:31 pm

[SOLVED] Intel Microcode update broke WiFi

Post by gotling » Fri Jan 12, 2018 11:47 pm

After upgrading package intel-microcode to version 3.20180108.0~ubuntu16.04.02 and rebooting WiFi does not want to connect anymore. Networks are shown like before but clicking one just shows connecting...

A solution that works for now is downgrading intel-microcode to the previous version, 3.20170707.1~ubuntu16.04.0

  1. Download intel-microcode_3.20170707.1~ubuntu16.04.0_amd64.deb using another device
  2. Transfer file to the device not working
  3. Install with:

    Code: Select all

    sudo dpkg -i intel-microcode_3.20170707.1_ubuntu16.04.0_amd64.deb
  4. Reboot and make sure WiFi works like before
Of course with Meldown and Spectre out there we want to have these microcode updates but until WiFi is working correct this will have to do.

Linux Mint: 18.3
Computer: Asus Transformer T303UA
Network card: Intel Corporation Wireless 7265

Post Reply

Return to “Wireless”