Problems Installing Hamsphere 4 On 18.3

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
john7148
Level 1
Level 1
Posts: 4
Joined: Sat Aug 30, 2014 6:59 am

Problems Installing Hamsphere 4 On 18.3

Post by john7148 » Thu Mar 08, 2018 6:07 pm

Hi, I can install Hamsphere 4 on older versions but can't get to run the executable file on 18.3. It's a tar.gz programme and when using tar zxvf command it unpacks to an exectuable file which runs in older versions such as 17.3 but just hangs with a message saying can't run untrusted files or something but it's a commercial programme. Is there a way to change security settings, it's a java application of a ham radio simulator.
Any suggestions, Thanks.. John.

User avatar
catweazel
Level 17
Level 17
Posts: 7770
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Problems Installing Hamsphere 4 On 18.3

Post by catweazel » Fri Mar 09, 2018 1:48 am

john7148 wrote:
Thu Mar 08, 2018 6:07 pm
Hamsphere 4
You might get a faster response on the Hamsphere forums.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

User avatar
phd21
Level 17
Level 17
Posts: 7480
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Problems Installing Hamsphere 4 On 18.3

Post by phd21 » Fri Mar 09, 2018 3:19 am

Hi john7148,

It looks interesting, I think I tried this a long time ago.

You have to make sure you have Java runtimes installed and permissions to run their Java jar file or if they use a script or executable program file. FYI: there are 2 versions of Java, Oracle's Java and open source Java (openJDK). The open source Java is probably installed in all Linux Mint editions and versions. Some programs require one Java version or the other, so I always install both versions.

I just downloaded their version 4 and it works on my Linux Mint KDE 18.2 system, but they now use an executable program file. You can check and or change permissions, by right-clicking their file "hamsphere_4.010", select properties, permissions tabs, check allow execute or executable, apply, ok, then double-click the file. With jar files, you can right-click and select which version of Java to use, with a program file, you may have to set the default version you want to use. I tried both Java 8 versions and Oracle Java 9 and they all seem to work the same.

You can also use their version 3.

Hope this helps ...
HamSphere1.jpg
HamSphere2.jpg
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

john7148
Level 1
Level 1
Posts: 4
Joined: Sat Aug 30, 2014 6:59 am

Re: Problems Installing Hamsphere 4 On 18.3

Post by john7148 » Fri Mar 09, 2018 7:11 am

Thanks for the replies. I found that java wasn't installed by default in 18.3 and installed openjdk-8-jre but still no luck. There are no error messages it just won't run. I get the hamsphere-4.010-native folder open that and get an rt folder and the executable hamsphere_4.010 which should open to the log in screen. Mint 17.3 by default has openjdk 7 installed and hamsphere4 runs so I will stick with that for now. I can run hamsphere 3 only if I install oracle java and right click and open with oracle java but I find I get very crackly audio on HS3 so I have used an old copy of XP but now it doesn't allow the java updates on XP.
I am sure I couldn't get it working on 18.2 I got a failed to execute child process error.
I haven't had any luck on the hamsphere forums, think my last post has been unanswered .
Thanks, I will continue to experiment.
John.

Post Reply

Return to “Software & Applications”