Unable to Install Package "snapd"

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
tb75252
Level 1
Level 1
Posts: 39
Joined: Tue Nov 29, 2011 3:34 pm

Unable to Install Package "snapd"

Post by tb75252 » Mon Mar 12, 2018 7:34 am

I am using LMDE 2, 64-bit.

I would like to install the Snapcraft version of Skype. See this link: https://snapcraft.io/skype
The instructions state that I should first install snapd

Code: Select all

sudo apt install snapd
but I get an error:
Unable to locate package snapd
It has been suggested to make sure that the option to accept software from given ppas is ticked. Where do I check that? I don't see it in Synaptic Package Manager...

User avatar
Pierre
Level 17
Level 17
Posts: 7137
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Unable to Install Package "snapd"

Post by Pierre » Mon Mar 12, 2018 7:39 am

well - - LMDE doesn't support PPAs . .
so, you can't install those.

and the program snapd should be in Package Manager AKA synaptic,
after which you may be able to install the Snapcraft version of Skype.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

User avatar
Marziano
Level 7
Level 7
Posts: 1830
Joined: Thu Jan 04, 2018 1:00 pm

Re: Unable to Install Package "snapd"

Post by Marziano » Mon Mar 12, 2018 8:19 am

Pierre wrote:
Mon Mar 12, 2018 7:39 am
and the program snapd should be in Package Manager AKA synaptic,
It doesn't seem so. I run LMDE 2- MATE in a VM and in another thread (from the same OP: viewtopic.php?f=236&t=265318&p=1440821& ... e#p1440821) I tried to install snapd. I could do so neither from a terminal nor from Synaptic. So I wonder whether snapd is available for LMDE2 at all.
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

User avatar
Pierre
Level 17
Level 17
Posts: 7137
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Unable to Install Package "snapd"

Post by Pierre » Mon Mar 12, 2018 8:38 am

can you search in Package Manager AKA synaptic,
and see if snapd is listed there ?.

I've not got any LMDE working ATM, so I'm not able to check that.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

User avatar
Marziano
Level 7
Level 7
Posts: 1830
Joined: Thu Jan 04, 2018 1:00 pm

Re: Unable to Install Package "snapd"

Post by Marziano » Mon Mar 12, 2018 9:14 am

Pierre wrote:
Mon Mar 12, 2018 8:38 am
can you search in Package Manager AKA synaptic,
and see if snapd is listed there ?.
"snapd" is nowhere to be found :?
SynapticSnapd.png
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

tb75252
Level 1
Level 1
Posts: 39
Joined: Tue Nov 29, 2011 3:34 pm

Re: Unable to Install Package "snapd"

Post by tb75252 » Mon Mar 12, 2018 3:29 pm

I am told that snapd is surely in the Stretch (stable), Buster (testing) and Sid (unstable) debian archives, according to the debian package search.
What release is LMDE based on?

User avatar
Marziano
Level 7
Level 7
Posts: 1830
Joined: Thu Jan 04, 2018 1:00 pm

Re: Unable to Install Package "snapd"

Post by Marziano » Mon Mar 12, 2018 3:37 pm

LMDE 2 is based on Debian Jessie ("Stable").
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

youstupiddarkness
Level 1
Level 1
Posts: 23
Joined: Sat Jun 17, 2017 8:29 pm

Re: Unable to Install Package "snapd"

Post by youstupiddarkness » Wed Mar 14, 2018 11:49 pm

Marziano wrote:
Mon Mar 12, 2018 3:37 pm
LMDE 2 is based on Debian Jessie ("Stable").
Currently "oldstable", to be pedantic.

User avatar
sdibaja
Level 5
Level 5
Posts: 564
Joined: Sun May 08, 2011 12:57 pm
Location: Baja California, Mexico

Re: Unable to Install Package "snapd"

Post by sdibaja » Thu Mar 15, 2018 12:08 am

youstupiddarkness wrote:
Wed Mar 14, 2018 11:49 pm
Marziano wrote:
Mon Mar 12, 2018 3:37 pm
LMDE 2 is based on Debian Jessie ("Stable").
Currently "oldstable", to be pedantic.
End of life date ~June 6th 2018 (full) / ~June 6th 2020 (LTS) ... only security updates
https://wiki.debian.org/DebianOldStable

Post Reply

Return to “Newbie Questions”