Wine App Not Seeing USB Device

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
jackerbes
Level 3
Level 3
Posts: 155
Joined: Fri Jul 03, 2015 8:37 am

Wine App Not Seeing USB Device

Post by jackerbes » Mon Mar 19, 2018 9:56 am

I use Eagle Tree Systems devices called eLoggers to collect data on small electric motor used in Radio
Control airplanes. The eLogger saves the data and an Windows app called the Data Recorder downloads the data and displays it.

I used Wine to install the Data Recorder again and that went well as far as I can tell.

Here are two links to the Wine HQ page and the Wine page for the Data Recorder application:

https://www.winehq.org/

https://appdb.winehq.org/objectManager. ... ngId=31166

The fact that the Data Recorder app is rated as "garbage" because the app would not run under Wine successfully.

When I plugged a V3 eLogger into a USB port on my laptop (Lenovo T520) running Mint 18.2 64 bit Linux) and ran the Linux dmesg command I got the following info that indicated the system is seeing the eLogger:

Code: Select all

..<snip>...
[276580.507173] usb 1-1.1: new full-speed USB device number 16 using ehci-pci
[276580.620914] usb 1-1.1: New USB device found, idVendor=0461, idProduct=0200
[276580.620921] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[276580.620925] usb 1-1.1: Product: ETS eLogger V3        
[276580.620928] usb 1-1.1: Manufacturer: ETS
[276580.664757] hid-generic 0003:0461:0200.0006: hiddev1,hidraw3: USB HID v1.00 Device [ETS ETS eLogger V3        ] on usb-0000:00:1a.0-1.1/input0
..<snip>...
When I run the Data Recorder app with a device connected to a USB port I get a Select Device Dialog pop up seen in the image. I cannot get past that regardless of how I start the Data Recorder or when I plug the eLogger in (before or after starting the app).

So it is apparent that, while Linux sees the eLogger, the app is not seeing the USB port or something like that.

The Wine page for the Data Recorder app has this comment on it:
Additional Comments

Installation requires investigation if the device contains a USB-serial interface. If so, it may be possible to configure a com port for wine ie: ln -s /dev/ttyUSB0 ~/.wine/dosdevices/com1
Does anyone have any suggestions as to how I can get the Data Recorder app to find the eLogger?

Thanks for any help you can provide on this.

Jack
Mint 18.3 and 19, 64-bit, Cinnamon, Lenovo ThinkPad SL510 laptop, ASUS Z-97 desktop, Samsung S6 Android phone
Jack Erbes in Ellsworth, ME, USA

User avatar
Flemur
Level 17
Level 17
Posts: 7069
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Wine App Not Seeing USB Device

Post by Flemur » Mon Mar 19, 2018 2:21 pm

jackerbes wrote:
Mon Mar 19, 2018 9:56 am
So it is apparent that, while Linux sees the eLogger, the app is not seeing the USB port or something like that.
Internet search on [linux wine "usb"] --> looks like you have to do some fiddling for wine programs to see USB devices.

Perhaps this:
http://g8ogj.org/files/Using%20USB%20se ... %20ipb.pdf
or, this looks simpler:
https://ubuntuforums.org/showthread.php?t=1335098
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

User avatar
trytip
Level 11
Level 11
Posts: 3562
Joined: Tue Jul 05, 2016 1:20 pm

Re: Wine App Not Seeing USB Device

Post by trytip » Mon Mar 19, 2018 3:33 pm

wine and devices do not work since wine is just the basic to run programs not hardware compatibility. your best bet is install windows xp or 7 in virtualbox then you have full hardware support
Image

punkbiscuit
Level 1
Level 1
Posts: 34
Joined: Wed Feb 08, 2017 3:06 pm

Re: Wine App Not Seeing USB Device

Post by punkbiscuit » Mon Mar 19, 2018 3:49 pm

I think your comport needs to be mapped out to make it visiible.

I have a few specialist Windows apps that are not available for Linux and I use them with WINE.

I needed to map it out like this

In the terminal I use the command -

Code: Select all

ln -s /dev/ttyUSB0 ~/.wine/dosdevices/com1 
(this command maps out a comport. COM1 shown in your Windows prog is mapped to the physical USB device 0)
If you're not sure what physical comport it is, then try each USB socket until it works ;-)

You can check which comports are available with the command -

Code: Select all

dmesg | grep tty
You may also need to use this -

Code: Select all

sudo usermod -aG dialout username 
This command allows username to have access to the comports.

I've only ever needed to do this setup once and it seemed to do the trick for me.

jackerbes
Level 3
Level 3
Posts: 155
Joined: Fri Jul 03, 2015 8:37 am

Re: Wine App Not Seeing USB Device

Post by jackerbes » Mon Mar 19, 2018 7:10 pm

Thanks for the good replys guys!

I'm off to give this a whirl and to see if I can get it going.

I'll definitely follow up here though.

Jack
Mint 18.3 and 19, 64-bit, Cinnamon, Lenovo ThinkPad SL510 laptop, ASUS Z-97 desktop, Samsung S6 Android phone
Jack Erbes in Ellsworth, ME, USA

Post Reply

Return to “Newbie Questions”