Mint 18.3 Working Fine: But Not After BIOS Reset!

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
User avatar
darethehair
Level 4
Level 4
Posts: 239
Joined: Sun Mar 08, 2009 2:22 pm
Location: Morden Manitoba Canada
Contact:

Mint 18.3 Working Fine: But Not After BIOS Reset!

Post by darethehair »

I was happy as a clam when I was able to install Mint 18.3 on my new HP 530-131 gaming desktop -- onto an SSD (leaving Windows on the HDD alone). No BIOS changes. Secure boot enabled. Everything cool. Installed Steam and graphics worked fine. Upgraded kernel to 4.15 to get sound working fine. But I was annoyed that the wifi chip (RTL8188?) was not being detected, so I opted to restore the BIOS settings back to factory state in case some upgrade (by previous owner) had done something.

DISASTER!

The SSD containing Mint 18.3 was no longer available in the BIOS boot options. Re-trying to load my Mint 18.3 USB live stick refused to boot -- complaining about 'secure boot' conflicts. Turning OFF secure boot allows me to boot the live USB, but it gets stuck during the boot process.

I then upgraded the BIOS to the most recent version, and it makes no difference.

What happened to my wonderful/easy Mint 18.3 system? Help please!

UPDATE: Disabling 'Secure Boot' and enabling 'Legacy' allows me to select the SSD containing Mint 18.3. So the next question becomes why did my SSD device turn into one that is only detectable with 'Legacy'?
There is nothing more dangerous than a bored cat.

deepakdeshp
Level 17
Level 17
Posts: 7910
Joined: Sun Aug 09, 2015 10:00 am

Re: Mint 18.3 Working Fine: But Not After BIOS Reset!

Post by deepakdeshp »

Good progress by you to get the system to work. Congratulations.
I will state the obvious.One needs to note down the BIOS settings before factory reset
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 20 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Post Reply

Return to “Installation & Boot”