Can't use microphone, only playback

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 8
Joined: Fri Apr 20, 2018 7:23 am

Can't use microphone, only playback

Post by Chocapic » Tue Apr 24, 2018 9:07 am

Hi everyone,

I have been using linux for years but my experience with trouble shooting is looking up stuff on the Internet, copying lines of code I don't understand and smile if it works.

I'm having a hard time trying to get my mic to work, on Audacity every option leads me to record playback. I have installed a bunch of programs that lead me nowhere, Qasmixer, HDAjackRetask, Echomixer, others and more tools that didn't help.
All options I try on pulse lead me to the same result.
If I knew how to use what I installed, maybe it could lead me to my solution, but you probably guessed it, I'm walking in unknown territory.

Your help would be very welcome

Here's my inxi

Code: Select all

 System:    Host: LeRepaireDesBrigands Kernel: 4.8.0-53-generic i686 (32 bit gcc: 5.4.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18.2 Sonya
Machine:   System: ASUSTeK (portable) product: X540SAA v: 1.0
           Mobo: ASUSTeK model: X540SAA v: 1.0
           Bios: American Megatrends v: X540SAA.303 date: 09/20/2016
CPU:       Quad core Intel Pentium N3710 (-MCP-) cache: 1024 KB
           flags: (lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 12800
           clock speeds: max: 2560 MHz 1: 689 MHz 2: 532 MHz 3: 479 MHz
           4: 480 MHz
Graphics:  Card: Intel Device 22b1 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.97hz
           GLX Renderer: Mesa DRI Intel HD Graphics 405 (Braswell) x86/MMX/SSE2
           GLX Version: 3.0 Mesa 12.0.6 Direct Rendering: Yes
Audio:     Card Intel Device 2284 driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter
           driver: rtl8723be port: d000 bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 1000.2GB (26.4% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABD1 size: 1000.2GB
Partition: ID-1: / size: 913G used: 242G (28%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 472M used: 65M (15%) fs: ext2 dev: /dev/sda1
           ID-3: swap-1 size: 4.19GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 62.0C mobo: 46.0C
           Fan Speeds (in rpm): cpu: 3400
Info:      Processes: 211 Uptime: 2:36 Memory: 1665.1/3941.7MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

User avatar
Level 19
Level 19
Posts: 9054
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Can't use microphone, only playback

Post by phd21 » Tue Apr 24, 2018 11:02 am

HI Chocapic,

I do not see anything wrong with the results of the "inxi -Fxzd" console terminal command, so that is a good thing. Might consider updating the Linux Kernel to the 4.13.xx or 4.14.xx series for newer hardware and security reasons.

If you could please post a screenshot or more of "QasMixer" fullscreen on the "sysdefault" mixer, that would be a good starting point. QasMixer will show different results depending upon the computer hardware it is run on.

Also after helping others, I noticed that for whatever reasons, sometimes the default Sound Settings Configuration may not be on Full Duplex as it should be.

Note: Usually the various volume sliders would be about halfway up, but depending upon the type of microphone, you may need to adjust that higher or lower.

Hope this helps ...
My QasMixer for
Intel 82801JD/DO (ICH10 Family) HD Audio
KDE Sound Settings General Configuration
Linux Mint KDE Sound Settings Input (microphones)
Last edited by phd21 on Tue Apr 24, 2018 1:15 pm, edited 1 time in total.
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:

User avatar
Level 10
Level 10
Posts: 3477
Joined: Tue Jul 05, 2016 1:20 pm

Re: Can't use microphone, only playback

Post by trytip » Tue Apr 24, 2018 11:37 am

i remember installing things on top of things hoping one of them will kickstart something but most of the time it only took away hard drive space and solved nothing. first you need to clear up your temp sound files go to .config/pulse delete everything in it and reboot

Post Reply

Return to “Hardware Support”