Grub no detecta Windows 8

Spanish Forum

Moderator: JCSenar

isanchcr
Level 1
Level 1
Posts: 20
Joined: Sun May 06, 2018 7:18 am

Grub no detecta Windows 8

Post by isanchcr » Sun May 06, 2018 7:20 am

Buenos días, ayer instalé Mint en un portátil y luego quise instalar Windows para tener un arranque dual en el ordenador. Pues me encuentro con que el grub no detecta la partición de Windows y he intentado todo lo que he leído en la red. ¿Alguna sugerencia?

User avatar
JCSenar
Level 9
Level 9
Posts: 2743
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Grub no detecta Windows 8

Post by JCSenar » Sun May 06, 2018 9:09 am

Hola isanchcr: ¡Bienvenido al foro! :D
isanchcr wrote:
Sun May 06, 2018 7:20 am
luego quise instalar Windows para tener un arranque dual en el ordenador.
¿Conseguiste instalar Windows? ¿En qué partición?

El orden correcto para la instalación es primero Windows y luego Linux Mint. Windows necesita estar en las primeras particiones del disco.

De todas formas, respondiendo a tu pregunta, para que Grub reconozca los distintos sistemas operativos has de hacer en el Terminal:

Code: Select all

sudo os-prober
seguido de:

Code: Select all

sudo update-grub
Esto debería hacer que se reconozcan los distintos sistemas y que aparezcan en el Grub. En caso contrario, pon aquí el resultado de esos códigos utilizando el formato code </>.
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

isanchcr
Level 1
Level 1
Posts: 20
Joined: Sun May 06, 2018 7:18 am

Re: Grub no detecta Windows 8

Post by isanchcr » Tue May 08, 2018 3:01 am

Generando archivo de configuración grub...
Aviso: Ya no se permite establecer GRUB_TIMEOUT a un valor distinto de cero cuando GRUB_HIDDEN_TIMEOUT está activado.
Encontrada imagen de linux: /boot/vmlinuz-4.10.0-38-generic
Encontrada imagen de memoria inicial: /boot/initrd.img-4.10.0-38-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
hecho

Eso es después de os-probe y update grub

isanchcr
Level 1
Level 1
Posts: 20
Joined: Sun May 06, 2018 7:18 am

Re: Grub no detecta Windows 8

Post by isanchcr » Tue May 08, 2018 3:56 am

Bueno decir que primero tenía linux mint instalado y luego quise meter windows. Ayer deshice todas las particiones y empecé al revés. Primero windows y luego detrás una partición con linux y nada, me tira windows directamente, no me sale ni el menú de selección de SO y mucho menos me detecta la partición de windows... probé os-probe pero no me dice nada... y update grub pues ya véis lo que me tira.

User avatar
JOPETA
Level 13
Level 13
Posts: 4714
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Grub no detecta Windows 8

Post by JOPETA » Tue May 08, 2018 4:38 am

Es necesario que devuelvas el resultado completo de los códigos propuestos . Mejor copiar y pegarlos en la terminal (ya que no es os-probe sino os-prober) y devolverlos de la forma solicitada es decir siguiendo las indicaciones de este enlace.
1)¿Cómo instalaste Mint?. Si seguiste algún tutorial proporciona el enlace. ¿Tuviste algún problema o comunicación de error durante la instalación? ¿Se trata de Linux y Windows de 64 bits?

2)Aunque ya te lo ha preguntado JCSenar sigues sin responder ¿Creaste una partición para Windows? ¿Cómo? ¿Donde? Copia y pega en la terminal los siguiente códigos (una línea cada vez seguido de Intro) y proporciona el resultado de la misma manera (usando la opción </> Code)

Code: Select all

inxi -Fxznr
sudo fdisk -l
3)Dices que quisiste instalar Windows ¿Que ocurrió en la pretendida instalación? ¿Algún error que recuerdes?

4) Para obtener un arranque dual los dos sistemas deben estar instalados del mismo modo, lo que significa realizar un particionado adecuado del Disco duro y tener una configuración adecuada de la propia BIOS/UEFI.
SI fuera un equipo BIOS tradicional con el disco duro particionado en MBR (msdos) no deberías haber tenido problemas al instalar Windows de haber reservado espacio al principio del disco (son dos las particiones que requiere como mínimo Windows 8 y deben ser las primeras como dice JCSenar (aunque te habrías cargado el GRUB de pura lógica). Todo dependerá, aún así de que el resultado final sea sean máximo 4 particiones primarias ( o tres primarias y una extendidad con varas particiones lógicas)

En los modernos sistemas BIOS/UEFI existe la posibilidad de iniciar en modo Compatible o CSM lo que permite iniciar y tener instalado un sistema en modo MBR (BIOS tradicional) e iniciar otros en modo UEFI (por ejemplo el medio de Instalación de Windows) o viceversa .

Linux puede instalarse en partionados GPT sin mayores problemas y no requieren de partición EFI. Sin embargo para que la instalación de Windows en partionado GPT prospere y se deben crear además de las particiones de Windows la partición EFI.
5)En espera de que los resultados confirmen lo que ocurre, como ya te indica JCSenar, te convendría ir pensando primero en instalar WIndows 8, elimiando el particionado actual y seleccionando el modo que deses de instalación, dejándolo hacer. Posteriormente instala Mint siguiendo el tutorial adecuado
-Instalar Linux Mint junto a Windows XP-7 (BIOS), instalación tradicional con Windows preexistente en modo Legacy, Compatible (CSM) o sistemas BIOS (MBR).

-Instalar Linux Mint 17-18 junto Windows 7-10 (UEFI), completo tutorial de instalación detallado paso a paso desde la configuración previa de Windows y la UEFI/BIOS hasta la solución de los problemas más frecuentes de inicio una vez instalado. Profusamente ilustrado y con enlaces a las aclaraciones de detalle para que no te pierdas.
Last edited by JOPETA on Tue May 08, 2018 4:48 am, edited 1 time in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

isanchcr
Level 1
Level 1
Posts: 20
Joined: Sun May 06, 2018 7:18 am

Re: Grub no detecta Windows 8

Post by isanchcr » Tue May 08, 2018 4:42 am

Code: Select all

System:    Host: ivan-Aspire-5735 Kernel: 4.13.0-39-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18.3 Sylvia
Machine:   System: Acer product: Aspire 5735 v: 0100
           Mobo: Acer model: CathedralPeak v: Rev
           Bios: Phoenix v: V1.08 date: 09/10/2008
CPU:       Dual core Intel Pentium Dual T3200 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 ssse3) bmips: 7980
           clock speeds: max: 2000 MHz 1: 1345 MHz 2: 1254 MHz
Graphics:  Card: Intel Mobile 4 Series Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.11hz
           GLX Renderer: Mesa DRI Mobile Intel GM45 Express
           GLX Version: 2.1 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-39-generic
Network:   Card-1: Marvell 88E8071 PCI-E Gigabit Ethernet Controller
           driver: sky2 v: 1.30 port: 2000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Broadcom BCM4312 802.11b/g LP-PHY
           driver: wl bus-ID: 03:00.0
           IF: wlp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 600.1GB (2.6% used)
           ID-1: /dev/sda model: KINGSTON_SV300S3 size: 120.0GB
           ID-2: /dev/sdb model: SAMSUNG_HM321HI size: 320.1GB
           ID-3: USB /dev/sdd model: 00BEVS size: 160.0GB
Partition: ID-1: / size: 25G used: 6.6G (29%) fs: ext4 dev: /dev/sda5
           ID-2: /home size: 30G used: 478M (2%) fs: ext4 dev: /dev/sda6
           ID-3: swap-1 size: 8.60GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 49.0C mobo: 48.0C
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list.d/atareao-telegram-xenial.list
           deb http://ppa.launchpad.net/atareao/telegram/ubuntu xenial main
           deb-src http://ppa.launchpad.net/atareao/telegram/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/atareao-whatsapp-desktop-xenial.list
           deb http://ppa.launchpad.net/atareao/whatsapp-desktop/ubuntu xenial main
           deb-src http://ppa.launchpad.net/atareao/whatsapp-desktop/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com sylvia main upstream import backport #id:linuxmint_main
           deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
Info:      Processes: 183 Uptime: 38 min Memory: 857.0/2931.3MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

isanchcr
Level 1
Level 1
Posts: 20
Joined: Sun May 06, 2018 7:18 am

Re: Grub no detecta Windows 8

Post by isanchcr » Tue May 08, 2018 4:43 am

Code: Select all

Disk /dev/sda: 111,8 GiB, 120034123776 bytes, 234441648 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x06332da3

Disposit.  Inicio     Start     Final  Sectores  Size Id Tipo
/dev/sda1  *           2048    206847    204800  100M  7 HPFS/NTFS/exFAT
/dev/sda2            206848 102402047 102195200 48,7G  7 HPFS/NTFS/exFAT
/dev/sda3         102404094 234440703 132036610   63G  5 Extendida
/dev/sda5         102404096 155135999  52731904 25,1G 83 Linux
/dev/sda6         155138048 217636863  62498816 29,8G 83 Linux
/dev/sda7         217638912 234440703  16801792    8G 82 Linux swap / Solaris


Disk /dev/sdb: 298,1 GiB, 320072933376 bytes, 625142448 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xa590c937

Disposit.  Inicio  Start     Final  Sectores  Size Id Tipo
/dev/sdb2         206848 625141759 624934912  298G  7 HPFS/NTFS/exFAT


Disk /dev/sdd: 149,1 GiB, 160041885696 bytes, 312581808 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x4c937ecc

Disposit.  Inicio     Start     Final  Sectores  Size Id Tipo
/dev/sdd1  *      134560440 312578047 178017608 84,9G  7 HPFS/NTFS/exFAT
/dev/sdd2             16065 134560439 134544375 64,2G  f W95 Ext'd (LBA)
/dev/sdd5             16128 134560439 134544312 64,2G  7 HPFS/NTFS/exFAT

Partition table entries are not in disk order.

isanchcr
Level 1
Level 1
Posts: 20
Joined: Sun May 06, 2018 7:18 am

Re: Grub no detecta Windows 8

Post by isanchcr » Tue May 08, 2018 4:44 am

He instalado linux con windows en muchas ocasiones y es la primera vez que me pasa esto. No sé si instalarlo en un ssd influye, pero es la única diferencia con las demás. El disco sin partición, instalo windows, meto mint, creo particiones e instalo... y nada, tira linux directo y no detecta nada más.

User avatar
JOPETA
Level 13
Level 13
Posts: 4714
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Grub no detecta Windows 8

Post by JOPETA » Tue May 08, 2018 5:08 am

Ya que sigues sin proporcionar el resultado de sudo os-prober, confirma en primer lugar que no tienes instalado GRUB Customizer u otro precargador como BURG y que puedes montar la partición de Windows sin mayores problemas desde el navegador de archivos. Si no pudieras devuelve cualquier error que te lance en el montaje de las dos partiones Güindolin.

Aunque existen Live de rescate (Recatux, Supergrub 2, Boot Repair) o se podría instalar Boot Repair y ejecutarlo desde la instalación de Mint o incluso crear una entrada personalizada para Windows en el menú GRUB, creo que lo mas tangible, ya que aseguras en primer lugar que Windows no se ha visto dañado (si como pareces indicar, por ejemplo, no defragmentaste ni le redujiste espacio desde el propio Güindolín y reiniciaste con él para comprobar la efectividad de los cambios antes de instalar Mint) puede ser:
1)Inicia con el medio de instalación de Güindolín para resolver los problemas de inicio de este. La imposibilidad de este rescate significaría que Güindolín está dañado y procedería la reinstalación desde cero, pero esta vez tomando las oportunas precauciones que establece JCSenar en su tutorial comentadas antes.

2)Si por el contrario el rescate del inicio de Güindolín es posible, cuando logres iniciar con él asegúrate que desactivas las Hibernación/ Inicio rápido de Güindolín.

3)Procede a iniciar con el Live de Mint para reinstalar GRUB de la forma indicada aquí.
Last edited by JOPETA on Thu May 10, 2018 3:19 am, edited 13 times in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

isanchcr
Level 1
Level 1
Posts: 20
Joined: Sun May 06, 2018 7:18 am

Re: Grub no detecta Windows 8

Post by isanchcr » Tue May 08, 2018 5:13 am

Una cosa supercuriosa que me acaba de pasar ahora... tengo un disco duro que conecté por usb con windows instalado y al hacer la prueba de os-prober me detecta windows jajajajajaja pero al arrancar sí me sale el menú de selección pero no lo ejecuta... flipante.

isanchcr
Level 1
Level 1
Posts: 20
Joined: Sun May 06, 2018 7:18 am

Re: Grub no detecta Windows 8

Post by isanchcr » Tue May 08, 2018 6:18 am

Es que sudo or-prober no me saca nada en pantalla, por eso no lo pongo, pero sí me detecta cuando tengo un usb puesto con windows y eso es lo que me mosquea.

isanchcr
Level 1
Level 1
Posts: 20
Joined: Sun May 06, 2018 7:18 am

Re: Grub no detecta Windows 8

Post by isanchcr » Tue May 08, 2018 7:10 am

Mas detalles. Antes de cambiar el disco a un ssd tenía los dos sistemas operativos instalados y no había problema alguno, todo ha sido a raíz del cambio a ssd...

User avatar
JCSenar
Level 9
Level 9
Posts: 2743
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Grub no detecta Windows 8

Post by JCSenar » Tue May 08, 2018 9:51 am

isanchcr wrote:
Tue May 08, 2018 3:56 am
Bueno decir que primero tenía linux mint instalado y luego quise meter windows. Ayer deshice todas las particiones y empecé al revés. Primero windows y luego detrás una partición con linux y nada, me tira windows directamente, no me sale ni el menú de selección de SO y mucho menos me detecta la partición de windows... probé os-probe pero no me dice nada... y update grub pues ya véis lo que me tira.
Entonces esto es una errata.
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

isanchcr
Level 1
Level 1
Posts: 20
Joined: Sun May 06, 2018 7:18 am

Re: Grub no detecta Windows 8

Post by isanchcr » Wed May 09, 2018 3:33 am

No, no es una errata, os pongo todo lo que me ha salido en todas las veces que he intentado tener el arranque dual y nada... Primero me tiraba solamente windows, luego solo linux, ahora solo linux sin el menú de selección...

User avatar
JOPETA
Level 13
Level 13
Posts: 4714
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Grub no detecta Windows 8

Post by JOPETA » Wed May 09, 2018 3:46 am

Lee mi post anterior y sigue lo indicado. Si te toca reinstalar todo, ten en consideración los Pasos previos Imprescindibles que establece JCSenar en sus tutoriales.Este vale para para instalar Mint junto a Guindos (un recuerdo de mis partes Sr. Ex-Ministro) 8-10 instalados en modo BIOS . :wink:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

isanchcr
Level 1
Level 1
Posts: 20
Joined: Sun May 06, 2018 7:18 am

Re: Grub no detecta Windows 8

Post by isanchcr » Wed May 09, 2018 4:32 am

Antes del cambio a ssd todo funcionaba perfecto, arranque dual y demás... ya os digo, he instalado linux con windows mil veces pero esta vez es diferente, no veo qué se me escapa. Formatee windows desde 0 e hice todo lo demás como siempre, pero sigue sin funcionar. No sé si tendré que instalar los sistemas en discos diferentes.

isanchcr
Level 1
Level 1
Posts: 20
Joined: Sun May 06, 2018 7:18 am

Re: Grub no detecta Windows 8

Post by isanchcr » Thu May 10, 2018 2:30 am

¿De qué manera puedo adjuntar una captura de pantalla con las particiones de mi disco duro?

User avatar
JOPETA
Level 13
Level 13
Posts: 4714
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Grub no detecta Windows 8

Post by JOPETA » Thu May 10, 2018 3:10 am

Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

isanchcr
Level 1
Level 1
Posts: 20
Joined: Sun May 06, 2018 7:18 am

Re: Grub no detecta Windows 8

Post by isanchcr » Thu May 10, 2018 3:18 am

Ahí va
Attachments
Captura de pantalla_2018-05-10_07-13-48.png

User avatar
JOPETA
Level 13
Level 13
Posts: 4714
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Grub no detecta Windows 8

Post by JOPETA » Thu May 10, 2018 3:29 am

Es un particionado similar al que ya has mostrado en listado anteriormente aunque el flag boot lo tiene ahora la partición sda2 (antes era la sda1). Un poco de contexto no vendría mal. ¿En que situación estás ahora?.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

Post Reply

Return to “Español (Spanish)”