[SOLVED] Mint will not allow me to save folder in new partition due to permissions

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
kologha
Level 1
Level 1
Posts: 24
Joined: Wed May 16, 2018 11:47 am

[SOLVED] Mint will not allow me to save folder in new partition due to permissions

Post by kologha » Wed May 16, 2018 12:08 pm

My PC had two 500mb disks, one for the OS and one for my personal data. The personal data disk failed and the OS disk had so many Pre-fail flags that I decided to replace it before it failed. I had made a Clonezilla image of the personal data disk on a portable HDD so haven't lost any data. I installed a WD 1TB disk and cloned the OS onto it using Clonezilla. No problems with the OS it boots and works. However I decided to put my personal data onto this disk instead of installing a second disk and made a 465GB partition which I labelled RRG Documents using Gparted. I tried to copy my personal data from the portable drive onto this partition but Mint would not allow this, so I copied the data onto my personal folder thinking that I would move it to RRG Documents once it was on the PC. This I cannot do as it displays the following message: "The folder cannot be copied because you do not have permissions to create it in the destination."
How do I give myself permission to copy this folder to RRG Documents?
Thank you
Last edited by kologha on Fri May 18, 2018 1:23 pm, edited 1 time in total.

User avatar
all41
Level 13
Level 13
Posts: 4510
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Mint will not allow me to save folder in new partition due to permissions

Post by all41 » Wed May 16, 2018 1:01 pm

Since gparted runs as root the partitions it creates are owned by root and the group is also root.
Change in a terminal:

Code: Select all

sudo chown -R $USER:$USER /dev/sdXX
Replace sdXX with the actual partition id. (such as sda2)
That will set ownership and group to the logged in user.
Proud to be a supporter and monthly contributor to Mint.

kologha
Level 1
Level 1
Posts: 24
Joined: Wed May 16, 2018 11:47 am

Re: Mint will not allow me to save folder in new partition due to permissions

Post by kologha » Thu May 17, 2018 7:01 am

Tried using this code (partition is sda3) but still does not allow me to access it. I tried with the partition both mounted and unmounted, to no avail. Looking up the permissions in the properties for the partition it tells me: "The permissions of WDC WD10EZEX-08WN4A0: 'RRG Documents' could not be determined."

User avatar
WharfRat
Level 20
Level 20
Posts: 11428
Joined: Thu Apr 07, 2011 8:15 pm

Re: Mint will not allow me to save folder in new partition due to permissions

Post by WharfRat » Thu May 17, 2018 9:18 am

kologha wrote:
Thu May 17, 2018 7:01 am
Tried using this code (partition is sda3) but still does not allow me to access it. I tried with the partition both mounted and unmounted, to no avail. Looking up the permissions in the properties for the partition it tells me: "The permissions of WDC WD10EZEX-08WN4A0: 'RRG Documents' could not be determined."
With the drives plugged in paste back mount|grep ^/dev
ImageImage

User avatar
Lucap
Level 5
Level 5
Posts: 913
Joined: Tue May 24, 2016 1:40 am

Re: Mint will not allow me to save folder in new partition due to permissions

Post by Lucap » Thu May 17, 2018 9:25 am

What about right click and open nemo as root or sudo nemo from command line?

User avatar
Flemur
Level 15
Level 15
Posts: 5935
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Mint will not allow me to save folder in new partition due to permissions

Post by Flemur » Thu May 17, 2018 9:39 am

Lucap wrote:
Thu May 17, 2018 9:25 am
What about right click and open nemo as root or sudo nemo from command line?
"gksudo nemo" NOT "sudo"
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

kologha
Level 1
Level 1
Posts: 24
Joined: Wed May 16, 2018 11:47 am

Re: Mint will not allow me to save folder in new partition due to permissions

Post by kologha » Thu May 17, 2018 1:41 pm

{With the drives plugged in paste back mount|grep ^/dev}

Returns: "/dev/sda3 on /media/rrg/RRG Documents type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)". I still do not have permission to copy to partition.

{gksudo nemo}

Asks for password and then appears to do nothing.

User avatar
WharfRat
Level 20
Level 20
Posts: 11428
Joined: Thu Apr 07, 2011 8:15 pm

Re: Mint will not allow me to save folder in new partition due to permissions

Post by WharfRat » Thu May 17, 2018 3:31 pm

If rrg is your user name then create a mountpoint /media/RRG then mount /dev/sda3 to it and sudo chown rrg:rrg /media/RRG

If you have files on the partition with owner:group settings other than you then use sudo chown-R rrg:rrg /media/RRG

Mount the partition to /media/RRG with /etc/fstab during boot.
ImageImage

User avatar
Lucap
Level 5
Level 5
Posts: 913
Joined: Tue May 24, 2016 1:40 am

Re: Mint will not allow me to save folder in new partition due to permissions

Post by Lucap » Fri May 18, 2018 12:49 am

*removed*

No longer relevant.
Last edited by Lucap on Fri May 18, 2018 9:11 am, edited 1 time in total.

kologha
Level 1
Level 1
Posts: 24
Joined: Wed May 16, 2018 11:47 am

Re: Mint will not allow me to save folder in new partition due to permissions

Post by kologha » Fri May 18, 2018 6:47 am

If rrg is your user name then create a mountpoint /media/RRG then mount /dev/sda3 to it and sudo chown rrg:rrg /media/RRG

If you have files on the partition with owner:group settings other than you then use sudo chown-R rrg:rrg /media/RRG

Mount the partition to /media/RRG with /etc/fstab during boot.

My user name is rrg (small letters). I am the only one using the PC, but I am not sure how to create a mountpoint, please be so kind as to talk me through as I am literally in way over my head. I generally lookup anything that needs to be done on the Internet and luckily up to now I have always found the necessary code which I would then copy & paste. Thank you.

User avatar
Sir Charles
Level 7
Level 7
Posts: 1832
Joined: Thu Jan 04, 2018 1:00 pm

Re: Mint will not allow me to save folder in new partition due to permissions

Post by Sir Charles » Fri May 18, 2018 7:51 am

... create a mountpoint /media/RRG

Code: Select all

sudo mkdir /media/RRG
... mount /dev/sda3 to it

Code: Select all

sudo mount /dev/sda3 /media/RRG
and then:

Code: Select all

sudo chown -R rrg:rrg /media/RRG
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

User avatar
JerryF
Level 9
Level 9
Posts: 2767
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Mint will not allow me to save folder in new partition due to permissions

Post by JerryF » Fri May 18, 2018 8:36 am

kologha wrote:
Thu May 17, 2018 1:41 pm
{With the drives plugged in paste back mount|grep ^/dev}

Returns: "/dev/sda3 on /media/rrg/RRG Documents type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)". I still do not have permission to copy to partition.

{gksudo nemo}

Asks for password and then appears to do nothing.
OP may not be using Cinnamon (Nemo file manager)
IF AND WHEN your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

User avatar
Flemur
Level 15
Level 15
Posts: 5935
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Mint will not allow me to save folder in new partition due to permissions

Post by Flemur » Fri May 18, 2018 9:04 am

JerryF wrote:
Fri May 18, 2018 8:36 am
OP may not be using Cinnamon (Nemo file manager)
I don't have "nemo" and "gksudo nemo" produces "nothing" as the OP said. It's a bug in gksudo, which should act like "sudo":

Code: Select all

$ sudo nemo
[sudo] password for X: 
sudo: nemo: command not found
Edit: this is a lesson on why everyone should either give their system specs like they're "supposed to", or just stick to terminal commands.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

kologha
Level 1
Level 1
Posts: 24
Joined: Wed May 16, 2018 11:47 am

Re: Mint will not allow me to save folder in new partition due to permissions

Post by kologha » Fri May 18, 2018 9:53 am

Thank you Marziano, I can now copy to the partition. All I need to know now, is how to edit my original post to include the word 'Solved'. Thanks everyone.

User avatar
Sir Charles
Level 7
Level 7
Posts: 1832
Joined: Thu Jan 04, 2018 1:00 pm

Re: Mint will not allow me to save folder in new partition due to permissions

Post by Sir Charles » Fri May 18, 2018 10:37 am

You are welcome! I am/We are (if I can speak on behalf of all the respondents in the thread) glad that your issue is resolved. In order to mark the thread as solved you would need to edit your first post by clicking on the pen icon and adding [SOLVED] to the title of the thread.
Enjoy you Mint!
Cheers
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

User avatar
JerryF
Level 9
Level 9
Posts: 2767
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Mint will not allow me to save folder in new partition due to permissions

Post by JerryF » Fri May 18, 2018 12:23 pm

Flemur wrote:
Fri May 18, 2018 9:04 am
...
Edit: this is a lesson on why everyone should either give their system specs like they're "supposed to", or just stick to terminal commands.
Yes, I agree :?
IF AND WHEN your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

Post Reply

Return to “Newbie Questions”