My mouse stopped working

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
brutusoftroy99
Level 1
Level 1
Posts: 13
Joined: Thu Mar 01, 2018 9:29 pm

My mouse stopped working

Post by brutusoftroy99 » Thu May 17, 2018 8:11 am

ok guys, sorry for the dumb question.
I don't know what version of mint I am running but I installed it about 4 months ago.
I bought a mouse from Tesco. It worked fine......and then..... it stopped working.
the thing is that I can still click on whatever the cursor is on... and I can still scroll the screen up and down using the wheel but the cursor won't move at all.
Any advice?
Thankyou.

User avatar
darethehair
Level 4
Level 4
Posts: 233
Joined: Sun Mar 08, 2009 2:22 pm
Location: Morden Manitoba Canada
Contact:

Re: My mouse stopped working

Post by darethehair » Thu May 17, 2018 8:33 am

I don't have any great ideas, but one thing that I always try to do when I want to help isolate tech problems is to try to use them in a different context to see if it makes a difference. In this case, my suggestion would be to try using it on a different computer (or, if this is a dual-boot computer with Windows on it, boot with Windows) to see if it works or not. If it doesn't work, perhaps the mouse has failed -- in which case you might want to open it to see if there is anything you can do about it (I did this once for an optical mouse, and got it to work again).
There is nothing more dangerous than a bored cat.

User avatar
administrollaattori
Level 14
Level 14
Posts: 5007
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: My mouse stopped working

Post by administrollaattori » Thu May 17, 2018 8:56 am

Mouse uses four wire, so some of them may be broken.
https://hubpages.com/technology/USB-Wir ... USB-wiring

User avatar
lsemmens
Level 5
Level 5
Posts: 682
Joined: Wed Sep 10, 2014 9:07 pm
Location: Rural South Australia

Re: My mouse stopped working

Post by lsemmens » Thu May 17, 2018 9:36 am

The first question I would ask is "Wired or Wireless?"
If wireless - new battery?
if wired - try it in another computer or using a live OS.
Kernel: 4.15.0-24-generic x86_64 bits: 64
Desktop: Cinnamon 3.8.7
Distro: Linux Mint 19 Tara

Laptop T4500 Dualcore 4Gb RAM
Server AMD Phenom 9650 - GEForce 9400GT 6Gb RAM
Out of my mind - please leave a message

User avatar
AndyMH
Level 4
Level 4
Posts: 486
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: My mouse stopped working

Post by AndyMH » Thu May 17, 2018 4:34 pm

Tesco - sounds cheap. Probably the mouse not mint. Been a fan of MS mice for years, more expensive but reliable. A lot of us like to knock MS, but their hardware peripherals are pretty good.
Thinkpad T430 i7-3632 Cinnamon 18.3, Thinkpad T420 Cinnamon 18.3, Thinkpad T410 Cinnamon 17.3, Thinkpad T60 19.0 Mate

User avatar
BG405
Level 6
Level 6
Posts: 1238
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: My mouse stopped working

Post by BG405 » Fri May 18, 2018 10:32 am

AndyMH wrote:
Thu May 17, 2018 4:34 pm
A lot of us like to knock MS, but their hardware peripherals are pretty good.
True. I'd get another wireless 3500 tomorrow if I could afford it, mine's showing its age, a bit like its owner. Still works though, except the scroll wheel. :(

I'd suggest taking it back for a replacement, it will still be under warranty if it's only 4 months old. It's likely the sensor has failed if the switches still work, happened to a couple of mine. If it's had an impact, that could have wrecked the alignment or the sensor itself. Liquids (including switch cleaner, which I found out the hard way) will ruin an optical sensor.

To get & post system specs, open a Terminal and enter inxi -Fxz, highlight the text, copy (CTRL+SHIFT+C), then in your post, paste the output between [CODE] & [/CODE] tags by pressing the </> button followed by CTRL+V.

NB: inxi is a very useful tool, you can look at all the options using man inxi. :)

P.S. Thanks Catweazel for the idea of putting the code markers in inline code, it's much more readable like this.
Dell Inspiron 1525 - LM17.3 CE 64-------------------Acer D255E 2GB - Manjaro KDE, LM17.3 KDE 32
Toshiba NB305 - LM17.3 Xfce 32---------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Dell PII 350 64MB - Puppy 4.3 & Win98-SE

User avatar
wallyUSA
Level 4
Level 4
Posts: 413
Joined: Thu Jun 08, 2017 2:31 pm
Location: N. Georgia Mtns USA (UTC-4/5)

Re: My mouse stopped working

Post by wallyUSA » Sat May 19, 2018 8:04 am

Personally, I like Logitech. I have wireless mouse/keyboard that comes with 3 year warranty. Lots of options and good support!
Tara Cinnamon 3.8.8 Kernel 4.15.0-29 (64 bit)
Please, if your query has been resolved, edit your first post and add [SOLVED] to the subject line.

brutusoftroy99
Level 1
Level 1
Posts: 13
Joined: Thu Mar 01, 2018 9:29 pm

Re: My mouse stopped working

Post by brutusoftroy99 » Sat May 19, 2018 8:06 am

System: Host: brutus-ThinkPad-Edge-E130 Kernel: 4.13.0-38-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine: System: LENOVO product: 3358AXG v: ThinkPad Edge E130
Mobo: LENOVO model: 3358AXG v: Win8 Pro DPK TPG Bios: LENOVO v: H4ET92WW (2.52 ) date: 04/18/2013
CPU: Dual core Intel Core i3-3227U (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7582
clock speeds: max: 1900 MHz 1: 854 MHz 2: 846 MHz 3: 1012 MHz 4: 888 MHz
Graphics: Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.07hz
GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio: Card Intel 7 Series/C210 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.13.0-38-generic
Network: Card-1: Broadcom BCM43228 802.11a/b/g/n driver: wl bus-ID: 03:00.0
IF: wlp3s0 state: up mac: <filter>
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 09:00.0
IF: enp9s0 state: down mac: <filter>
Drives: HDD Total Size: 320.1GB (14.5% used) ID-1: /dev/sda model: Hitachi_HTS72503 size: 320.1GB
Partition: ID-1: / size: 290G used: 40G (15%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 4.00GB used: 0.07GB (2%) fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 46.0C mobo: 0.0C
Fan Speeds (in rpm): cpu: 589
Info: Processes: 218 Uptime: 5:18 Memory: 2650.8/3669.2MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

there's my specs, great command.
and yes it's a wireless.
So I guess the conclusion is go and buy another one.
ok will do
thanks guys

Post Reply

Return to “Newbie Questions”