Screen Tearing V18.3 XFCE

Forum rules
Before you post please read how to get help
Post Reply
corma
Level 1
Level 1
Posts: 2
Joined: Fri Jun 08, 2018 2:22 pm

Screen Tearing V18.3 XFCE

Post by corma » Fri Jun 08, 2018 3:06 pm

Hi everyone,

I like Linux Mint but all XFCE versions (up to 18.3) suffers from screen tearing even with changes in the desktop setting. (metacity compton,...)
With the compton metacity all works well except Netflix in Firefox.
No screen tearing at all when I use the Cinnamon DE.
Why XFCE can not function without screen tearing out of the box like Cinnamon ?
I am currently using Ubuntu an have no problem at all.
Any easy and logical fix would move me again to Mint XFCE :)

User avatar
MrEen
Level 6
Level 6
Posts: 1342
Joined: Mon Jun 12, 2017 8:39 pm

Re: Screen Tearing V18.3 XFCE

Post by MrEen » Fri Jun 08, 2018 4:27 pm

I could have sworn almost all tearing issues I've read about were Cinnamon users (and some Mate users.)

I'm using Xfce and have never seen tearing. I don't need any eye candy, so my settings are more conservative, but you can try Menu > Settings > Desktop Settings change to Xfwm4 and see if you can tolerate that. I'm guessing that might have something to do with no tearing here, but I could be wrong.

User avatar
TeaSwigger
Level 3
Level 3
Posts: 125
Joined: Mon Feb 06, 2012 6:42 am
Location: CA

Re: Screen Tearing V18.3 XFCE

Post by TeaSwigger » Fri Jun 08, 2018 8:57 pm

In Desktop Settings > Window Manager I'm using 'Xfwm4 + Compton' and not getting any tearing issues in Mint 18.3 xfce (AMD w/radeon drivers).

Perhaps the issues are driver related. In my case, for an example, I had to tweak the radeon config in 18.2; I can't recall if it was carried over or not needed for 18.3 back when I upgraded. For 18.2 anyway, I created a file called 20-radeon.conf in /usr/share/X11/xorg.conf.d/ directory with the following contents:

Code: Select all

Section "Device"
	Identifier "Radeon"
	Driver "radeon"
	Option "DRI" "3"
	Option "AccelMethod" "glamor"
EndSection
Again, this is for AMD/radeon. nvidia or others may need their own different fixes.

Perhaps some Compton settings need to be adjusted for your system. They're set in a hidden file in your home directory (so ~/.compton.conf). Here's my .compton.conf in case it might help you sort yours out (it's a bit of a mess right now, but working fine):

Code: Select all

backend = "glx";
paint-on-overlay = true;
glx-no-stencil = true;
glx-no-rebind-pixmap = true;
vsync = "opengl-swc";
glx-swap-method = "3";

#unredir-if-possible = true; 

# These are important. The first one enables the opengl backend. The last one is the vsync method. Depending on the driver you might need to use a different method.
# The other options are smaller performance tweaks that work well in most cases. 
# You can find the rest of the options here: https://github.com/chjj/compton/wiki/perf-guide, and here: https://github.com/chjj/compton/wiki/vsync-guide


# Shadow
shadow = true;			# Enabled client-side shadows on windows.
no-dock-shadow = true;		# Avoid drawing shadows on dock/panel windows.
no-dnd-shadow = true;		# Don't draw shadows on DND windows.
clear-shadow = true;		# Zero the part of the shadow's mask behind the window (experimental).
shadow-radius = 6;		# The blur radius for shadows. (default 12)
shadow-offset-x = -6;		# The left offset for shadows. (default -15)
shadow-offset-y = -6;		# The top offset for shadows. (default -15)
shadow-exclude = [
	"name = 'Notification'",
	"class_g = 'Conky'",
	"class_g ?= 'Notify-osd'",
	"class_g = 'Cairo-clock'",
	"class_g = 'mpv'",
    "class_g = 'vlc'",
    "class_g = 'ghb'",
    "class_g = 'ghb'",
    "class_g = 'HandBrake'",
    "class_g = 'Preview'",
	"class_g = 'gksu'",
	"class_g = 'Firefox' && argb",
    "_GTK_FRAME_EXTENTS@:c"
];
# shadow-exclude = "n:e:Notification";
# shadow-exclude-reg = "x10+0+0";
# xinerama-shadow-crop = true;
#shadow-exclude = [
# "! name~=''",
# "n:e:Notification",
# "n:e:Plank",
# "n:e:Docky",
# "g:e:Synapse",
# "g:e:Kupfer",
# "g:e:Conky",
# "n:w:*Firefox*",
# "n:w:*Chrome*",
# "n:w:*Chromium*",
# "class_g ?= 'Notify-osd'",
# "class_g ?= 'Cairo-dock'",
# "class_g ?= 'Xfce4-notifyd'",
# "class_g ?= 'Xfce4-power-manager'"
# "_GTK_FRAME_EXTENTS@:c"
#];

# The shadow exclude options are helpful if you have shadows enabled. Due to the way compton draws its shadows, certain applications will have visual glitches 
# (most applications are fine, only apps that do weird things with xshapes or argb are affected). 
# This list includes all the affected apps I found in my testing. The "! name~=''" part excludes shadows on any "Unknown" windows, this prevents a visual glitch with the XFWM alt tab switcher.

focus-exclude = [
    "class_g = 'mpv'",
    "class_g = 'vlc'"
];


# Fading
fading = true; # Fade windows during opacity changes.
fade-delta = 4; # The time between steps in a fade in milliseconds. (default 10).
fade-in-step = 0.03; # Opacity change between steps while fading in. (default 0.028).
fade-out-step = 0.03; # Opacity change between steps while fading out. (default 0.03).
#no-fading-openclose = true; # Fade windows in/out when opening/closing

detect-client-opacity = true; # This prevents opacity being ignored for some apps. For example without this enabled my xfce4-notifyd is 100% opacity no matter what.

# Window type settings
wintypes:
{
  tooltip = { fade = true; shadow = false; };
};
If your only issues are in Firefox: Under Firefox's preferences > General > Performance try unchecking 'Use hardware acceleration when available' and under Browsing try disabling 'autoscrolling' and 'smooth scrolling'.

Good luck :)
Mint 18.3 xfce w/nemo - AMD Quad Core - lovely ASUS Xonar ST sound - Radeon R7 Graphics - 1920x1200 Dell U2415
some favs: Zim - mocp - kid3 - calibre - gimp - artha - deluge - handbrake - k3b - ClickRepair - mc
Folding@Home Mint Team Contributor

corma
Level 1
Level 1
Posts: 2
Joined: Fri Jun 08, 2018 2:22 pm

Re: Screen Tearing V18.3 XFCE

Post by corma » Sat Jun 09, 2018 1:16 pm

Hi and thanks for your reply :)
It is probably only a browser (Firefox) problem and only with Netfix movies, youtube is doing fine.
Also files like mpeg, divx and mkv play well with the default media player.
Steam and GOG ganes also works fine.
All with metacity-compton.
I didn't have any of those screen tearing problems with Cinnamon, it worked out of the box.
Currently I am running Ubuntu and will keep it that way for a while, little bit lazzy I guess :)

Post Reply

Return to “Xfce”