This also occurred with Mint 17.3 LTS, and as a last-resort, I rebuilt Caja (1.12) from source - lo and behold, it worked perfectly and has continued to do so for about the past 2 years. So, the problem is not with Caja, it has to do with the way the Mint packages are being built!
So, back to now, I'm trying to build Caja on my fresh 18.3 install and seem to have hit an insurmountable problem. I have downloaded from the Git-hub, source for the same version of Caja that is installed - 1.18.5 https://github.com/mate-desktop/caja/tr ... eced28dfc2. When I try building this, I receive the following errors;
Question, how can a Caja 1.18.5-build be requiring Depend-versions that are newer that the current repository installations? It seems to me that the Devs. built these packages using newer libraries, probably from Mint 19-Beta repositories. If so, this laziness prevents Mint 18.3 users from 'rolling their own' Caja, and likely a whole lot of other packages, until the repositories receive a major update. This is in a word, unconscionable.Requested 'glib-2.0 >= 2.50.0' but version of GLib is 2.48.2
No package 'mate-desktop-2.0' found
Requested 'gio-2.0 >= 2.50.0' but version of GIO is 2.48.2