I cannot explain this situation at all, after system freeze, onboard ethernet adapter changed mac add perm. and more!

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
Level 4
Level 4
Posts: 411
Joined: Tue Aug 05, 2014 7:52 pm

I cannot explain this situation at all, after system freeze, onboard ethernet adapter changed mac add perm. and more!

Post by fruitkiller » Tue Jun 12, 2018 12:12 pm

So, it started with the long story of my onboard adapter not connecting normally to my vps. I use openvpn to connect to it, as if it was a vpn server. Now that my FTTH connection is way over 100/100 (I got it this way), it has been boosted twice in 2 years for free and now it's more along the lines of 500/350. So of course, I want to use my onboard adapter, since it is 10/100/1000 and not my old (but thankfully much more stable) pci ethernet card which is 10/100 which cuts my speed that I pay for a lot. But I am forced to use it. I'll try to explain everything as succinctly as possible.

OpenVPN connection on the fast onboard adapter all of a sudden starts to connect but most of the time will not be able to do anything related to a browser. I can go on IRC, I can use Pidgin, but http/s doesn't work, except on the very website of my vps provider. Switching to the old PCI adapter I kept to plug another computer to my main desktop for some time, then later for a hard drive that works with ethernet, which I sold, so, I'm bound to it. Although sometimes, randomly openvpn connection on the main onboard adapter will work in all browsers I have installed, but that often stops working after some time, especially if the computer was put on lock-down (no, I do not have the option to turn off internet when that happens).

What's even stranger is that at a moment where I was demanding a lot, from my supposedly very strong cpu (with an incredible EVO cooling device that keeps even 4 core compiling under 35c), which is an AMDFX-8350 Black Edition (slightly overclocked to 4.2ghz per core instead of the 4ghz by default) octocore 4ghz and 24gb of Corsair ram.
Although, the freezing I experienced was so unusual, I never started the application that caused it again...I have better tools on my VPS for what I was trying to do anyways. What happened is that I had forced a change in the mac address of the onboard adapter, it seemed to help connecting to the vps through openvpn. But what happened when the desktop froze is something I really don't understand...it burned in the fake mac address I assigned to it (using hw ether eth0 *mac*) or such, since macchanger -r does not work in Mint 17.x (it always doesn't change the mac address and says IT'S THE SAME MAC!!!...I know many people noticed this here.

But yes, now the network-manager sees "eth0" (I'll come back to this in a sec), as Realtek P8H77-I Motherboard....which...doesn't make sense.

Code: Select all

Machine:   Mobo: ASUSTeK model: M5A97 LE R2.0 version: Rev 1.xx Bios: American Megatrends version: 2701 date: 03/24/2016
inxi -N
Network:   Card-1: VIA VT6102/VT6103 [Rhine-II] driver: via-rhine 
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
It used to say the motherboard adaoter was an AsusTek Gigabit etc. If I boot in Windows 7, which I almost never do, and see if all drivers are up to date, they are and it somehow sees the real name for the adapter, but also sees it with the corrupted burned-in mac address which isn't even the one I had given to it, only the three last double digits are still there from the original mac address.

I tried changing DNS servers, which I had to do anyway, my isp's dns servers suck, they don't even have DNSSEC, which I find to be a complete necessity. I tried many things. But it only got stranger. Upon a reboot, the onboard adapter became eth3. I don't know what the deal is, but when that freezing happened, after reboot, it said that the onboard adapter wasn't managed, so I looked around and I was given an option, somewhere in the file where you can force a mac address on boot and other things, /etc/something/networking...I don't remember exactly right now, I could find it but you guys surely know what I mean, anyway, I fixed it by changing a config option that was ifupdown=false and changed it to true, following a guide for instances of an adapter showing up as "not managed" or such. After that it became usable again but then it seems like a package took over the job, aptly named ifupdown, and I had to do an update to it just now, it shows up in network-manager, the "Connect" option is now called Ifupdown (eth0), even if an ifconfig shows no such thing as eth0...eth0 became eth3. It's a mess, and all of this because of the very strange behaviour of that motherboard network adapter acting so strangely.

If you guys want me to show the config of some files, I'll cooperate, I'd really like to have the onboard adapter show as eth0 again, not have to enable this ifupdown to have my suddenly moved to another address without telling the landlord onboard adapter that supports speed over 100mbps, but that has so many problems with openvpn (it stems from this problem that everything else snowballed from it, as you all can see).

I don't expect a miracle, but I'd use some help here, if possible. I feel slighted by this, even wondering if the onboard adapter is somehow corrupt...but it works without openvpn, which is a strange thing, despite everything else. But that forces me to use max 100mbps out of my 500 (well, 280, the vps connection reduces it, hence why I want to use the faster adapter, it drops more when using the spare pci card, that saves my butt for now. Does 10/100/1000 pci ethernet cards even exist? If push comes to shove..I only got free regular pci slots, the pci-e ones are all in use.

Post Reply

Return to “Ethernet”