Wrong GPU use in GRUB

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
wou5er
Level 1
Level 1
Posts: 2
Joined: Sun Jun 10, 2018 11:16 am

Wrong GPU use in GRUB

Post by wou5er » Tue Jun 12, 2018 9:50 pm

Hello,

So i've been using Mint for some while now and i decided to do a dual boot with windows 10

I got a :

Intel i7 6800k
Gigabyte X-99 Gaming 7
Nvidia GTX1070 Main
Nvidia GTX560 TI

In windows everything works fine...
When i boot my pc and it gets into grub it doesn't use my GTX1070 as main but the HDMI on my GTX560 TI.
How am i able to change this so it boots on only one video output.
I'd tryed Boot repair and different type of applications that do the same thing but i don't get it to work.
Google or forum search doesn't help me eiter, perhaps i use the wrong search therms but still, i'm'out ideas and hope you guyes can clear some out.

Linux mint is running latest Nvidia drivers PPA version x90.xx

dustystrings3001
Level 1
Level 1
Posts: 4
Joined: Tue May 01, 2012 11:36 pm

Re: Wrong GPU use in GRUB

Post by dustystrings3001 » Fri Jun 15, 2018 12:51 am

I'm not sure whether this response will work for your specific situation, but it will describe the steps I took when loading Linux Mint for the first time onto a PC that had an Nvidia GTX-970 card (which was fairly new at the time of PC build - January 2016). Perhaps this narrative will help put you further down the road on solving your issue.

1. the PC had an on-board HDMI video port (max resolution 2560x1440) as well as the Nvidia GTX-970 (max resolution >= 3840x2160). Not quite the same as your situation, but maybe not too different.
2. when I initially loaded Linux Mint, I first used the UEFI boot menu to (1) activate the Nvidia card and (2) deactivate the on-board HDMI video, then moved the HDMI cable to the Nvidia port. Linux Mint installation then froze up hard (and repeatably) at the very beginning with a black screen. No error message - but it was clear that the system was unable to deal with the GTX-970 card with the vido driver used by the Mint installation process.
3. I then used UEFI boot menu to (1) deactivate Nvidia card and (2) activate the on-board HDMI video, and was rewarded when Linux Mint installation proceeded just fine with on-board HDMI video.
4. So I then went to the Mint Systems Settings area under Driver Manager to see whether a proprietary driver for the Nvidia card could be found once the cache was updated. It was! So I installed that proprietary driver, powered the system down, then used UEFI boot menu to (1) activate the Nvidia card and (2) deactivate the on-board HDMI video, and moved the video cable back to the Nvidia port. After power-up, the Nvidia card worked fine - much to my relief, as I really wanted that 4K video.

So I did not use the PPA method for proprietary video drivers that you used, but instead used the Driver Manager. Perhaps Linux Mint works better when you use the Driver Manager (?). And after a year or so, I noticed that the open source Noveau driver that Linux Mint uses by default for installations must have been upgraded, and could handle the GTX-970 card without choking ... and I no longer needed to do all that UEFI video port enabling/disabling.

Hope this adds some value to your troubleshooting. :D

Post Reply

Return to “Newbie Questions”