[SOLVED],Canon ImageCLASSD530

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
CoastalBoy
Level 1
Level 1
Posts: 18
Joined: Thu Dec 29, 2016 12:14 pm

[SOLVED],Canon ImageCLASSD530

Post by CoastalBoy » Wed Jun 13, 2018 3:28 pm

Has anyone ever come up with a solution to use this printer, Canon D530 monochrome laser (All in One) with Linux Mint 18.3? I have been looking and researching this problem for days. I have been using Mint 18.3,(32 bit) for the past year and I had the printer working. I have been using Kernel 4.10.0-38 and sticking with it because any other kernel kills my wifi adapter. Recently I switched computers and I installed MInt 18.3,(64 bit) and the printer worked at first. Then after setting mint up as was directed by "Easy LInux tips project" things started going wrong. Trying to make this short, it seems the printer worked fine until I updated the cups driver recommended for Canon, UFR II Printer Driver for Linux Version 3.50. I think my solution is to uninstall ALL the versions of cups I have installed and revert to the old cups 2.90 or somewhere back in an older version. I think I was using cups 3.31 or 3.40 when it worked before. I have since learned that the Canon D530 doesn't support 64 bit drivers despite they are available.

So....... how do I remove any and all the versions of CUPS I've installed? Please help before I take hammer to this printer.

Thanks for looking and any help would be greatly appreciated. I know it is an old printer and everything I know now says DO NOT BUY CANON PRINTERS FOR LINUX!!! But I just really can not afford a new printer.

Here is what I think I have installed:

sailor@sailor-Latitude-D630 ~ $ dpkg -l | grep Canon
ii cndrvcups-common:i386 3.90-1 i386 Canon Printer Driver Common Modules Ver.3.90
rc cndrvcups-ufr2-uk:i386 3.10-1 i386 Canon UFR2 Printer Driver for Linux
ii cndrvcups-ufr2-us:i386 3.50-1 i386 Canon UFR2 Printer Driver for Linux
ii cups-backend-bjnp 2.0-0ubuntu2 amd64 printer backend for Canon BJNP protocol
Last edited by CoastalBoy on Fri Jun 15, 2018 6:28 am, edited 4 times in total.

User avatar
administrollaattori
Level 14
Level 14
Posts: 5487
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Canon ImageCLASSD530

Post by administrollaattori » Wed Jun 13, 2018 3:35 pm

For knowing installed "cups" packages, run

Code: Select all

dpkg --get-selections | grep cups

CoastalBoy
Level 1
Level 1
Posts: 18
Joined: Thu Dec 29, 2016 12:14 pm

Re: Canon ImageCLASSD530

Post by CoastalBoy » Wed Jun 13, 2018 3:45 pm

Here is the output for that command:

sailor@sailor-Latitude-D630 ~ $ dpkg --get-selections | grep cups
bluez-cups install
brother-cups-wrapper-common install
cndrvcups-common:i386 install
cndrvcups-ufr2-uk:i386 deinstall
cndrvcups-ufr2-us:i386 install
cndrvcups-utility:i386 install
cups install
cups-backend-bjnp install
cups-browsed install
cups-bsd install
cups-client install
cups-common install
cups-core-drivers install
cups-daemon install
cups-filters install
cups-filters-core-drivers install
cups-ipp-utils install
cups-pk-helper install
cups-ppdc install
cups-server-common install
cups-x2go deinstall
libcups2:amd64 install
libcups2:i386 install
libcupscgi1:amd64 install
libcupscgi1:i386 install
libcupsfilters1:amd64 install
libcupsfilters1:i386 install
libcupsimage2:amd64 install
libcupsimage2:i386 install
libcupsmime1:amd64 install
libcupsmime1:i386 install
libcupsppdc1:amd64 install
libcupsppdc1:i386 install
printer-driver-cups-pdf deinstall
python-cups install
python3-cups install

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Canon ImageCLASSD530 uses Canon's UFRII

Post by pdc_2 » Thu Jun 14, 2018 3:24 pm

so I don't know how you installed the 3.5 drivers; I don't know where someone said the D530 doesn't like 64bit drivers;

Canon continue to issue updates to their drivers; so the UFR 3.5 was issued 8th Feb 2018: so let's all join in and thank Canon for supporting linux with rpm; debian and source code packages; in both 32bit and 64 bit packages ..

_________

you say your Mint version is 64bit; but the drivers you listed are 32bit;
eg Canon say in the 3.5 README ........
cndrvcups-common_3.90-1_amd64.deb (for Debian 64-bit)
to me, you seem to have
cndrvcups-common:i386 3.90-1 i386 Canon Printer Driver Common Modules Ver.3.90
I don't know how you installed the drivers; but I would suggest that using Canon's install script allows the install script to do the work;

so if I were advising folks: I would say: go here http://support-asia.canon-asia.com/cont ... 24010.html

and click to download and SAVE what will be linux-UFRII-drv-v350-uken.tar.gz and it should end up in your Downloads folder

then open a terminal; copy each line of commands below; line by line; paste each line into the terminal; hit the ENTER key after each paste;

(oh, and delete any entries in the PRINTERS folder as you say they do not work ........... ie delete existing icons for the D530)

Code: Select all

cd Downloads

Code: Select all

tar -zxvf linux-UFRII-drv-v350-uken.tar.gz

Code: Select all

cd linux-UFRII-drv-v350-uken

Code: Select all

sudo ./install.sh
watch that final command as it may ask you some questions; I wouldn't worry about deleting existing drivers; I would let the script work it out for itself;

.....that is starting from scratch advice; if you look in your Downloads folder, is linux-UFRII-drv-v350-uken sitting there? (unpacked?) If so, you don't need to download it

____________
you posted this in the general hardware forum; there is a printers sub-forum; where posts are more likely to be seen; so let's wait till you have read this; and then we get a mod to move this

_________
ou have got the word SOLVED in the title of your first post: perhaps edit that out till we can see if we can get the printer working

It is all very frustrating and irritating when all this printer disturbance happens; we can only hope for a better outcome for you

CoastalBoy
Level 1
Level 1
Posts: 18
Joined: Thu Dec 29, 2016 12:14 pm

Re: Canon ImageCLASSD530

Post by CoastalBoy » Thu Jun 14, 2018 7:49 pm

Well Lo and Behold! I went back and followed your directions. Yes, there were several questions about removing several things I had erroneously installed or never should have clicked on, whatever. The short of the story is I now have a functional Printer!!!

I think in my frustration I had added enough BS that I didn't know what I had done.

Thank You Very Much!

here is my current printer arrangement, I will wait to hear from you before I mark my questions as SOLVED!

sailor@sailor-Latitude-D630 ~ $ dpkg --get-selections | grep cups
bluez-cups install
cndrvcups-common install
cndrvcups-ufr2-uk install
cndrvcups-ufr2-us:i386 deinstall
cndrvcups-utility install
cups install
cups-backend-bjnp install
cups-browsed install
cups-bsd install
cups-client install
cups-common install
cups-core-drivers install
cups-daemon install
cups-filters install
cups-filters-core-drivers install
cups-ipp-utils install
cups-pk-helper install
cups-ppdc install
cups-server-common install
cups-x2go deinstall
libcups2:amd64 install
libcups2:i386 install
libcupscgi1:amd64 install
libcupsfilters1:amd64 install
libcupsfilters1:i386 install
libcupsimage2:amd64 install
libcupsimage2:i386 install
libcupsmime1:amd64 install
libcupsppdc1:amd64 install
printer-driver-cups-pdf deinstall
python-cups install
python3-cups install
python3-cupshelpers install

Thanks Again!

pdc_2
Level 8
Level 8
Posts: 2411
Joined: Mon May 11, 2009 1:21 am

Re: Canon ImageCLASSD530

Post by pdc_2 » Fri Jun 15, 2018 1:24 am

well done! You did well; glad to hear all is working; enjoy

(By the way you can now add SOLVED to the title of the first post!)

CoastalBoy
Level 1
Level 1
Posts: 18
Joined: Thu Dec 29, 2016 12:14 pm

Re: Canon ImageCLASSD530

Post by CoastalBoy » Fri Jun 15, 2018 6:25 am

Well again, Thank you very much for your help. I was not looking forward to buying a different printer. Now I can afford a BEER and see about utilizing the scanner!

Best Regards

Post Reply

Return to “Hardware Support”