Shutter have dependencies problem in Linux Mint 19

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
monkiki
Level 1
Level 1
Posts: 6
Joined: Sun Jun 26, 2011 5:26 am

Shutter have dependencies problem in Linux Mint 19

Post by monkiki » Thu Jun 14, 2018 3:58 am

Hi all,

I'm testing Linux Mint 19 and I've found a problem with Shutter: I can't install those packages needed to enable the Edit button:

Code: Select all

$ sudo apt-get install libgoo-canvas-perl libgoocanvas-common libgoocanvas3 libgoocanvas-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libgoo-canvas-perl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libgoo-canvas-perl' has no installation candidate
E: Unable to locate package libgoocanvas-common
E: Unable to locate package libgoocanvas3
E: Unable to locate package libgoocanvas-common
Should I report this problem in another place?

User avatar
catweazel
Level 14
Level 14
Posts: 5480
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Shutter have dependencies problem in Linux Mint 19

Post by catweazel » Thu Jun 14, 2018 4:18 am

monkiki wrote:
Thu Jun 14, 2018 3:58 am
Should I report this problem in another place?
Yes. Mint 19 is unsupported here until it's released. Post your comments on the Mint blog.

Linux Mint 19 "Tara" Cinnamon – BETA Release
Linux Mint 19 "Tara" MATE – BETA Release
Linux Mint 19 "Tara" Xfce – BETA Release
A new scientific truth does not triumph by convincing its opponents and making them see the light, but rather because its opponents eventually die, and a new generation grows up that is familiar with it. - Max Planck

Marziano
Level 6
Level 6
Posts: 1400
Joined: Thu Jan 04, 2018 1:00 pm

Re: Shutter have dependencies problem in Linux Mint 19

Post by Marziano » Thu Jun 14, 2018 4:19 am

monkiki wrote:
Thu Jun 14, 2018 3:58 am
I can't install those packages needed to enable the Edit button:
Me too, I noticed the problem after installing Shutter in Ubuntu 18.04. Those packages seem not to be included in Bionic's
repositories (see bug report in launchpad) and consequently absent in Tara. I haven't tried the QuickFix described in the link myself but maybe you will find it worthwhile to give it a consideration.
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

Hoser Rob
Level 11
Level 11
Posts: 3863
Joined: Sat Dec 15, 2012 8:57 am

Re: Shutter have dependencies problem in Linux Mint 19

Post by Hoser Rob » Thu Jun 14, 2018 7:08 am

Even with new stable, non beta, actually officially supported releases it's common that not all the software you may want is available at first. With unstable beta unsupported releases like Mint 19 it's obviously going to be even worse.

My advice, unless you have seriously bleeding edge hardware and have some kind of hate on for Ubuntu, which does support Ubuntu 18.04, is to install MInt 18.3. Frankly I wish Mint could develop a larger expert user base so they wouldn't encourage using rank beginners to do their beta testing. Beginners using beta OS releases is NUTS.

User avatar
JerryF
Level 9
Level 9
Posts: 2510
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Shutter have dependencies problem in Linux Mint 19

Post by JerryF » Thu Jun 14, 2018 8:39 am

Hoser Rob wrote:
Thu Jun 14, 2018 7:08 am
...
My advice, unless you have seriously bleeding edge hardware and have some kind of hate on for Ubuntu, which does support Ubuntu 18.04, is to install MInt 18.3. Frankly I wish Mint could develop a larger expert user base so they wouldn't encourage using rank beginners to do their beta testing. Beginners using beta OS releases is NUTS.
The whole idea is trying to the most diverse users to run the beta so that bugs can be found. But...

If newbies want to install a beta, that's their choice, but shouldn't come running 'home' crying that this, that, and the other isn't working properly.

I'm being blunt because I get frustrated with people not taking responsibility of their own actions.
IF AND WHEN your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

Hoser Rob
Level 11
Level 11
Posts: 3863
Joined: Sat Dec 15, 2012 8:57 am

Re: Shutter have dependencies problem in Linux Mint 19

Post by Hoser Rob » Thu Jun 14, 2018 9:30 am

JerryF wrote:
Thu Jun 14, 2018 8:39 am
Hoser Rob wrote:
Thu Jun 14, 2018 7:08 am
...
My advice, unless you have seriously bleeding edge hardware and have some kind of hate on for Ubuntu, which does support Ubuntu 18.04, is to install MInt 18.3. Frankly I wish Mint could develop a larger expert user base so they wouldn't encourage using rank beginners to do their beta testing. Beginners using beta OS releases is NUTS.
The whole idea is trying to the most diverse users to run the beta so that bugs can be found. But...

If newbies want to install a beta, that's their choice, but shouldn't come running 'home' crying that this, that, and the other isn't working properly.

I'm being blunt because I get frustrated with people not taking responsibility of their own actions.
I was blunt because Linux newbies don't generally understand the implications of installing a beta release, and I stand by my comments.

User avatar
JerryF
Level 9
Level 9
Posts: 2510
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Shutter have dependencies problem in Linux Mint 19

Post by JerryF » Thu Jun 14, 2018 11:07 am

Hoser Rob wrote:
Thu Jun 14, 2018 9:30 am
JerryF wrote:
Thu Jun 14, 2018 8:39 am
Hoser Rob wrote:
Thu Jun 14, 2018 7:08 am
...
My advice, unless you have seriously bleeding edge hardware and have some kind of hate on for Ubuntu, which does support Ubuntu 18.04, is to install MInt 18.3. Frankly I wish Mint could develop a larger expert user base so they wouldn't encourage using rank beginners to do their beta testing. Beginners using beta OS releases is NUTS.
The whole idea is trying to the most diverse users to run the beta so that bugs can be found. But...

If newbies want to install a beta, that's their choice, but shouldn't come running 'home' crying that this, that, and the other isn't working properly.

I'm being blunt because I get frustrated with people not taking responsibility of their own actions.
I was blunt because Linux newbies don't generally understand the implications of installing a beta release, and I stand by my comments.
My comment about being blunt wasn't anything towards your post. I agree with you. Beta releases aren't for the faint of heart.
IF AND WHEN your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

User avatar
smgordon1259
Level 1
Level 1
Posts: 33
Joined: Tue Jul 30, 2013 6:12 pm
Location: Wisconsin, USA

Re: Shutter have dependencies problem in Linux Mint 19

Post by smgordon1259 » Thu Jun 14, 2018 11:21 am

That's Odd, I installed shutter and it is fully functional, edit button is accessible.

have you tried uninstalling then reinstalling ?

did you install Shutter through the Software manager?
ASUS M5A78L-M/USB3
AMD FX-4350 (4.2gHz)
MSI GeForce GT730 - 2gb Memory
Linux Mint 19 MATE Beta amd64/ Kernel 4.15.0-22
Team Vulcan DDR3 1600mHz (8gb)
Primary: Seagate 500GB SSHD
Secondary: Seagate 1TB SSHD
Tertiary: Hitachi 750GB HD

monkiki
Level 1
Level 1
Posts: 6
Joined: Sun Jun 26, 2011 5:26 am

Re: Shutter have dependencies problem in Linux Mint 19

Post by monkiki » Fri Jun 15, 2018 12:40 am

Marziano wrote:
Thu Jun 14, 2018 4:19 am
Me too, I noticed the problem after installing Shutter in Ubuntu 18.04. Those packages seem not to be included in Bionic's
repositories (see bug report in launchpad) and consequently absent in Tara. I haven't tried the QuickFix described in the link myself but maybe you will find it worthwhile to give it a consideration.
Thanks for pointing to the solution :)

Marziano
Level 6
Level 6
Posts: 1400
Joined: Thu Jan 04, 2018 1:00 pm

Re: Shutter have dependencies problem in Linux Mint 19

Post by Marziano » Fri Jun 15, 2018 12:45 am

You are welcome! I'm glad I could help.
Cheers
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

monkiki
Level 1
Level 1
Posts: 6
Joined: Sun Jun 26, 2011 5:26 am

Re: Shutter have dependencies problem in Linux Mint 19

Post by monkiki » Fri Jun 15, 2018 12:54 am

JerryF wrote:
Thu Jun 14, 2018 8:39 am
Hoser Rob wrote:
Thu Jun 14, 2018 7:08 am
...
My advice, unless you have seriously bleeding edge hardware and have some kind of hate on for Ubuntu, which does support Ubuntu 18.04, is to install MInt 18.3. Frankly I wish Mint could develop a larger expert user base so they wouldn't encourage using rank beginners to do their beta testing. Beginners using beta OS releases is NUTS.
The whole idea is trying to the most diverse users to run the beta so that bugs can be found. But...

If newbies want to install a beta, that's their choice, but shouldn't come running 'home' crying that this, that, and the other isn't working properly.

I'm being blunt because I get frustrated with people not taking responsibility of their own actions.
Sorry but if you think I came crying you're absolutely lost. I started using Linux in 1995 with Slackware, when you needed to compile the kernel just to get the sound card working. So don't try to explain me what a beta is. I know this is a beta and decided to install. It's pretty stable, even to be used daily at work. I just found a issue and wanted to report it. I can't understan why it should be a problem.

User avatar
JerryF
Level 9
Level 9
Posts: 2510
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Shutter have dependencies problem in Linux Mint 19

Post by JerryF » Fri Jun 15, 2018 8:12 am

monkiki wrote:
Fri Jun 15, 2018 12:54 am
Sorry but if you think I came crying you're absolutely lost. I started using Linux in 1995 with Slackware, when you needed to compile the kernel just to get the sound card working. So don't try to explain me what a beta is. I know this is a beta and decided to install. It's pretty stable, even to be used daily at work. I just found a issue and wanted to report it. I can't understan why it should be a problem.
Not a problem. Issues for beta releases should be reported in the Comments section at Mint blog LinuxMint.com
IF AND WHEN your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

User avatar
Moem
Level 15
Level 15
Posts: 5896
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Shutter have dependencies problem in Linux Mint 19

Post by Moem » Fri Jun 15, 2018 8:15 am

monkiki wrote:
Fri Jun 15, 2018 12:54 am
I just found a issue and wanted to report it. I can't understan why it should be a problem.
You're missing the point: you can't report beta bugs in this forum, it's the wrong place. And you can't expect support for beta issues here, either. So it was redundant to post your issue on the forum. That's all.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

monkiki
Level 1
Level 1
Posts: 6
Joined: Sun Jun 26, 2011 5:26 am

Re: Shutter have dependencies problem in Linux Mint 19

Post by monkiki » Fri Jun 15, 2018 8:30 am

Well, I was not aware of it.

Giving support using a blog is not very common. In my opinion, posting these issues in the forum would ease the feedback and collaboration. Or even better, using a ticket system like osTicket, Mantis or Jira. Or just GitHub :)

Best regards.

User avatar
Moem
Level 15
Level 15
Posts: 5896
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Shutter have dependencies problem in Linux Mint 19

Post by Moem » Fri Jun 15, 2018 8:43 am

monkiki wrote:
Fri Jun 15, 2018 8:30 am
Giving support using a blog is not very common.
You were giving feedback, right? Not asking for support, as I understood it.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
Ozo
Level 5
Level 5
Posts: 714
Joined: Tue Dec 22, 2015 11:49 am
Location: Titusville, Florida USA

Re: Shutter have dependencies problem in Linux Mint 19

Post by Ozo » Fri Jun 15, 2018 9:22 am

If Clem did not want this dialog he would have locked the thread from the get go. This kind of thing happens every time one of these type announcements is left open.

Post Reply

Return to “Software & Applications”