No sound on Linux Mint 18.3

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

No sound on Linux Mint 18.3

Post by robluck82 » Thu Jun 14, 2018 6:11 pm

System:
HP Envy 27 P014
Fresh LINUX MINT 18.3 Cinnamon install 24 hours ago, no audio whatsoever. As you'll see, I've upgraded the kernel to the latest stable release, no effect. Will be reverting back to 4.13.0-45.50~16.04.1

PAVUCONTROL shows a number of devices, all unplugged. Device = "Built-in Audio Digital Stereo (HDMI)
ALSAMIXER shows the same single device, labeled "0 HDA Intel PCH"
ALSAMIXER shows "PCM" volume 100, and three S/PDIF outputs all at 00 - nothing is muted, cannot increase volume on the S/PDIFs

Opening an audio application (Rhythmbox) causes the app to freeze and force close.

Uname:
4.17.1-041701-generic #201806111730 SMP Mon Jun 11 21:32:41 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux


Audio Device from lspci:
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)

Aplay output:
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0


PLEASE HELP! :)

User avatar
MrEen
Level 6
Level 6
Posts: 1058
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Linux Mint 18.3

Post by MrEen » Thu Jun 14, 2018 9:34 pm

Hi robluck82, and welcome to the forum.

If you look at this topic you might notice same audio card and busID as you're running. ori0n's mysteriously started working the next day. Can we hope the same for you?

A couple of things that might improve the help here:
1. Is HDMI how you want sound? Or from your speakers/headphones? If the latter, in pavucontrol's Configuration tab is there a second Built-in Audio dropdown to select Analog Stereo Duplex? If this is accomplished, go back to the Output Devices tab and you should be able to select headphones or speakers.
2. Have you installed anything related to JACK (jackd, Cadence, Qjackctl, etc?) If so, you might need to kill jack to get pulseaudio running again with killall jackd followed by pulseaudio --start (there are other ways to get them to cooperate that I won't go into here.)

I'll probably have more questions after I have some of these answers.

Good luck.

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Sat Jun 16, 2018 2:50 pm

MrEen -

I've seen your name and assistance all over this forum as I have been searching for answers, so thank you for helping me out as well. It is truly appreciated!

OK, to answer your questions:
1. HDMI is the only option, it seems. Some context: This is an HP ENVY all-in-one desktop PC. What's REALLY interesting is there is no external headphone jack, so I have no way of testing that, either. Now, in pavucontrol and the configuration tab, NO cards are available for configuration.
2. Nothing related to JACK.

I did follow the topic you linked and installed some of the packages mentioned in that thread that were missing. I will reboot!

Thanks!

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Sat Jun 16, 2018 2:58 pm

No dice after reboot.

One thing I should mention: I now have Rythmnbox working. In fact, I'm streaming radio on it now, but of course no sound. How strange!

User avatar
MrEen
Level 6
Level 6
Posts: 1058
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Linux Mint 18.3

Post by MrEen » Sat Jun 16, 2018 3:14 pm

Well, it's improvement at least. While Rythmbox is playing is there visual feedback in pavucontrol's Playback tab?

Also, in alsamixer, what options exist when you press F6?

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Sat Jun 16, 2018 3:25 pm

Yes, Rythmnbox shows visual feedback in pavucontrol. :)

What's interesting, is I remember checking alsamixer, and no - nothing was muted or at 00. However, alsamixer is now missing. I have alsa-utils installed, so will purge that and reinstall and reboot.

Also, while browsing the syslog, I came across this:

Jun 16 13:52:17 rob-27-p014 pulseaudio[1165]: W: [pulseaudio] authkey.c: Failed to open cookie file '/home/rob/.config/pulse/cookie': No such file or directory
Jun 16 13:52:17 rob-27-p014 pulseaudio[1165]: W: [pulseaudio] authkey.c: Failed to load authentication key '/home/rob/.config/pulse/cookie': No such file or directory
Jun 16 13:52:17 rob-27-p014 pulseaudio[1165]: W: [pulseaudio] server-lookup.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NotSupported: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
Jun 16 13:52:17 rob-27-p014 pulseaudio[1165]: W: [pulseaudio] main.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NotSupported: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
Jun 16 13:52:17 rob-27-p014 systemd[1161]: Started Sound Service.

Do any of those pulseaudio errors make a difference?

User avatar
MrEen
Level 6
Level 6
Posts: 1058
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Linux Mint 18.3

Post by MrEen » Sat Jun 16, 2018 3:34 pm

robluck82 wrote:
Sat Jun 16, 2018 3:25 pm
Do any of those pulseaudio errors make a difference?
I honestly don't know. Hopefully restoring alsamixer will get us somewhere.

User avatar
MrEen
Level 6
Level 6
Posts: 1058
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Linux Mint 18.3

Post by MrEen » Sat Jun 16, 2018 3:42 pm

Also, when you have time, paste back the results of inxi -A as well as pacmd list-sinks

When pasting large blocks of text, use the code button (looks like </>) to help retain formatting. For me, when I hit that button I can rightclick anywhere in the text area to paste and it automatically pastes it between the code and /code tags.

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Sat Jun 16, 2018 3:46 pm

Results of

Code: Select all

inxi -A
:

Code: Select all

Audio:     Card Intel Sunrise Point-H HD Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.13.0-45-generic
And results of

Code: Select all

pacmd list-sinks
:

Code: Select all

1 sink(s) available.
  * index: 0
	name: <auto_null>
	driver: <module-null-sink.c>
	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: IDLE
	suspend cause: 
	priority: 1000
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 766.68 ms
	max request: 344 KiB
	max rewind: 344 KiB
	monitor source: 0
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	configured latency: 2000.00 ms; range is 0.50 .. 2000.00 ms
	module: 10
	properties:
		device.description = "Dummy Output"
		device.class = "abstract"
		device.icon_name = "audio-card"
I CANNOT get alsamixer back. I have GUI versions, which all report unmuted and such. Strange...

User avatar
MrEen
Level 6
Level 6
Posts: 1058
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Linux Mint 18.3

Post by MrEen » Sat Jun 16, 2018 3:56 pm

Eww. driver: <module-null-sink.c> That might be your problem. I'll try researching this.

User avatar
MrEen
Level 6
Level 6
Posts: 1058
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Linux Mint 18.3

Post by MrEen » Sat Jun 16, 2018 4:10 pm

Let's give this a shot and see if it works as it's easy to reverse if it doesn't help.

In the terminal, type gksudo xed /etc/modprobe.d/alsa-base.conf then scroll to the bottom of the file and add this line: options snd-hda-intel model=auto

Save the file, then reboot and test sound.

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Sat Jun 16, 2018 4:17 pm

No dice. Here's the contents of alsa-base.conf, for reference:

Code: Select all

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
options snd-hda-intel model=auto

User avatar
trytip
Level 7
Level 7
Posts: 1867
Joined: Tue Jul 05, 2016 1:20 pm

Re: No sound on Linux Mint 18.3

Post by trytip » Sat Jun 16, 2018 4:32 pm

delete everything in .config/pulse/ then open terminal and type pulseaudio -k wait about 5 seconds for new cookie to be created
Image

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Sat Jun 16, 2018 4:42 pm

trytip wrote:
Sat Jun 16, 2018 4:32 pm
delete everything in .config/pulse/ then open terminal and type pulseaudio -k wait about 5 seconds for new cookie to be created
Done, no change.

User avatar
MrEen
Level 6
Level 6
Posts: 1058
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Linux Mint 18.3

Post by MrEen » Sat Jun 16, 2018 5:29 pm

Damn. I typed eveything below then realized I've never seen your specs. Before trying the below, please post the results of inxi -Fxz.

Here's something that may help (but I'm not really counting on it.)

You said in your first post:
As you'll see, I've upgraded the kernel to the latest stable release, no effect. Will be reverting back to 4.13.0-45.50~16.04.1
I now see you had been using a kernel not supported by Mint/Ubuntu (4.17)

Maybe try using the Update Manager to update to the latest kernel in the 4.15 series and see if that resolves the issue. After opening the Update Manager click on View > Linux kernels, then click on 4.15 on the left, select 4.15.0-23 and click on Install.

EDIT: I should have asked this earlier as well. What exactly happens when you type alsamixer?

REEDIT: Give pulseaudio -k && sudo alsa force-reload a try before anything else.

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Sun Jun 17, 2018 9:26 am

Okie doke. So, when I pulseaudio -k && sudo alsa force-reload:

Code: Select all

rob@rob-27-p014 ~ $ pulseaudio -k && alsa force-reload
mkdir: cannot create directory ‘/var/run/alsa’: Permission denied
/sbin/alsa: Warning: Failed to create /var/run/alsa/. 
/sbin/alsa: Warning: Not keeping list of removed modules because /var/run/alsa is absent.
It will not be possible automatically to reload these modules. 
Unloading ALSA sound driver modules:/sbin/alsa: 135: /sbin/alsa: cannot create /var/run/alsa/modules-removed: Directory nonexistent
 snd-hda-intel snd-hda-codec snd-hda-core snd-hwdep snd-pcm snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer.
mkdir: cannot create directory ‘/var/run/alsa’: Permission denied
Loading ALSA sound driver modules: (none to reload).
rob@rob-27-p014 ~ $ sudo pulseaudio -k && alsa force-reload
[sudo] password for rob: 
E: [pulseaudio] core-util.c: Home directory not accessible: Permission denied
E: [pulseaudio] main.c: Failed to kill daemon: No such file or director
Interesting. Oh, and alsamixer just straight up ghosts me:

Code: Select all

rob@rob-27-p014 ~ $ alsamixer

alsamixer: function snd_ctl_open failed for default: No such file or directory
Here's my output of inxi -Fxz:

Code: Select all

System:    Host: rob-27-p014 Kernel: 4.13.0-45-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: HP model: 2B3E v: 1.05 Bios: AMI v: A0.06 date: 09/21/2015
CPU:       Quad core Intel Core i5-6400T (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 17664
           clock speeds: max: 2800 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz
           4: 800 MHz
Graphics:  Card: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@59.98hz
           GLX Renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2)
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-H HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.13.0-45-generic
Network:   Card-1: Intel Wireless 7265 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 1000.2GB (4.9% used)
           ID-1: /dev/sda model: ST1000LM024_HN size: 1000.2GB temp: 28C
Partition: ID-1: / size: 172G used: 35G (22%) fs: ext4 dev: /dev/sda6
           ID-2: swap-1 size: 12.74GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 211 Uptime: 10 min Memory: 1128.3/11873.6MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
As you can see, I've been messing with kernels to see if going back a bit helps. I'm installing 4.15.0-23 and rebooting now.

User avatar
MrEen
Level 6
Level 6
Posts: 1058
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Linux Mint 18.3

Post by MrEen » Sun Jun 17, 2018 10:39 am

rob@rob-27-p014 ~ $ pulseaudio -k && alsa force-reload
You missed the sudo before alsa.

EDIT: Before trying that, see next post first.
Last edited by MrEen on Sun Jun 17, 2018 10:57 am, edited 1 time in total.

User avatar
MrEen
Level 6
Level 6
Posts: 1058
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Linux Mint 18.3

Post by MrEen » Sun Jun 17, 2018 10:56 am

Well this might be telling:
E: [pulseaudio] core-util.c: Home directory not accessible: Permission denied
You seem to have lost ownership of part of your home directory. You can verify with find $HOME ! -user $USER and repair with sudo chown -R $USER:$USER /home/$USER

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Mon Jun 18, 2018 7:09 am

Results:

Code: Select all

rob@rob-27-p014 ~ $ find $HOME ! -user $USER
/home/rob/.cache/ukuu/v4.16.2
/home/rob/.cache/ukuu/v4.16.2/CHANGES
/home/rob/.cache/ukuu/v4.16.2/index.html
/home/rob/.cache/ukuu/v4.16.12/CHANGES
/home/rob/.cache/ukuu/v4.16.12/index.html
/home/rob/.cache/ukuu/v4.16.3
/home/rob/.cache/ukuu/v4.16.3/CHANGES
/home/rob/.cache/ukuu/v4.16.3/index.html
/home/rob/.cache/ukuu/v4.17-keep
/home/rob/.cache/ukuu/v4.17-keep/CHANGES
/home/rob/.cache/ukuu/v4.17-keep/index.html
/home/rob/.cache/ukuu/v4.17
/home/rob/.cache/ukuu/v4.17/CHANGES
/home/rob/.cache/ukuu/v4.17/index.html
/home/rob/.cache/ukuu/v4.16.9/CHANGES
/home/rob/.cache/ukuu/v4.16.9/index.html
/home/rob/.cache/ukuu/v4.16.10/CHANGES
/home/rob/.cache/ukuu/v4.16.10/index.html
/home/rob/.cache/ukuu/v4.16.5
/home/rob/.cache/ukuu/v4.16.5/CHANGES
/home/rob/.cache/ukuu/v4.16.5/index.html
/home/rob/.cache/ukuu/v4.16.4
/home/rob/.cache/ukuu/v4.16.4/CHANGES
/home/rob/.cache/ukuu/v4.16.4/index.html
/home/rob/.cache/ukuu/v4.16.1
/home/rob/.cache/ukuu/v4.16.1/CHANGES
/home/rob/.cache/ukuu/v4.16.1/index.html
/home/rob/.cache/ukuu/v4.16.8
/home/rob/.cache/ukuu/v4.16.8/CHANGES
/home/rob/.cache/ukuu/v4.16.8/index.html
/home/rob/.cache/ukuu/v4.16.6
/home/rob/.cache/ukuu/v4.16.6/CHANGES
/home/rob/.cache/ukuu/v4.16.6/index.html
/home/rob/.cache/ukuu/v4.16.14/CHANGES
/home/rob/.cache/ukuu/v4.16.14/index.html
/home/rob/.cache/ukuu/v4.17.1
/home/rob/.cache/ukuu/v4.17.1/amd64
/home/rob/.cache/ukuu/v4.17.1/CHANGES
/home/rob/.cache/ukuu/v4.17.1/index.html
/home/rob/.cache/ukuu/v4.16.15
/home/rob/.cache/ukuu/v4.16.15/CHANGES
/home/rob/.cache/ukuu/v4.16.15/index.html
/home/rob/.cache/dconf
find: ‘/home/rob/.cache/dconf’: Permission denied
/home/rob/.aptitude/config
rob@rob-27-p014 ~ $ sudo chown -R $USER:$USER /home/$USER
[sudo] password for rob: 
rob@rob-27-p014 ~ $ pulseaudio -k && sudo alsa force-reload
Unloading ALSA sound driver modules: snd-hda-intel snd-hda-codec snd-hda-core snd-hwdep snd-pcm snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer.
Loading ALSA sound driver modules: snd-hda-intel snd-hda-codec snd-hda-core snd-hwdep snd-pcm snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer.

User avatar
MrEen
Level 6
Level 6
Posts: 1058
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Linux Mint 18.3

Post by MrEen » Mon Jun 18, 2018 7:18 am

I think it's time to try a reinstall of sound modules.

Code: Select all

apt install --reinstall linux-sound-base alsa-base alsa-utils libasound2
Followed by:

Code: Select all

sudo alsa force-reload
Good luck.

Post Reply

Return to “Hardware Support”