can't get rid of "checking media (fail)"

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
eightwt
Level 1
Level 1
Posts: 18
Joined: Tue Nov 26, 2013 8:34 am

can't get rid of "checking media (fail)"

Post by eightwt » Thu Jun 14, 2018 8:35 pm

I have just installed Mint 18.3 on a Acer Aspire V3 112p machine with 240G SSD. My partitions look like this from gdisk :

Disk /dev/sda: 468862128 sectors, 223.6 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 11326D1A-4051-4529-B3D6-99D372289EDA
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 468862094
Partitions will be aligned on 2048-sector boundaries
Total free space is 3305 sectors (1.6 MiB)

Number Start (sector) End (sector) Size Code Name
1 2048 208895 101.0 MiB EF00 EFI System Partition
2 208896 142714755 68.0 GiB 8303 Mint OS
3 142714880 147425279 2.2 GiB 8200
4 147425280 468860927 153.3 GiB 8300 Linux filesystem

The firmware is set to UEFI with Secure Boot disabled.

The boot order is:
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 2003,2001,2002
Boot0000* Unknown Device: HD(1,GPT,c63e5c13-cf4e-43fc-9acd-dcc41288957f,0x800,0x32800)/File(\EFI\ubuntu\grubx64.efi)RC
Boot0001* Network Boot-IPV4: 54-AB-3A-04-A9-F5 PciRoot(0x0)/Pci(0x1c,0x2)/Pci(0x0,0x0)/MAC(54ab3a04a9f5,0)/IPv4(0.0.0.0:0<->0.0.0.0:0,0,0)RC
Boot0002* Network Boot-IPV6: 54-AB-3A-04-A9-F5 PciRoot(0x0)/Pci(0x1c,0x2)/Pci(0x0,0x0)/MAC(54ab3a04a9f5,0)/IPv6([::]:<->[::]:,0,0)RC
Boot0003* Unknown Device: HD(1,GPT,c63e5c13-cf4e-43fc-9acd-dcc41288957f,0x800,0x32800)/File(\EFI\ubuntu\grubx64.efi)RC
Boot0004* Unknown Device: HD(1,GPT,c63e5c13-cf4e-43fc-9acd-dcc41288957f,0x800,0x32800)/File(\EFI\ubuntu\grubx64.efi)RC
Boot2001* EFI USB Device RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC

When booted the machine goes into "checking media" mode for two cycles (looking for a network boot). Not finding anything it throws up a dialog asking to drop into the boot manager, which it does when I hit OK.

Then it shows me three options listed above: Boot0000,Boot0001, and Boot0002, in that order. Notice Boot0000 lists my SSD as Unknown Device. I select this one and I get the normal Grub menu from which I can select the OS to boot and it happily doe

User avatar
catweazel
Level 17
Level 17
Posts: 7463
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: can't get rid of "checking media (fail)"

Post by catweazel » Fri Jun 15, 2018 2:43 am

eightwt wrote:
Thu Jun 14, 2018 8:35 pm
When booted the machine goes into "checking media" mode for two cycles (looking for a network boot).
If that's correct then it has nothing to do with Linux Mint, rather it's your machine's BIOS that is set to PXE-boot from the network. Disable PXE boot in the BIOS.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

eightwt
Level 1
Level 1
Posts: 18
Joined: Tue Nov 26, 2013 8:34 am

Re: can't get rid of "checking media (fail)"

Post by eightwt » Fri Jun 15, 2018 8:18 am

I tried disabling PXE boot but then it wouldn't recognize the SSD at all.

I realize that this probably has nothing to do with Mint per se, but it does have everything to do with how to get a Linux distro to boot in UEFI mode.

Post Reply

Return to “Installation & Boot”