Can't Get Easy BCD to Dual Boot LMDE on Win 7 Machine

All Gurus once were Newbies
Locked
gergnella
Level 1
Level 1
Posts: 2
Joined: Wed Jun 06, 2018 5:35 am

Can't Get Easy BCD to Dual Boot LMDE on Win 7 Machine

Post by gergnella » Tue Jun 19, 2018 5:49 am

I'm a Newbie wanting to dual Boot LMDE and Windows 7 Ultimate(64Bit).
Win 7 is installed on C drive Disc 0 as MBR and I installed successfully LMDE on a second HDD Disc 1.
LMDE runs well when I change the Boot order in UEFI(Bios) but when added to the MBR using Easy BCD,
on start up both choices are in the MBR and when LMDE is selected I get a GRUB> and LMDE won't boot.

I've exhausted all the processes on the net I can find on how to dual boot, both trying installing LMDE in a new partition on the same drive as Win 7
as well with the same result!!!

I would prefer to have LMDE on the separate HDD, Can anyone help me to set LMDE to get past the GRUB> page after selection in the MBR page?

User avatar
Pierre
Level 18
Level 18
Posts: 8794
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Can't Get Easy BCD to Dual Boot LMDE on Win 7 Machine

Post by Pierre » Tue Jun 19, 2018 5:56 am

if LMDE runs well when you change the Boot order in UEFI(Bios),
then that means that the Grub Loader is pointing to the correct partition - where the the LMDE system resides.

but when added to the MBR using Easy BCD,
on start up both choices are in the MBR and when LMDE is selected I get a GRUB> and LMDE won't boot.
- that means that the LMDE partition is incorrect in easyBCD menu / table
so the GRUB loader can't find the partition that the LMDE system resides upon.

it sounds as if the GRUB loader is on disc 0 when accessed by the easyBCD program,
but it's not being pointed to disc 1 where the LMDE system is residing ..
& so can't transfer the system to disc 1 for some reason.

what is the easyBCD settings giving as instructions ?.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

gergnella
Level 1
Level 1
Posts: 2
Joined: Wed Jun 06, 2018 5:35 am

Re: Can't Get Easy BCD to Dual Boot LMDE on Win 7 Machine

Post by gergnella » Wed Jun 20, 2018 5:19 am

Hi there and Thanks for the heip:
My Linux partitions are:
Partition Type O/S Mount point
1 fat32 EFI System /boot/efi
2 ext4 boot /boot
3 linux-swap Swap swap
4 ext4 LMDE 2 /root
5 ext4 Home /home

LMDE partition Manager would not proceed without creating the /boot/efi partition.

Easy BCD setting: Linux/BSD
Type - GRUB2
Name - LMDE
Drive - I've tried Automatic Locate and Load
Partitions 1 2 & 4
as well as Drive 0 (Windows 7) Partition 1 (bootmanager)
All combinations give the same result.

Locked

Return to “Newbie Questions”