fresh mint xfce 19 oem install boots to initramfs

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Dav3graph

fresh mint xfce 19 oem install boots to initramfs

Post by Dav3graph » Wed Jul 04, 2018 5:08 pm

I had 18.3 oem 64 bit install and it worked good. (stayed on the temporary user part)
Wanted to do a fresh OEM install for 19 64 bit and it keeps booting to busy box
have looked around and nothing that I have tried has worked
Able to use multibootusb drive to boot into live and also used it to do oem install
Using oem because I was working on this computer for a friend and they haven't picked it up yet. I've been using the Linux side and wanted to do an upgrade

This is a Sony Vaio core 2 duo with 4GB ram
Hard Drive is partitioned into
sda1 Windows recovery
sda2 windows
sda3 Extended
sda5 Mint
sda6 swap
here is a picture of what comes up when I try exit at initramfs

Code: Select all

System:    Host: mint Kernel: 4.15.0-20-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Sony product: VGN-NW125J v: C601FG7G serial: N/A
           Mobo: Sony model: VAIO serial: N/A
           BIOS: American Megatrends v: R0170Y4 date: 05/22/2009
Battery    BAT0: charge: 28.0 Wh 94.2% condition: 29.7/41.1 Wh (72%)
           model: Sony status: Charging
CPU:       Dual core Intel Core2 Duo T6500 (-MCP-) 
           arch: Penryn rev.10 cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3) bmips: 8372
           clock speeds: max: 2100 MHz 1: 1308 MHz 2: 1537 MHz
Graphics:  Card: Intel Mobile 4 Series Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.94hz
           OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express
           version: 2.1 Mesa 18.0.0-rc5 Direct Render: Yes
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card-1: Marvell 88E8057 PCI-E Gigabit Ethernet Controller
           driver: sky2 v: 1.30 port: d000 bus-ID: 01:00.0
           IF: enp1s0 state: down mac: <filter>
           Card-2: Intel WiFi Link 5100 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
Drives:    HDD Total Size: 328.1GB (2.4% used)
           ID-1: /dev/sda model: Hitachi_HTS54323 size: 320.1GB temp: 0C
           ID-2: USB /dev/sdb model: SanDisk_Cruzer size: 8.0GB temp: 0C
Partition: ID-1: / size: 1.9G used: 221M (12%) fs: overlay dev: N/A
           ID-2: swap-1 size: 4.13GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 56.0C mobo: 56.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 172 Uptime: 2:01 Memory: 1116.6/3786.5MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
           
20180704_161336.jpg

Reddog1
Level 3
Level 3
Posts: 144
Joined: Wed Jun 01, 2011 2:12 pm

Re: fresh mint xfce 19 oem install boots to initramfs

Post by Reddog1 » Sat Jul 07, 2018 2:33 am

I'll take a stab at the problem. This is from my notes when it happened to me with 18.3. Type:

(initramfs)exit

You might get a return resembling this:

/dev/sda1: Unexpected ......
fsck exited ........
The root filesystem on /dev/sda1 requires manual fsck

BusyBox v1.22 ......

(intramfs)

... means followed by a bunch of gobblydygook

Now, type the following command:

(intramfs)fsck /dev/sda1

NOTE: /dev/ is consistent. sda1 is delineated by the line above -- The root filesystem on /dev/sda1 requires a manual fsck

If that doesn't work I'm out of ideas.

User avatar
MrEen
Level 13
Level 13
Posts: 4554
Joined: Mon Jun 12, 2017 8:39 pm

Re: fresh mint xfce 19 oem install boots to initramfs

Post by MrEen » Sat Jul 07, 2018 3:30 am

I think you tried to install root somewhere incorrectly:
Partition: ID-1: / size: 1.9G used: 221M (12%) fs: overlay dev: N/A
Looks like you need to try the install again.

EDIT: Oops. Read that wrong. That's the live version.

Mute Ant
Level 14
Level 14
Posts: 5135
Joined: Tue Sep 03, 2013 7:45 pm
Location: Norfolk UK

Re: fresh mint xfce 19 oem install boots to initramfs

Post by Mute Ant » Sat Jul 07, 2018 4:11 am

I have no EFI system to test this, so not an answer, but interesting questions. What it looks like is GRUB has got the root file system wrong...
"...gave up waiting for the root file system device..."
Normally the root file system is specified with an ext4 UUID like...
root=UUID=3c61928a-9079-8246-d74b-4e25055cf7ef
What it was actually looking for was...
UUID=CCAE-E8C9
...which is typically a FAT file system ID used for EFI code. Something during the install seems to have caused a FAT partition to be specified as the OS root partition, which is plain wrong.
o Does that sound familiar? Did you have to specify the GRUB device? Might you have confused 'OS root device' with 'GRUB device'?
o Does the boot drive have an EFI partition? Has it been formatted or deleted after Mint was installed?
o Have you changed the boot mode in the BIOS? From EFI to MBR for example.
While you're waiting, read the free novel we sent you. It's a Spanish story about a guy named "manual".

franzag
Level 1
Level 1
Posts: 2
Joined: Mon Dec 31, 2018 7:06 pm

Re: fresh mint xfce 19 oem install boots to initramfs

Post by franzag » Mon Dec 31, 2018 7:25 pm

If you have problems with UUID and Grub just disable it.
go to /etc/default/grub and uncomment the line:
GRUB_DISABLE_LINUX_UUID=true
then do: sudo update-grub

dutchmans
Level 1
Level 1
Posts: 1
Joined: Thu Feb 28, 2019 9:40 am

Re: fresh mint xfce 19 oem install boots to initramfs

Post by dutchmans » Thu Feb 28, 2019 9:53 am

Try to edit the bootup config.
When going in the grub select linux mint startup and press "e", and search for a line that states uuid=CCAE-E8C9 (For other users the format is similar (xxx-xxxx) not a bigger string though).
Then remove it (the "uuid=xxxx-xxxx") for the time being and you should be able to log on.
The problem with your computer was that for some reason, the grub selected some other device that doesn't exist during installation to do something (maybe set that volume as boot, don't know too well the details though), so the next step should be fixing that, you should be able to look up how to change the grub settings online to not have to change this every time you want to log on, to do this you want to edit your grub.cfg on /boot/grub/ and in line 145 (probably) you will see root=uuid=xxxx-xxxx, now either remove root=... or change the uuid to the real uuid of the hard drive, wich should be in that same line or you can check it yourself with blkid command and set it to your hard drive partition (sda1 in my case) and that should be it.
TL;DR change some stuff in grub in loadup time then set persistence

Post Reply

Return to “Installation & Boot”