Many problems with Mint 19

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Level 2
Level 2
Posts: 96
Joined: Mon Jun 08, 2009 12:34 pm
Location: Near intersection of I-80 and I-57 in US

Many problems with Mint 19

Post by timmn1 » Wed Jul 18, 2018 1:50 pm

Moderator: I'm not sure what topic this fits in, so I'm putting it here, feel free to move it.

Sometimes Mint won't boot, all you get is a black screen, I took quiet splash out of grub to find out how far it got before it stopped, it doesn't look like grub even starts. I get the BIOS screen, and it then just turns black. If I restart the computer, sometimes Mint will boot, sometimes it won't. If it doesn't I will get the grub menu, if I choose advanced options and then recovery, then choose resume at the next two menus, Mint will boot into software mode. If I restart the computer, Mint will boot normally.

Firefox simply freezes from time to time, and the only way out is to restart the computer (see the first paragraph)
Other than that, it works great!
It works a bit better since I installed the 4.15.0-29-generic x86_64 kernel, but the problems still persist. I would really like to get it to work reliably but I can't even figure out where to start.

For those who are interested, here is the output from inxi -Fxz (when it has booted successfully)

Code: Select all

System:    Host: AB350M-D3H Kernel: 4.15.0-29-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1) Distro: Linux Mint 19 Tara
Machine:   Device: desktop System: Gigabyte product: AB350M-D3H serial: N/A
           Mobo: Gigabyte model: AB350M-D3H-CF v: x.x serial: N/A
           UEFI: American Megatrends v: F22 date: 03/15/2018
Battery    hidpp__0: charge: N/A condition: NA/NA Wh model: Logitech Wireless Mouse M510 status: Discharging
CPU:       Quad core AMD Ryzen 3 2200G with Radeon Vega Graphics (-MCP-) arch: Zen rev.0 cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 27953
           clock speeds: max: 3500 MHz 1: 1428 MHz 2: 1916 MHz 3: 1764 MHz 4: 1555 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Vega [Radeon Vega 8 Mobile] bus-ID: 07:00.0
           Display Server: x11 (X.Org 1.19.6 ) drivers: ati,amdgpu (unloaded: modesetting,fbdev,radeon,vesa)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: AMD RAVEN (DRM 3.23.0 / 4.15.0-29-generic, LLVM 6.0.0)
           version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] Device 15e3 driver: snd_hda_intel bus-ID: 07:00.6
           Card-2 Advanced Micro Devices [AMD/ATI] Device 15de driver: snd_hda_intel bus-ID: 07:00.1
           Sound: Advanced Linux Sound Architecture v: k4.15.0-29-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: f000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
           Card-2: Intel Wireless 8260 driver: iwlwifi bus-ID: 06:00.0
           IF: wlp6s0 state: up mac: <filter>
Drives:    HDD Total Size: 1000.2GB (2.3% used)
           ID-1: /dev/sda model: ST1000DX002 size: 1000.2GB
Partition: ID-1: / size: 916G used: 22G (3%) fs: ext4 dev: /dev/sda2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.2C mobo: N/A gpu: 0.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 220 Uptime: 26 min Memory: 1389.3/14975.7MB Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
Someday, maybe I'll figure out exactly what the hell I'm doing.

Level 17
Level 17
Posts: 7080
Joined: Thu Jun 21, 2018 5:11 pm

Re: Many problems with Mint 19

Post by gm10 » Wed Jul 18, 2018 1:55 pm

Frankly that sounds like a hardware failure or incompatibility with your UEFI (-settings). Bad PSU or memory can cause such things, for example.
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

User avatar
Level 20
Level 20
Posts: 12389
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)

Re: Many problems with Mint 19

Post by Pjotr » Wed Jul 18, 2018 1:56 pm

You might try this: check the support section of the website of the motherboard manufacturer, for an updated BIOS. When available, install it.
Tip: 10 things to do after installing Linux Mint 19.1 Tessa
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
All in all, horse sense simply makes sense.

User avatar
Level 7
Level 7
Posts: 1706
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Many problems with Mint 19

Post by thx-1138 » Wed Jul 18, 2018 2:03 pm have Ryzen 3 2200G with Vega. It's not completely supported yet.
Update your BIOS to the latest version, try out mainline 4.17.x, and be patient...

Check the links in my responses here (and search the forum for Ryzen & Vega as well...)

User avatar
Level 20
Level 20
Posts: 10674
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Many problems with Mint 19

Post by karlchen » Thu Jul 19, 2018 4:42 am

<moderator on> Split off and turned into a separate thead: My weird problems with Mint 19.1/xfce </moderator off>
Last edited by karlchen on Thu Jul 19, 2018 4:59 am, edited 1 time in total.
Reason: link fixed
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.22a 64-bit
Ubuntu 18.04.2 32-bit Mate Desktop, Total Commander 9.22a 32-bit
Windows? - 1 window in every room

Level 1
Level 1
Posts: 17
Joined: Sat Jul 07, 2018 6:35 pm

Re: Many problems with Mint 19

Post by olay1 » Mon Aug 06, 2018 10:48 am

try updating the bios and using the 4.18 rc4 kernel. It worked for me
Last edited by karlchen on Mon Aug 06, 2018 11:34 am, edited 1 time in total.
Reason: word without an "a": "kernel"

User avatar
Level 18
Level 18
Posts: 8674
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands

Re: Many problems with Mint 19

Post by Moem » Mon Aug 06, 2018 11:41 am

olay1 wrote:
Mon Aug 06, 2018 10:48 am
try updating the bios and using the 4.18 rc4 kernel. It worked for me
Do you have the exact same hardware as the OP?

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

Post Reply

Return to “Software & Applications”