[SOLVED] Mint 19 Does not Shut Down

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Dork Thirty
Level 1
Level 1
Posts: 35
Joined: Fri Jun 01, 2018 4:49 pm

[SOLVED] Mint 19 Does not Shut Down

Post by Dork Thirty » Tue Aug 07, 2018 4:52 pm

I've just installed Linux Mint 19 (Tara), Cinnamon, 64-bit. I'm using an ASUS ROG Strix Scar, 17", i7-8550H. Install went smoothly enough; I made a partition on the SSD for Mint and I didn't run into any display issues from the NVidia card or what have you.

I'm having two issues, but I'll make a separate post for the other. The major issue is this: the computer won't shut down. When I ask it to restart or shutdown it will start the process, then hang on the desktop with no pointer active and no keyboard controls. I have to do a hard shutdown. It starts up just fine after, but this is obviously incorrect.

I need the device for school/work (running CERN ROOT for "small" data sets), so I have to get this reconciled. Any ideas or direction? Thanks!
Last edited by Dork Thirty on Wed Aug 08, 2018 10:07 am, edited 1 time in total.

User avatar
Lord Boltar
Level 5
Level 5
Posts: 688
Joined: Mon Jan 09, 2017 7:24 pm
Location: Sunny Florida

Re: Mint 19 Does not Shut Down

Post by Lord Boltar » Tue Aug 07, 2018 5:06 pm

Have you tried to reboot or shutdown through the terminal? Does this work?

For shutdown:

sudo poweroff

For restart:

sudo reboot
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

Dork Thirty
Level 1
Level 1
Posts: 35
Joined: Fri Jun 01, 2018 4:49 pm

Re: Mint 19 Does not Shut Down

Post by Dork Thirty » Tue Aug 07, 2018 5:09 pm

Lord Boltar wrote:
Tue Aug 07, 2018 5:06 pm
Have you tried to reboot or shutdown through the terminal? Does this work?

For shutdown:

sudo poweroff

For restart:

sudo reboot
I tried sudo poweroff and everything just froze in place with no inputs active like before.

User avatar
Tomgin5
Level 5
Level 5
Posts: 933
Joined: Sat Mar 19, 2016 2:37 pm
Location: Beaverton, Oregon USA

Re: Mint 19 Does not Shut Down

Post by Tomgin5 » Tue Aug 07, 2018 5:25 pm

Just my 2 cents worth. Make sure the EUFI/ Bios is in Legacy mode and not active with Fast boot. 8 installs of LM 19 with no failures. ONLY Bios/EUFI issues. Some booted fine in EUFI but had issues (Like freezing). Some required a fresh install.

User avatar
Lord Boltar
Level 5
Level 5
Posts: 688
Joined: Mon Jan 09, 2017 7:24 pm
Location: Sunny Florida

Re: Mint 19 Does not Shut Down

Post by Lord Boltar » Tue Aug 07, 2018 5:41 pm

Have you updated the nVidia drivers yet by default Linux does not have nVidia drivers it uses nouveau drivers which work ok on older nVidia cards but not so great on newer ones

To add the Proprietary GPU Drivers PPA in Linux Mint and update the software sources in the terminal, use the following commands:

sudo add-apt-repository ppa:graphics-drivers/ppa

sudo apt update

Close terminal then open the Driver Manager and install latest nVidia drivers - then reboot hope this helps
Dork Thirty wrote:
Tue Aug 07, 2018 5:09 pm
Lord Boltar wrote:
Tue Aug 07, 2018 5:06 pm
Have you tried to reboot or shutdown through the terminal? Does this work?

For shutdown:

sudo poweroff

For restart:

sudo reboot
I tried sudo poweroff and everything just froze in place with no inputs active like before.
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

Dork Thirty
Level 1
Level 1
Posts: 35
Joined: Fri Jun 01, 2018 4:49 pm

Re: Mint 19 Does not Shut Down

Post by Dork Thirty » Tue Aug 07, 2018 6:23 pm

Tomgin5 wrote:
Tue Aug 07, 2018 5:25 pm
Just my 2 cents worth. Make sure the EUFI/ Bios is in Legacy mode and not active with Fast boot. 8 installs of LM 19 with no failures. ONLY Bios/EUFI issues. Some booted fine in EUFI but had issues (Like freezing). Some required a fresh install.
What's legacy mode, and how do I get into it?

Dork Thirty
Level 1
Level 1
Posts: 35
Joined: Fri Jun 01, 2018 4:49 pm

Re: Mint 19 Does not Shut Down

Post by Dork Thirty » Tue Aug 07, 2018 6:23 pm

Lord Boltar wrote:
Tue Aug 07, 2018 5:41 pm
Have you updated the nVidia drivers yet by default Linux does not have nVidia drivers it uses nouveau drivers which work ok on older nVidia cards but not so great on newer ones

To add the Proprietary GPU Drivers PPA in Linux Mint and update the software sources in the terminal, use the following commands:

sudo add-apt-repository ppa:graphics-drivers/ppa

sudo apt update

Close terminal then open the Driver Manager and install latest nVidia drivers - then reboot hope this helps
I'll give this a go. Would this cause shutdown issues?

Dork Thirty
Level 1
Level 1
Posts: 35
Joined: Fri Jun 01, 2018 4:49 pm

Re: Mint 19 Does not Shut Down

Post by Dork Thirty » Tue Aug 07, 2018 8:44 pm

Fixing the Nvidia drivers seems to have solved the problem. Thanks!

User avatar
Lord Boltar
Level 5
Level 5
Posts: 688
Joined: Mon Jan 09, 2017 7:24 pm
Location: Sunny Florida

Re: Mint 19 Does not Shut Down

Post by Lord Boltar » Wed Aug 08, 2018 12:20 am

Please mark this as Solved
Dork Thirty wrote:
Tue Aug 07, 2018 8:44 pm
Fixing the Nvidia drivers seems to have solved the problem. Thanks!
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

vladtepes
Level 3
Level 3
Posts: 171
Joined: Sat Feb 25, 2012 7:48 am
Location: Brisbane, Australia
Contact:

Re: Mint 19 Does not Shut Down

Post by vladtepes » Wed Aug 08, 2018 2:36 am

I've been experiencing a shutdown problem too, albeit slightly different.

Also LM19. i7 using onboard graphics ( no separate GPU).

If I choose power off it does.. then reboots and starts up again. So a power off does exactly the same as a restart.
Hard shutdown with power switch required.

Any ideas?
Keep Calm
and
Impale Your Enemies

alexis19apl
Level 1
Level 1
Posts: 3
Joined: Fri Aug 03, 2018 3:17 pm

Re: [SOLVED] Mint 19 Does not Shut Down

Post by alexis19apl » Mon Aug 13, 2018 10:10 pm

Hi Guys;

Experience the same "Graphic issue" of freezing on my i7 7700HQ with GTX 1050 de 4GB, decided to change everything on Bios and one thing was "Discrete" to "UMA" that I never used before in my life, this is what happens:
  • OS stop freezing
    OS now detects intel Graphics card.
So maybe there to possible root causes for the fail:

Bios setting "Discrete" create sort of Intel/Nvidia switchable usage based on system demand, that is not tuned for Linux.
Nvidia graphics have heavy issues with Linux and that makes the unstable graphical environment and that's why freeze.
Based on this, what options do I have? this is what i did:
  • sudo apt-get purge nvidia*
    sudo sh ~/Software/NVIDIA-Linux-*.run
    apt remove nvidia-current nvidia-settings
Then
  • sudo add-apt-repository ppa:graphics-drivers
    sudo apt-get update
    sudo apt-get install nvidia-390
    Restart
Even that still freeze when restart o shutdown, i did a fresh isntall with all this steps without success. Please please help me!

Russell55
Level 1
Level 1
Posts: 8
Joined: Wed Nov 21, 2018 7:20 am

Re: [SOLVED] Mint 19 Does not Shut Down

Post by Russell55 » Sat Dec 01, 2018 10:00 pm

Finally found & followed the above for removal & install of NVIDIA after 3.5 days of trying various processes and finally have a clean shutdown.
To all those having shutdown issues give this a go.
Many many thanks.

Post Reply

Return to “Newbie Questions”