Getting rid of overlay scrollbars

Forum rules
Before you post please read how to get help
Post Reply
Ascaris
Level 2
Level 2
Posts: 57
Joined: Sun Jun 19, 2016 11:56 pm

Getting rid of overlay scrollbars

Post by Ascaris » Thu Aug 09, 2018 2:42 pm

I just switched to Mint Xfce from Mint Cinnamon, and I would like to know how to get rid of the overlay scrollbars in the various "X" programs (Xed, Xreader, etc). I remember the setting in Cinnamon's Settings, but I can't find anything similar in Xfce. How do I get rid of these horrible things?
Main PC: Mint 18.3 Cinnamon & Windows 8.1/ Asus P8P67 Deluxe/i5-2500k @ 4.5Ghz
Laptop: Mint 19 Xfce/ Acer Swift 1 13.3"
Older laptop: Mint 19 Cinnamon & Windows 8.1/ Asus F8Sn with 8GB, SSD, GT220m GPU

User avatar
richyrich
Level 19
Level 19
Posts: 9051
Joined: Mon May 04, 2009 8:31 pm

Re: Getting rid of overlay scrollbars

Post by richyrich » Thu Aug 09, 2018 6:27 pm

Only places I know where it could be hiding is Menu > Settings > Appearance, or Menu > Settings > Window Manager.

Ascaris
Level 2
Level 2
Posts: 57
Joined: Sun Jun 19, 2016 11:56 pm

Re: Getting rid of overlay scrollbars

Post by Ascaris » Thu Aug 09, 2018 7:56 pm

Found the solution. It involves setting the environment variable GTK_OVERLAY_SCROLLING to 0.

https://forum.xfce.org/viewtopic.php?id=10881
Main PC: Mint 18.3 Cinnamon & Windows 8.1/ Asus P8P67 Deluxe/i5-2500k @ 4.5Ghz
Laptop: Mint 19 Xfce/ Acer Swift 1 13.3"
Older laptop: Mint 19 Cinnamon & Windows 8.1/ Asus F8Sn with 8GB, SSD, GT220m GPU

slavko
Level 1
Level 1
Posts: 30
Joined: Thu Mar 24, 2016 4:15 pm

Re: Getting rid of overlay scrollbars

Post by slavko » Mon Sep 10, 2018 6:15 am

I did what has been suggested, but it doesn't work for me. Is adding

Code: Select all

export GTK_OVERLAY_SCROLLING=0
to ~/.bashrc only thing you had to do? Are you using Mint 19 or Mint 18.x?
Mint 19 Xfce here.

User avatar
MrEen
Level 9
Level 9
Posts: 2588
Joined: Mon Jun 12, 2017 8:39 pm

Re: Getting rid of overlay scrollbars

Post by MrEen » Mon Sep 10, 2018 9:05 am

Hi slavko.

Have you tried logging out/in or rebooting since the change?

From the OP's signature, it appears they were using 19 as well.

slavko
Level 1
Level 1
Posts: 30
Joined: Thu Mar 24, 2016 4:15 pm

Re: Getting rid of overlay scrollbars

Post by slavko » Mon Sep 10, 2018 12:12 pm

MrEen wrote:
Mon Sep 10, 2018 9:05 am
Have you tried logging out/in or rebooting
Yes, of course, rebooted, but it was of no avail.

Neil Darlow
Level 2
Level 2
Posts: 50
Joined: Fri Aug 03, 2018 5:17 am

Re: Getting rid of overlay scrollbars

Post by Neil Darlow » Mon Sep 10, 2018 12:27 pm

Settings | Effects | Overlay scrollbars (logout required). Turn it off ... simples! :D
Linux Mint 19.1, Intel Core i5 8400 2.8GHz, ASUS Prime Z370-P, Corsair Vengeance 3400 16GB, ASUS Cerberus GTX1050 Ti, Samsung 970 Evo 500GB M.2, Western Digital Blue 4TB, Wircard RealTek 8821ae PCIe Wireless+Bluetooth 4.0, Pioneer BDR-209EBK BDRW.

slavko
Level 1
Level 1
Posts: 30
Joined: Thu Mar 24, 2016 4:15 pm

Re: Getting rid of overlay scrollbars

Post by slavko » Mon Sep 10, 2018 12:57 pm

Neil Darlow wrote:
Mon Sep 10, 2018 12:27 pm
Settings | Effects | Overlay scrollbars (logout required). Turn it off ... simples! :D
Yes... in Cinnamon, not so simple in Xfce.

User avatar
MrEen
Level 9
Level 9
Posts: 2588
Joined: Mon Jun 12, 2017 8:39 pm

Re: Getting rid of overlay scrollbars

Post by MrEen » Mon Sep 10, 2018 3:26 pm

See if the last post here helps.

User avatar
mint4all
Level 2
Level 2
Posts: 92
Joined: Tue Feb 13, 2018 1:16 pm

Re: Getting rid of overlay scrollbars

Post by mint4all » Tue Sep 11, 2018 7:56 pm

slavko wrote:
Mon Sep 10, 2018 12:12 pm
MrEen wrote:
Mon Sep 10, 2018 9:05 am
Have you tried logging out/in or rebooting
Yes, of course, rebooted, but it was of no avail.
Greetings!

Your problem is an old/standing issue. Its been discussed at length on the Xfce.org-forum, @ https://forum.xfce.org/viewtopic.php?pid=49672#p49672 ... My reply @ #9 describes what i did to kill those fade-in/-out scrollbars in the Mint-X & -Y themes (i assume that other GTK3-compliant themes have similar issues). Editing the "/etc/environment" file (as root) fixed my laptop's fresh LM19-xfce install. Credit is due: ultimately, the post on Arch's forum did the trick.

Good luck, M4A

slavko
Level 1
Level 1
Posts: 30
Joined: Thu Mar 24, 2016 4:15 pm

Re: Getting rid of overlay scrollbars

Post by slavko » Wed Sep 12, 2018 3:58 pm

AAAAAAAAH, what a relief! Finally, those pesky things are gone!

Thanks to all off you who offered help!

Now, to summarize, just for the record:
LM 19 Xfce, tried several things (all revolving around system variable GTK_OVERLAY_SCROLLING):

1. If I start program with:

Code: Select all

GTK_OVERLAY_SCROLLING=0 xed
it WORKS (that means NO overlay scrollbars).

2. If I set variable per user, by adding:

Code: Select all

export GTK_OVERLAY_SCROLLING=0
to ~/.bashrc then it DOESN'T WORK.

3. If I set variable globally, by adding:

Code: Select all

GTK_OVERLAY_SCROLLING=0
to /etc/environment then it WORKS, again.

Funny thing is, in both cases 2 and 3, export -p reports variable as set (with value "0"). Now, why in case 2 it doesn't work and in case 3 it works, is beyond my understanding.

BTW, in Cinnamon it's as simple as turning off one switch in Settings » Effects, In MATE it's already set (globally) to "0".

slavko
Level 1
Level 1
Posts: 30
Joined: Thu Mar 24, 2016 4:15 pm

Re: Getting rid of overlay scrollbars

Post by slavko » Wed Sep 12, 2018 4:06 pm

I'm not the OP, so I can't mark topic as "solved", but it should be marked, IMO.

User avatar
mint4all
Level 2
Level 2
Posts: 92
Joined: Tue Feb 13, 2018 1:16 pm

Re: Getting rid of overlay scrollbars

Post by mint4all » Thu Sep 13, 2018 11:48 am

Glad to see it working for you :D ... My humble answer to your 3 scenarios: it all has to do with a particular switch-setting's "scope" -- simply speaking, who "sets" the variable, and who "sees" it. If we exclude hacks & exploits for a moment, a "parent" process sets it, and a "child" process sees, ad infinitum (unless some rules restrictions get programmed in). Linux' process tree (Terminal > "pstree") demonstrates that scope, and its underlying rules for who can "see" the parent's settings ... In LM18 & 19, "systemd" is the grand-parent for xfce4-panel, and all the processes started from the panel inherit the parent's settings (aka "environment").

Your #1 scenario works just for that instance because it inherits from the panel, then you set a new variable, and your editor inherits from terminal+commandline; then it goes away when you close THAT terminal window.
Your #2 scenario fails because you are barred from modifying the parent's environment; if you could, every process could do so up the process tree and create chaos at any level including the great-parent's (that's the world of hacks and exploits);
Scenario #3 works because at all levels/tree branches because you, as root, modified the GLOBAL environment of the systemd grand-parent process BUT you had to reboot to make it effective; that's why all subsequent processes (after that reboot) now can see the new setting/variable and act accordingly.

Sidebar: I wished there was a global system flowchart for each DE, such as XFCE or MATE, so we all could comprehend better how it all hangs together ... "Security by obscurity", eh? I hate this way of piecing things together ... :(

User avatar
LinWinux
Level 4
Level 4
Posts: 267
Joined: Fri Aug 30, 2013 9:04 pm
Location: East Coast

Re: Getting rid of overlay scrollbars

Post by LinWinux » Fri Sep 28, 2018 12:05 pm

mint4all wrote:
Thu Sep 13, 2018 11:48 am
Sidebar: I wished there was a global system flowchart for each DE, such as XFCE or MATE, so we all could comprehend better how it all hangs together ... "Security by obscurity", eh? I hate this way of piecing things together ... :(
Yup, I agree with that 100 percent. :)

This is a very helpful post, bound to be beneficial to others, so yeah, marking it solved could be even more helpful.

Greetings from Overseas ...

.
PLEASE ... Don't respond to questions with meaningless or thoughtless comments!
PLEASE ... Help others, don't be lazy! Take a moment to mark your post SOLVED if you received a solution.

Post Reply

Return to “Xfce”