<SOLVED> Gufw Firewall Stopped Working LM19

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Joe2Shoe
Level 4
Level 4
Posts: 429
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

<SOLVED> Gufw Firewall Stopped Working LM19

Post by Joe2Shoe » Sat Aug 11, 2018 4:20 pm

Gufw firewall stopped working in LM19 4.15.0.30 kernel. When I click the Firewall icon on the Menu/Preferences, I enter password, then nothing.
If I enter the Terminal and type:
$ gufw
Traceback (most recent call last):
File "/usr/share/gufw/gufw/gufw.py", line 21, in <module>
from gufw.view.gufw import Gufw
File "/usr/share/gufw/gufw/gufw/view/gufw.py", line 18, in <module>
import gi
ModuleNotFoundError: No module named 'gi'

I reverted to kernel 4.15.0.29, same issue.
I uninstalled ufw & gufw, re-booted, reinstalled both, re-booted, same issue.

$ inxi -Fxz
System: Host: Latitude-D620 Kernel: 4.15.0-29-generic x86_64
bits: 64 gcc: 7.3.0
Desktop: MATE 1.20.1 (Gtk 3.22.30-1ubuntu1)
Distro: Linux Mint 19 Tara
Machine: Device: portable System: Dell product: Latitude D620 serial: N/A
Mobo: Dell model: N/A serial: N/A
BIOS: Dell v: A10 date: 05/16/2008
Battery BAT0: charge: 48.8 Wh 149.8% condition: 32.6/48.8 Wh (67%)
model: Sanyo DELL 62 status: Full
CPU: Dual core Intel Core2 T7600 (-MCP-)
arch: Conroe rev.6 cache: 4096 KB
flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 9320
clock speeds: max: 2333 MHz 1: 1475 MHz 2: 1429 MHz
Graphics: Card: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller
bus-ID: 00:02.0
Display Server: x11 (X.Org 1.19.6 )
drivers: intel (unloaded: modesetting,fbdev,vesa)
Resolution: 1280x800@60.00hz
OpenGL: renderer: Mesa DRI Intel 945GM
version: 1.4 Mesa 18.0.5 Direct Render: Yes
Audio: Card Intel NM10/ICH7 Family High Def. Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.15.0-29-generic
Network: Card-1: Broadcom Limited NetXtreme BCM5752 Gigabit Ethernet PCIE
driver: tg3 v: 3.137 bus-ID: 09:00.0
IF: enp9s0 state: down mac: <filter>
Card-2: Intel PRO/Wireless 3945ABG [Golan] Network Connection
driver: iwl3945 v: in-tree:s bus-ID: 0c:00.0
IF: wlp12s0 state: up mac: <filter>
Drives: HDD Total Size: 1000.2GB (50.4% used)
ID-1: /dev/sda model: HGST_HTS721010A9 size: 1000.2GB
Partition: ID-1: / size: 30G used: 14G (48%) fs: ext4 dev: /dev/sda6
ID-2: /home size: 46G used: 5.5G (13%) fs: ext4 dev: /dev/sda8
ID-3: /boot size: 969M used: 288M (32%) fs: ext4 dev: /dev/sda5
ID-4: swap-1 size: 9.00GB used: 0.00GB (0%)
fs: swap dev: /dev/sda7
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 60.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 169 Uptime: 5 min Memory: 784.1/3244.4MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56

I don't know what happened.
If anyone has any suggestions, they are all greatly appreciated.
Thanks in advance.
Last edited by Joe2Shoe on Sat Aug 11, 2018 8:10 pm, edited 1 time in total.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

gm10
Level 17
Level 17
Posts: 7084
Joined: Thu Jun 21, 2018 5:11 pm

Re: Gufw Firewall Stopped Working LM19

Post by gm10 » Sat Aug 11, 2018 4:50 pm

Try

Code: Select all

apt install --reinstall gufw python3-gi
(I know you said you already re-installed it - humour me)

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 429
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Gufw Firewall Stopped Working LM19

Post by Joe2Shoe » Sat Aug 11, 2018 5:27 pm

Reinstalled per your suggestion. Still does not load. Same error message.
So, I uninstalled ufw and gufw.
Installed firewalld.
All is well.
Thanks for your help.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

gm10
Level 17
Level 17
Posts: 7084
Joined: Thu Jun 21, 2018 5:11 pm

Re: Gufw Firewall Stopped Working LM19

Post by gm10 » Sat Aug 11, 2018 5:34 pm

Fair enough. Note that if we didn't fix it by just reinstalling python3-gi you might potentially run into the same error with other applications that use the same python library that went bad. We might have to re-visit this then (probably needs purging before re-installing and/or we need to re-install the dependencies, too).

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 429
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: <SOLVED> Gufw Firewall Stopped Working LM19

Post by Joe2Shoe » Mon Aug 13, 2018 9:23 pm

gm10, Thanks again. I did autoremove & --purge ufw & gufw before reinstalling both, but reinstalled python3-gi, because uninstalling it and reinstalling would have taken over 30 apps out, etc.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

Post Reply

Return to “Software & Applications”