Manually set xed text editor preferences

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Envrin
Level 1
Level 1
Posts: 1
Joined: Sun Aug 12, 2018 4:47 pm

Manually set xed text editor preferences

Post by Envrin » Sun Aug 12, 2018 4:59 pm

Just got Linux Mint 19 setup and running on my new laptop, and as per-usual the default text editor is xed, which I want to keep using as I'm used to it.

However, I unfortunately went blind a couple years ago, and the Edit->Preferences menu within text editor is unreadable by the Orca screen reader. I can hear the toggle buttons, but can't read what I'm toggling.

Where is the xed preferences file? Or are there any commands that let me change the preferences via terminal? I just want by default to not use word-wrap, and to treat the tab key as a tab and not 4 spaces.

If I could get those two preferences changed via terminal or by modifying a prefs file somewhere, I would be forever greateful. Thanks in advance.

User avatar
smurphos
Level 8
Level 8
Posts: 2254
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Manually set xed text editor preferences

Post by smurphos » Mon Aug 13, 2018 1:10 am

Use tab as tab

gsettings set org.x.editor.preferences.editor insert-spaces false

Turn off word wrap

gsettings set org.x.editor.preferences.editor wrap-mode 'none'

JosephM
Level 6
Level 6
Posts: 1086
Joined: Sun May 26, 2013 6:25 pm

Re: Manually set xed text editor preferences

Post by JosephM » Tue Aug 14, 2018 5:12 am

However, I unfortunately went blind a couple years ago, and the Edit->Preferences menu within text editor is unreadable by the Orca screen reader. I can hear the toggle buttons, but can't read what I'm toggling.
Is it the menu or the actual preferences window that don't work with Orca? Sounds like something I should look in to. We get very little feedback regarding this sort of thing so often don't even realize people are having issues.
When I give opinions, they are my own. Not necessarily those of any other Linux Mint developer or the Linux Mint project as a whole.

Post Reply

Return to “Newbie Questions”