[SOLVED] Files copied to Samba share don't quite inherit the proper permissions

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
gene0915
Level 3
Level 3
Posts: 124
Joined: Sun Oct 26, 2014 7:52 pm

[SOLVED] Files copied to Samba share don't quite inherit the proper permissions

Post by gene0915 » Sun Aug 12, 2018 9:51 pm

SOLVED: The two things I changed was to move the "create mask = 0775" and "directory mask = 0775" to the Global section of Samba.conf and I changed both to 0777.

Lets say I have the following files on a Windows box:

c:\test\1.txt
c:\test\2.txt
c:\test\subfolder\3.txt
c:\test\subfolder\4.txt

When I copy these to my Samba share in Mint (v19), the files and folders are re-created perfectly but the permissions are a bit messed up. File 1.txt and 2.txt will be owned by (gene:gene) and have RW access for 'gene' user and 'gene' group but the files in the sub-folders will have RW access for user 'gene' but for group 'gene', they will be copied over as 'read only' for group access.

Here is my Samba.conf file. In it, I'm forcing user:group to gene for both and files/folders as 0775. Umask is currently 0022 if that matters.

Side note. Last week, I made a donation to the Mint team. I remember seeing something about how I'll be emailed instructions to do something (edit my user profile?!) to show that I've donated. It said if I don't receive those instructions in a couple of days, to email ______________ . I never received those instructions and I forget the address I'm suppose to email if I didn't receive anything. :( Does anyone know that email address?

Thanks

Code: Select all

#
# Sample configuration file for the Samba suite for Debian GNU/Linux.
#
#
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options most of which 
# are not shown in this example
#
# Some options that are often worth tuning have been included as
# commented-out examples in this file.
#  - When such options are commented with ";", the proposed setting
#    differs from the default Samba behaviour
#  - When commented with "#", the proposed setting is the default
#    behaviour of Samba but the option is considered important
#    enough to be mentioned here
#
# NOTE: Whenever you modify this file you should run the command
# "testparm" to check that you have not made any basic syntactic 
# errors. 

#======================= Global Settings =======================

[global]
   domain master = yes
   preferred master = yes
   local master = yes
   force user = gene
   force group = gene

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = WORKGROUP

# server string is the equivalent of the NT Description field
	server string = %h server (Samba, Ubuntu)

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
#   wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
   dns proxy = no

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
;   interfaces = 127.0.0.0/8 eth0

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine is
# not protected by a firewall or is a firewall itself.  However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
;   bind interfaces only = yes



#### Debugging/Accounting ####

# This tells Samba to use a separate log file for each machine
# that connects
   log file = /var/log/samba/log.%m

# Cap the size of the individual log files (in KiB).
   max log size = 1000

# If you want Samba to only log through syslog then set the following
# parameter to 'yes'.
#   syslog only = no

# We want Samba to log a minimum amount of information to syslog. Everything
# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
# through syslog you should set the following parameter to something higher.
   syslog = 0

# Do something sensible when Samba crashes: mail the admin a backtrace
   panic action = /usr/share/samba/panic-action %d


####### Authentication #######

# Server role. Defines in which mode Samba will operate. Possible
# values are "standalone server", "member server", "classic primary
# domain controller", "classic backup domain controller", "active
# directory domain controller". 
#
# Most people will want "standalone sever" or "member server".
# Running as "active directory domain controller" will require first
# running "samba-tool domain provision" to wipe databases and create a
# new domain.
   server role = standalone server

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using.  
   passdb backend = tdbsam

   obey pam restrictions = yes

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
   unix password sync = yes

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
# sending the correct chat script for the passwd program in Debian Sarge).
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
   pam password change = yes

# This option controls how unsuccessful authentication attempts are mapped
# to anonymous connections
   map to guest = bad user

########## Domains ###########

#
# The following settings only takes effect if 'server role = primary
# classic domain controller', 'server role = backup domain controller'
# or 'domain logons' is set 
#

# It specifies the location of the user's
# profile directory from the client point of view) The following
# required a [profiles] share to be setup on the samba server (see
# below)
;   logon path = \\%N\profiles\%U
# Another common choice is storing the profile in the user's home directory
# (this is Samba's default)
#   logon path = \\%N\%U\profile

# The following setting only takes effect if 'domain logons' is set
# It specifies the location of a user's home directory (from the client
# point of view)
;   logon drive = H:
#   logon home = \\%N\%U

# The following setting only takes effect if 'domain logons' is set
# It specifies the script to run during logon. The script must be stored
# in the [netlogon] share
# NOTE: Must be store in 'DOS' file format convention
;   logon script = logon.cmd

# This allows Unix users to be created on the domain controller via the SAMR
# RPC pipe.  The example command creates a user account with a disabled Unix
# password; please adapt to your needs
; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u

# This allows machine accounts to be created on the domain controller via the 
# SAMR RPC pipe.  
# The following assumes a "machines" group exists on the system
; add machine script  = /usr/sbin/useradd -g machines -c "%u machine account" -d /var/lib/samba -s /bin/false %u

# This allows Unix groups to be created on the domain controller via the SAMR
# RPC pipe.  
; add group script = /usr/sbin/addgroup --force-badname %g

############ Misc ############

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
;   include = /home/samba/etc/smb.conf.%m

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
;   idmap uid = 10000-20000
;   idmap gid = 10000-20000
;   template shell = /bin/bash

# Setup usershare options to enable non-root users to share folders
# with the net usershare command.

# Maximum number of usershare. 0 (default) means that usershare is disabled.
;   usershare max shares = 100

# Allow users who've been granted usershare privileges to create
# public shares, not just authenticated ones
   usershare allow guests = yes

#======================= Share Definitions =======================

# Un-comment the following (and tweak the other settings below to suit)
# to enable the default home directory shares. This will share each
# user's home directory as \\server\username
;[homes]
;   comment = Home Directories
;   browseable = no

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
;   read only = yes

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
   create mask = 0775

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
   directory mask = 0775

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server.
# Un-comment the following parameter to make sure that only "username"
# can connect to \\server\username
# This might need tweaking when using external authentication schemes
;   valid users = %S

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;[netlogon]
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   read only = yes

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;[profiles]
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700

[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no
# Uncomment to allow remote administration of Windows print drivers.
# You may need to replace 'lpadmin' with the name of the group your
# admin users are members of.
# Please note that you also need to set appropriate Unix permissions
# to the drivers directory for these users to have write rights in it
;   write list = root, @lpadmin
Last edited by gene0915 on Tue Aug 14, 2018 9:39 am, edited 1 time in total.

deepakdeshp
Level 10
Level 10
Posts: 3489
Joined: Sun Aug 09, 2015 10:00 am

Re: Files copied to Samba share don't quite inherit the proper permissions

Post by deepakdeshp » Mon Aug 13, 2018 6:20 am

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

altair4
Level 19
Level 19
Posts: 9148
Joined: Tue Feb 03, 2009 10:27 am

Re: Files copied to Samba share don't quite inherit the proper permissions

Post by altair4 » Mon Aug 13, 2018 7:26 am

The question I have for you is why does it matter? The reason you used "force user" in the first place was to make it so everyone ( server user and all client users ) act as one - in this case gene.

EDIT: For future reference:

When you post a samba question and want to display how you are set up post the output of both commands:

Code: Select all

testparm -s

Code: Select all

net usershare info --long
You need the second output because you have no shares defined in smb.conf as you are using nemo to create them.

When I first read through your smb.conf I missed the part where you set the create masks operatives. I missed them because you have them in the wrong spot - from a flow standpoint. testparm would have shown them as [global] operatives where they should be.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

gene0915
Level 3
Level 3
Posts: 124
Joined: Sun Oct 26, 2014 7:52 pm

Re: Files copied to Samba share don't quite inherit the proper permissions

Post by gene0915 » Mon Aug 13, 2018 9:12 am

I think the takeaway for me was to use 0777?

gene0915
Level 3
Level 3
Posts: 124
Joined: Sun Oct 26, 2014 7:52 pm

Re: Files copied to Samba share don't quite inherit the proper permissions

Post by gene0915 » Mon Aug 13, 2018 9:18 am

altair4 wrote:
Mon Aug 13, 2018 7:26 am
The question I have for you is why does it matter? The reason you used "force user" in the first place was to make it so everyone ( server user and all client users ) act as one - in this case gene.

EDIT: For future reference:

When you post a samba question and want to display how you are set up post the output of both commands:

Code: Select all

testparm -s

Code: Select all

net usershare info --long
You need the second output because you have no shares defined in smb.conf as you are using nemo to create them.

When I first read through your smb.conf I missed the part where you set the create masks operatives. I missed them because you have them in the wrong spot - from a flow standpoint. testparm would have shown them as [global] operatives where they should be.
As requested:

Code: Select all

Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: The "syslog" option is deprecated
Processing section "[printers]"
Processing section "[print$]"
Loaded services file OK.
Server role: ROLE_STANDALONE

# Global parameters
[global]
	dns proxy = No
	domain master = Yes
	log file = /var/log/samba/log.%m
	map to guest = Bad User
	max log size = 1000
	obey pam restrictions = Yes
	pam password change = Yes
	panic action = /usr/share/samba/panic-action %d
	passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
	passwd program = /usr/bin/passwd %u
	preferred master = Yes
	server role = standalone server
	server string = %h server (Samba, Ubuntu)
	syslog = 0
	unix password sync = Yes
	usershare allow guests = Yes
	idmap config * : backend = tdb
	create mask = 0777
	directory mask = 0777
	force group = gene
	force user = gene


[printers]
	browseable = No
	comment = All Printers
	create mask = 0700
	path = /var/spool/samba
	printable = Yes


[print$]
	comment = Printer Drivers
	path = /var/lib/samba/printers
And

Code: Select all

gene@server-pc:~$ net usershare info --long
[SSD Backup]
path=/mnt/md0/SSD Backup
comment=
usershare_acl=Everyone:F,
guest_ok=y

[gene backup]
path=/mnt/md0/gene backup
comment=
usershare_acl=Everyone:F,
guest_ok=y

[TV Shows]
path=/mnt/md0/TV Shows
comment=
usershare_acl=Everyone:R,Unix User\gene:F,
guest_ok=y

[Movies]
path=/mnt/md0/Movies
comment=
usershare_acl=Everyone:R,Unix User\gene:F,
guest_ok=y

[Movie requests]
path=/mnt/md0/Movie requests
comment=
usershare_acl=Everyone:R,Unix User\gene:F,
guest_ok=y

[Home Movies]
path=/mnt/md0/Home Movies
comment=
usershare_acl=Everyone:R,Unix User\gene:F,
guest_ok=y

[Friends]
path=/mnt/md0/Friends
comment=
usershare_acl=Everyone:R,Unix User\gene:F,
guest_ok=y

[Classic TV]
path=/mnt/md0/Classic TV
comment=
usershare_acl=Everyone:R,Unix User\gene:F,
guest_ok=y

[nintendo]
path=/mnt/md0/nintendo
comment=
usershare_acl=Everyone:F,
guest_ok=y

[marinaresume]
path=/mnt/md0/marinaresume
comment=
usershare_acl=Everyone:F,
guest_ok=y

[Pictures]
path=/mnt/md0/Pictures
comment=
usershare_acl=Everyone:R,Unix User\gene:F,
guest_ok=y

[marinabackup2]
path=/mnt/md0/marina backup 2
comment=
usershare_acl=Everyone:F,
guest_ok=y

[marinabackup]
path=/mnt/md0/marina backup
comment=
usershare_acl=Everyone:F,
guest_ok=y

[ally backup]
path=/mnt/md0/ally backup
comment=
usershare_acl=Everyone:F,
guest_ok=y

[crap]
path=/mnt/md0/crap
comment=
usershare_acl=Everyone:F,
guest_ok=y
I went ahead and moved the mask stuff into Global and switched it to 0777. I think the reason they were originally where they were is because when I was editing the Samba.conf file, I found the settings in their default? location and just removed the semi-colon and set them to 0775. I re-started smbd and nmbd. Will test when I get home.

Thanks for the help!

altair4
Level 19
Level 19
Posts: 9148
Joined: Tue Feb 03, 2009 10:27 am

Re: Files copied to Samba share don't quite inherit the proper permissions

Post by altair4 » Mon Aug 13, 2018 9:30 am

My original observation still stands. You are using force user = gene All users local and network will act as gene.

What difference does it make if the group permissions allow or don't allow write?
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

gene0915
Level 3
Level 3
Posts: 124
Joined: Sun Oct 26, 2014 7:52 pm

Re: Files copied to Samba share don't quite inherit the proper permissions

Post by gene0915 » Mon Aug 13, 2018 10:07 am

altair4 wrote:
Mon Aug 13, 2018 9:30 am
My original observation still stands. You are using force user = gene All users local and network will act as gene.

What difference does it make if the group permissions allow or don't allow write?
In the scenario I typed above, files that were being deposited into sub-folders from Windows machines were coming over as ready only for the group (gene). This was causing some issues with scripts I have running that are responsible for moving files around. I'll see if the changes I just made correct things tonight.

When a Windows box deposits anything onto the Samba shares, I want those folders/sub-folders/files in sub-folders to all have rwxrwxrw- permissions as they are copied over and be wide open on the Linux box and editable/delete-able by any process (or any user).

deepakdeshp
Level 10
Level 10
Posts: 3489
Joined: Sun Aug 09, 2015 10:00 am

Re: Files copied to Samba share don't quite inherit the proper permissions

Post by deepakdeshp » Mon Aug 13, 2018 10:40 am

gene0915 wrote:
Mon Aug 13, 2018 9:12 am
I think the takeaway for me was to use 0777?
That's correct.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

altair4
Level 19
Level 19
Posts: 9148
Joined: Tue Feb 03, 2009 10:27 am

Re: Files copied to Samba share don't quite inherit the proper permissions

Post by altair4 » Mon Aug 13, 2018 11:55 am

I created a test share on Mint19 Cinnamon which looks like this:
[Test]
path = /home/tester/Test
read only = No
force user = tester
force group = tester
guest ok = yes
create mask = 0775
directory mask = 0775
I then added files from Linux and from Win10 into that share and into a subfolder in that share.

Here are the results of permissions in the share itself:
tester@vmint19cinn:~$ ls -l /home/tester/Test
total 4
-rwxrw-r-- 1 tester tester 0 Aug 13 11:27 fromLinux.txt
-rwxrw-r-- 1 tester tester 0 Aug 13 11:41 fromWin10.txt
drwxr-xr-x 2 tester tester 4096 Aug 13 11:41 Subfolder
And here are the results in the Subfolder:
tester@vmint19cinn:~$ ls -l /home/tester/Test/Subfolder
total 0
-rwxrw-r-- 1 tester tester 0 Aug 13 11:27 fromLinux.txt
-rwxrw-r-- 1 tester tester 0 Aug 13 11:41 fromWin10.txt
In both cases the added files have the forced owner and group and permissions are rw to group.

In short I cannot reproduce your symptoms.

Note: should I change the masks to 0777 all it would do is add rw to other:
tester@vmint19cinn:~$ ls -l /home/tester/Test/Subfolder
total 0
-rwxrw-r-- 1 tester tester 0 Aug 13 11:27 fromLinux.txt
-rwxrw-rw- 1 tester tester 0 Aug 13 11:48 fromWin10-2.txt
-rwxrw-r-- 1 tester tester 0 Aug 13 11:41 fromWin10.txt
Either way the file is rw to group.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Post Reply

Return to “Newbie Questions”